aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-15 22:08:36 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-16 18:31:05 +0000
commite44d8d345dc327e379b6dc6e1fe6d6daa8fd1da7 (patch)
tree66e47c328f520125f5f2330933d1b802a8394888 /security
parent6664a69db4711435aaea44b8840c108ea63d2763 (diff)
downloadports-e44d8d345dc327e379b6dc6e1fe6d6daa8fd1da7.tar.gz
ports-e44d8d345dc327e379b6dc6e1fe6d6daa8fd1da7.zip
security/openconnect-gui: fix build ahead of CMake 3.20
The use of --build and --target is more strict in CMake 3.20, and it looks like it needs to be specified explicitly in more cases than before when dealing with externals. Avoid --target install though because that will install /wrkdirs into stage, which makes a big mess.
Diffstat (limited to 'security')
-rw-r--r--security/openconnect-gui/Makefile1
-rw-r--r--security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake6
2 files changed, 5 insertions, 2 deletions
diff --git a/security/openconnect-gui/Makefile b/security/openconnect-gui/Makefile
index ff6694804f92..c10e07402774 100644
--- a/security/openconnect-gui/Makefile
+++ b/security/openconnect-gui/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openconnect-gui
PORTVERSION= 1.5.3
+PORTREVISION= 1
DISTVERSIONPREFIX=v
MASTER_SITES= https://gitlab.com/openconnect/openconnect-gui/-/archive/v${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake
index 3604ecf590cc..78ae0a73d2dc 100644
--- a/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake
+++ b/security/openconnect-gui/files/patch-CMake_Includes_ProjectExternals__qt-solutions.cmake
@@ -1,6 +1,6 @@
--- CMake/Includes/ProjectExternals_qt-solutions.cmake.orig 2018-03-25 21:49:15 UTC
+++ CMake/Includes/ProjectExternals_qt-solutions.cmake
-@@ -9,10 +9,7 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
+@@ -9,11 +9,9 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
UPDATE_DISCONNECTED 0
UPDATE_COMMAND ""
@@ -10,9 +10,11 @@
-
+ SOURCE_DIR ${CMAKE_BINARY_DIR}/external/src/qt-solutions-master
BUILD_IN_SOURCE 1
++ BUILD_COMMAND ${CMAKE_COMMAND} --build .
PATCH_COMMAND ${CMAKE_COMMAND} -E copy_if_different
-@@ -21,14 +18,14 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
+ ${CMAKE_SOURCE_DIR}/CMake/Includes/CMakeLists_qt-solutions.cmake.in
+@@ -21,14 +19,14 @@ ExternalProject_Add(qt-solutions-${qt-solutions-TAG}
CMAKE_COMMAND ${CMAKE_CROSS_COMMAND} -DCMAKE_OSX_DEPLOYMENT_TARGET=${CMAKE_OSX_DEPLOYMENT_TARGET}
# Note: ninja-1.8.2 & cmake-3.10.2 failed in find/install this dependency wo next 2 lines :(