aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-02-29 17:11:11 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-02-29 17:11:11 +0000
commitf350bae837ee928584509227809ee461ac153f83 (patch)
treecebe89d4c7bdbb3fcfd9ad655095cd052a2c1491 /security
parentf1bbaead08fcb6672ac147910e3a6b6f0926bf45 (diff)
downloadports-f350bae837ee928584509227809ee461ac153f83.tar.gz
ports-f350bae837ee928584509227809ee461ac153f83.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-acme-tiny/Makefile33
-rw-r--r--security/py-acme-tiny/distinfo2
-rw-r--r--security/py-acme-tiny/files/pkg-message.in6
-rw-r--r--security/py-acme-tiny/pkg-descr7
5 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 753e9271c092..5550debd80c0 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -812,6 +812,7 @@
SUBDIR += py-scrypt
SUBDIR += py-SecretStorage
SUBDIR += py-acme
+ SUBDIR += py-acme-tiny
SUBDIR += py-artifacts
SUBDIR += py-bcrypt
SUBDIR += py-borg.localrole
diff --git a/security/py-acme-tiny/Makefile b/security/py-acme-tiny/Makefile
new file mode 100644
index 000000000000..04abf2b355e1
--- /dev/null
+++ b/security/py-acme-tiny/Makefile
@@ -0,0 +1,33 @@
+# Created by: mat
+# $FreeBSD$
+
+PORTNAME= acme-tiny
+PORTVERSION= 0.0.g.2015.12.29
+CATEGORIES= security python
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Tiny script to issue and renew TLS certs from Let's Encrypt
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_OPENSSL= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= diafygi
+GH_TAGNAME= f61f72c
+
+SUB_FILES= pkg-message
+NO_BUILD= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/acme_tiny ${DOCSDIR}/README.md
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/acme_tiny.py ${STAGEDIR}${PREFIX}/bin/acme_tiny
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-acme-tiny/distinfo b/security/py-acme-tiny/distinfo
new file mode 100644
index 000000000000..6747a3906791
--- /dev/null
+++ b/security/py-acme-tiny/distinfo
@@ -0,0 +1,2 @@
+SHA256 (diafygi-acme-tiny-0.0.g.2015.12.29-f61f72c_GH0.tar.gz) = d19a427cf1ed037e74b479536ddcc9f2c77c277421956ca5a7bbcee606d07839
+SIZE (diafygi-acme-tiny-0.0.g.2015.12.29-f61f72c_GH0.tar.gz) = 10470
diff --git a/security/py-acme-tiny/files/pkg-message.in b/security/py-acme-tiny/files/pkg-message.in
new file mode 100644
index 000000000000..328b19380520
--- /dev/null
+++ b/security/py-acme-tiny/files/pkg-message.in
@@ -0,0 +1,6 @@
+===========================================================================
+
+Have a look at the README.md file in the documentation directory:
+%%DOCSDIR%%
+
+===========================================================================
diff --git a/security/py-acme-tiny/pkg-descr b/security/py-acme-tiny/pkg-descr
new file mode 100644
index 000000000000..b5f030f89bd6
--- /dev/null
+++ b/security/py-acme-tiny/pkg-descr
@@ -0,0 +1,7 @@
+This is a tiny, auditable script that you can throw on your server to issue and
+renew Let's Encrypt certificates. Since it has to be run on your server and
+have access to your private Let's Encrypt account key, I tried to make it as
+tiny as possible (currently less than 200 lines). The only prerequisites are
+python and openssl.
+
+WWW: https://github.com/diafygi/acme-tiny