aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-11-18 12:22:20 +0000
committerRene Ladan <rene@FreeBSD.org>2020-11-18 12:22:20 +0000
commitf4130f4ab20c5286aa2f327235ab6b38f2dd86d8 (patch)
treeaa684f00d4126e7cb562bae512ded0dcbfe6a69b /security
parentc414aaedfa15e7c4c919d9cb8a598ee20c3df335 (diff)
downloadports-f4130f4ab20c5286aa2f327235ab6b38f2dd86d8.tar.gz
ports-f4130f4ab20c5286aa2f327235ab6b38f2dd86d8.zip
Notes
Diffstat (limited to 'security')
-rw-r--r--security/sudo/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index b52c72c2f62c..376c86a59e2b 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-rundir=/var/run/sudo
OPTIONS_DEFINE= LDAP INSULTS DISABLE_ROOT_SUDO DISABLE_AUTH NOARGS_SHELL \
- AUDIT OPIE PAM PYTHON NLS DOCS EXAMPLES
+ AUDIT OPIE PAM PYTHON NLS SSSD DOCS EXAMPLES
OPTIONS_RADIO= KERBEROS
OPTIONS_DEFAULT= AUDIT PAM
OPTIONS_SUB= yes
@@ -42,6 +42,7 @@ AUDIT_DESC= Enable BSM audit support
KERBEROS_DESC= Enable Kerberos 5 authentication (no PAM support)
OPIE_DESC= Enable one-time passwords (no PAM support)
PYTHON_DESC= Enable python plugin support
+SSSD_DESC= Enable SSSD backend support.
PAM_PREVENTS= OPIE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
PAM_PREVENTS_MSG= PAM cannot be combined with any other authentication plugin
@@ -77,6 +78,8 @@ PAM_CONFIGURE_ON= --with-pam
OPIE_CONFIGURE_ON= --with-opie
PYTHON_USES= python
PYTHON_CONFIGURE_ENABLE= python
+SSSD_CONFIGURE_ON= --with-sssd
+SSSD_RUN_DEPENDS= sssd:security/sssd
OPTIONS_RADIO_KERBEROS= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
GSSAPI_BASE_USES= gssapi