aboutsummaryrefslogtreecommitdiff
path: root/shells/44bsd-csh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:06:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:06:49 +0000
commit5159bbe33c9803ac71ff808185ebd02658adf130 (patch)
tree207767eab1df95eab4939c6be4f113d030d40e40 /shells/44bsd-csh
parentb18fcf42b601f30cf979241273959f051161e61c (diff)
downloadports-5159bbe33c9803ac71ff808185ebd02658adf130.tar.gz
ports-5159bbe33c9803ac71ff808185ebd02658adf130.zip
- Support stage
- Remove condition around the rcs build depends: What ever the version of FreeBSD is it will only pulls in rcs from ports if and only if rcs is not in base.
Notes
Notes: svn path=/head/; revision=337644
Diffstat (limited to 'shells/44bsd-csh')
-rw-r--r--shells/44bsd-csh/Makefile26
-rw-r--r--shells/44bsd-csh/pkg-plist1
2 files changed, 8 insertions, 19 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
index 14ef43912b59..5131f03b9ac7 100644
--- a/shells/44bsd-csh/Makefile
+++ b/shells/44bsd-csh/Makefile
@@ -12,16 +12,11 @@ COMMENT= The traditional 4.4BSD /bin/csh C-shell
USE_BZIP2= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 1000055
-BUILD_DEPENDS= rcs:${PORTSDIR}/devel/rcs57
-.endif
+BUILD_DEPENDS= rcs:${PORTSDIR}/devel/rcs57
NO_WRKSUBDIR= yes
-MAN1= 44bsd-csh.1
PORTDOCS= paper.ascii.gz
-NO_STAGE= yes
+
post-extract:
cd ${WRKSRC} ; co RCS/*,v; chmod u+w *
cd ${WRKSRC}/USD.doc ; co RCS/*,v
@@ -30,20 +25,13 @@ post-build:
cd ${WRKSRC}/USD.doc ; ${MAKE}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/csh ${PREFIX}/bin/44bsd-csh
- ${INSTALL_MAN} ${WRKSRC}/csh.1 ${PREFIX}/man/man1/44bsd-csh.1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/USD.doc/paper.ascii.gz ${DOCSDIR}
-.endif
- @${ECHO_MSG} "Updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @(${GREP} -v ${PREFIX}/bin/44bsd-csh /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/44bsd-csh) > /etc/shells
- @${RM} /etc/shells.bak
+ ${INSTALL_PROGRAM} ${WRKSRC}/csh ${STAGEDIR}${PREFIX}/bin/44bsd-csh
+ ${INSTALL_MAN} ${WRKSRC}/csh.1 ${STAGEDIR}${PREFIX}/man/man1/44bsd-csh.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/USD.doc/paper.ascii.gz ${STAGEDIR}${DOCSDIR}
tarup:
cd ${WRKSRC} ; rm * USD.doc/*
cd ${WRKSRC} ; ${TAR} cvyf /tmp/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/44bsd-csh/pkg-plist b/shells/44bsd-csh/pkg-plist
index f70d1ad837e2..2cc066b3ecb2 100644
--- a/shells/44bsd-csh/pkg-plist
+++ b/shells/44bsd-csh/pkg-plist
@@ -1,3 +1,4 @@
bin/44bsd-csh
+man/man1/44bsd-csh.1.gz
@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells