aboutsummaryrefslogtreecommitdiff
path: root/shells/44bsd-csh
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-04-15 04:26:42 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-04-15 04:26:42 +0000
commitd441f311ef7913a8cef211a8eaa6cdaa0a982210 (patch)
tree3115f5d8e80ea6db5a1705eb7c48aaabf832d2db /shells/44bsd-csh
parent72869f98d7ccd3a9185005bd51d7bf8fb6db32d3 (diff)
downloadports-d441f311ef7913a8cef211a8eaa6cdaa0a982210.tar.gz
ports-d441f311ef7913a8cef211a8eaa6cdaa0a982210.zip
This is the the traditional 4.4BSD /bin/csh C-shell, with additional
FreeBSD fixes and updates since 4.4BSD Lite was released.
Notes
Notes: svn path=/head/; revision=27577
Diffstat (limited to 'shells/44bsd-csh')
-rw-r--r--shells/44bsd-csh/Makefile46
-rw-r--r--shells/44bsd-csh/distinfo1
-rw-r--r--shells/44bsd-csh/pkg-comment1
-rw-r--r--shells/44bsd-csh/pkg-descr2
-rw-r--r--shells/44bsd-csh/pkg-plist4
5 files changed, 54 insertions, 0 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
new file mode 100644
index 000000000000..b19b156dc9ea
--- /dev/null
+++ b/shells/44bsd-csh/Makefile
@@ -0,0 +1,46 @@
+# ex:ts=8
+# Ports collection makefile for: csh
+# Date created: 23 January 2000
+# Whom: David O'Brien <obrien@NUXI.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 44bsd-csh
+PORTVERSION= 20000409
+CATEGORIES= shells
+MASTER_SITES= http://people.freebsd.org/~obrien/
+
+MAINTAINER= obrien@FreeBSD.org
+
+USE_BZIP2= yes
+
+NO_WRKSUBDIR= yes
+MAN1= 44bsd-csh.1
+
+post-extract:
+ cd ${WRKSRC} ; co RCS/*,v
+ cd ${WRKSRC}/USD.doc ; co RCS/*,v
+
+post-build:
+ cd ${WRKSRC}/USD.doc ; ${MAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/csh ${PREFIX}/bin/44bsd-csh
+ ${INSTALL_MAN} ${WRKSRC}/csh.1 ${PREFIX}/man/man1/44bsd-csh.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/44bsd-csh
+ ${INSTALL_MAN} ${WRKSRC}/USD.doc/paper.ascii.gz \
+ ${PREFIX}/share/doc/44bsd-csh
+.endif
+ @${ECHO} "Updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/tcsh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/tcsh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+tarup:
+ cd ${WRKSRC} ; rm * USD.doc/*
+ cd ${WRKSRC} ; tar cvyf /tmp/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+.include <bsd.port.mk>
diff --git a/shells/44bsd-csh/distinfo b/shells/44bsd-csh/distinfo
new file mode 100644
index 000000000000..33cf112924a6
--- /dev/null
+++ b/shells/44bsd-csh/distinfo
@@ -0,0 +1 @@
+MD5 (44bsd-csh-20000409.tar.bz2) = 427a55482f86629401fdb3a27809dfb4
diff --git a/shells/44bsd-csh/pkg-comment b/shells/44bsd-csh/pkg-comment
new file mode 100644
index 000000000000..f388e37661ae
--- /dev/null
+++ b/shells/44bsd-csh/pkg-comment
@@ -0,0 +1 @@
+the traditional 4.4BSD /bin/csh C-shell
diff --git a/shells/44bsd-csh/pkg-descr b/shells/44bsd-csh/pkg-descr
new file mode 100644
index 000000000000..c60360228855
--- /dev/null
+++ b/shells/44bsd-csh/pkg-descr
@@ -0,0 +1,2 @@
+This is the the traditional 4.4BSD /bin/csh C-shell, with additional
+FreeBSD fixes and updates since 4.4BSD Lite was released.
diff --git a/shells/44bsd-csh/pkg-plist b/shells/44bsd-csh/pkg-plist
new file mode 100644
index 000000000000..90d27221dd46
--- /dev/null
+++ b/shells/44bsd-csh/pkg-plist
@@ -0,0 +1,4 @@
+bin/44bsd-csh
+share/doc/44bsd-csh/paper.ascii.gz
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells