aboutsummaryrefslogtreecommitdiff
path: root/shells/ast-ksh
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2023-12-05 23:27:25 +0000
committerBrooks Davis <brooks@FreeBSD.org>2023-12-11 18:54:34 +0000
commitc35a419ccf030333c50808944ea171a8daaa8886 (patch)
tree1ed82afcc82af53a4beb2b724c5515465fe1dedb /shells/ast-ksh
parent73540e281dfc639b0937cf7512e60a6a69f83ef5 (diff)
downloadports-c35a419ccf030333c50808944ea171a8daaa8886.tar.gz
ports-c35a419ccf030333c50808944ea171a8daaa8886.zip
shells/ast-ksh: fix a typo, mark broken on 15
This is broken due to a new compiler on 14 so presumably also on 15. PR: 275647 Approved by: Marcin Cieślak <saper@saper.info> (maintainer) Sponsored by: DARPA
Diffstat (limited to 'shells/ast-ksh')
-rw-r--r--shells/ast-ksh/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/shells/ast-ksh/Makefile b/shells/ast-ksh/Makefile
index c7a4300d896e..c0057efca9a4 100644
--- a/shells/ast-ksh/Makefile
+++ b/shells/ast-ksh/Makefile
@@ -22,7 +22,8 @@ LICENSE= EPL
BROKEN_aarch64= Fails to compile: needs sbrk
BROKEN_riscv64= Fails to compile: ast-ksh93v/src/lib/libast/hash/hashalloc.c:162:4: non-const lvalue reference to type '__builtin_va_list' cannot bind to a temporary of type 'va_list'
-BROKEN_FreeBSD_14= Fails to compilt: error: incompatible function pointer types assigning to 'int (*)(wchar_t *, const char *, size_t)' (aka 'int (*)(int *, const char *, unsigned long)') from 'size_t (wchar_t *, const char *, size_t)' (aka 'unsigned long (int *, const char *, unsigned long)') [-Wincompatible-function-pointer-types]
+BROKEN_FreeBSD_14= Fails to compile: error: incompatible function pointer types assigning to 'int (*)(wchar_t *, const char *, size_t)' (aka 'int (*)(int *, const char *, unsigned long)') from 'size_t (wchar_t *, const char *, size_t)' (aka 'unsigned long (int *, const char *, unsigned long)') [-Wincompatible-function-pointer-types]
+BROKEN_FreeBSD_15= ${BROKEN_FreeBSD_14}
USES= compiler:c11