aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-01-17 07:17:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-01-17 07:17:24 +0000
commitc8b267ee81fdbaf603d5062bb1d2957c25839699 (patch)
tree0cb21b3d4206811dcfe2dcb3dfc2820f75406369 /shells/bash-completion
parent0e4f32f06d44c1166cf750182928f1d5c7fd1ba8 (diff)
downloadports-c8b267ee81fdbaf603d5062bb1d2957c25839699.tar.gz
ports-c8b267ee81fdbaf603d5062bb1d2957c25839699.zip
Add support for WITH_BASH_DEVEL=yes to depend on shells/bash-devel.
Also, use MDOCS.
Notes
Notes: svn path=/head/; revision=310540
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 53079dec32c3..4f7da7b60f0d 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -12,7 +12,11 @@ MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
+.if defined(WITH_BASH_DEVEL)
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
+.else
RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
+.endif
CONFLICTS= bash-completion-classic-[0-9]*
@@ -25,6 +29,8 @@ SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
PORTDOCS= *
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
@@ -42,7 +48,7 @@ post-patch:
${WRKSRC}/completions/*
post-install:
-.if !defined(WITHOUT_DOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for i in README doc/bash_completion.txt doc/bashrc doc/inputrc
${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}