aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-01-20 16:22:17 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-01-20 16:22:17 +0000
commitdb418ff1643e7003dfa31e4ab2688d8e4ac0188f (patch)
treea30d4b19671916b6a5ce134a4148a0fd8ed006f0 /shells/bash-completion
parent7efc3b05a531c86685adc82f79d2284dd71e96e5 (diff)
downloadports-db418ff1643e7003dfa31e4ab2688d8e4ac0188f.tar.gz
ports-db418ff1643e7003dfa31e4ab2688d8e4ac0188f.zip
Add a patch to fix tab on an empty line producing:
$ bash: words: bad array subscript PR: 196713 Submitted by: gnudalf@yandex.com Obtained from: upstream bug #1289597
Notes
Notes: svn path=/head/; revision=377528
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile2
-rw-r--r--shells/bash-completion/files/patch-bash__completion11
2 files changed, 12 insertions, 1 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 8c866c8d7fb4..6cca80d7a307 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bash-completion
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
diff --git a/shells/bash-completion/files/patch-bash__completion b/shells/bash-completion/files/patch-bash__completion
new file mode 100644
index 000000000000..6e6d95fa1a68
--- /dev/null
+++ b/shells/bash-completion/files/patch-bash__completion
@@ -0,0 +1,11 @@
+--- bash_completion.orig 2015-01-20 16:17:24 UTC
++++ bash_completion
+@@ -707,7 +707,7 @@ _init_completion()
+ fi
+ done
+
+- [[ $cword -eq 0 ]] && return 1
++ [[ $cword -le 0 ]] && return 1
+ prev=${words[cword-1]}
+
+ [[ ${split-} ]] && _split_longopt && split=true