aboutsummaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-08-10 19:32:19 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-08-10 19:32:19 +0000
commit764c05e57acb0657b5fd9c9c1aa19ad7051e8a8a (patch)
treebc5a3cc6b145d79269039c3ecbf5cf6ff7da75e2 /shells/bash
parente4dd95b91a6ad25d347f9897919e72e1abb2751a (diff)
downloadports-764c05e57acb0657b5fd9c9c1aa19ad7051e8a8a.tar.gz
ports-764c05e57acb0657b5fd9c9c1aa19ad7051e8a8a.zip
Notes
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile2
-rw-r--r--shells/bash/files/patch-braces.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 6934c16e2180..567a2d564228 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bash
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/
diff --git a/shells/bash/files/patch-braces.c b/shells/bash/files/patch-braces.c
new file mode 100644
index 000000000000..591d58ef3888
--- /dev/null
+++ b/shells/bash/files/patch-braces.c
@@ -0,0 +1,15 @@
+#
+# Fix nested brace vs. variable expansion
+#
+# http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00056.html
+#
+--- braces.c.orig Tue Aug 04 14:32:33 2004
++++ braces.c Tue Aug 04 15:15:36 2004
+@@ -402,6 +402,7 @@
+ {
+ pass_next = 1;
+ i++;
++ level++;
+ continue;
+ }
+ #endif