aboutsummaryrefslogtreecommitdiff
path: root/shells/fish/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-09-07 18:53:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-09-07 18:53:49 +0000
commitc5b7922a720aaba84ac9ad857e03e15975cf72d0 (patch)
treed6c957e40725ee9bd2c3561101212a0d7e5225c6 /shells/fish/Makefile
parent07e62b8b794883689c41cc58f1d25db4a57a03e4 (diff)
downloadports-c5b7922a720aaba84ac9ad857e03e15975cf72d0.tar.gz
ports-c5b7922a720aaba84ac9ad857e03e15975cf72d0.zip
Notes
Diffstat (limited to 'shells/fish/Makefile')
-rw-r--r--shells/fish/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 7daeb0be2c5b..193924953b5f 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fish
-PORTVERSION= 2.2.0
+PORTVERSION= 2.3.1
CATEGORIES= shells
MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
@@ -11,15 +11,13 @@ COMMENT= User friendly command line shell
LICENSE= GPLv2
-USES= autoreconf cpe gmake iconv ncurses pkgconfig pathfix
+USES= autoreconf cpe gmake libtool ncurses pkgconfig pathfix python:3 localbase
+
GNU_CONFIGURE= yes
CPE_VENDOR= fishshell
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread ${ICONV_LIB}
-
-PORTDOCS= *
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
MANDIRS= ${DATADIR}/man/man1
OPTIONS_DEFINE= DOCS NLS
@@ -45,7 +43,7 @@ post-patch:
s|ncurses.h||' ${WRKSRC}/configure.ac
post-install:
-.for i in fish fish_indent mimedb
+.for i in fish fish_indent fish_key_reader
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
.endfor