aboutsummaryrefslogtreecommitdiff
path: root/shells/fish
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2017-02-09 00:09:59 +0000
committerAlan Somers <asomers@FreeBSD.org>2017-02-09 00:09:59 +0000
commit339de38ec07f0d0077671049b6c0d1513a01920d (patch)
treef0506c6bc0aa8fd9dcdcd33500e2f98a0c6fcc38 /shells/fish
parent90cb6e2745656045fb53e4a12a796a7a16baac0d (diff)
downloadports-339de38ec07f0d0077671049b6c0d1513a01920d.tar.gz
ports-339de38ec07f0d0077671049b6c0d1513a01920d.zip
Fix two bugs in shells/fish
1) The build would fail when DOCS=off (PR 216167) 2) Tab completion doesn't work for "mount -t" (PR 216032) PR: 216167 PR: 216032 Reported by: Maxfx <maficccc@gmail.com> Reported by: David Guyot <david.guyot@europecamions-interactive.com> Approved by: brd (ports)
Notes
Notes: svn path=/head/; revision=433701
Diffstat (limited to 'shells/fish')
-rw-r--r--shells/fish/Makefile1
-rw-r--r--shells/fish/files/extra-patch-Makefile.in30
-rw-r--r--shells/fish/files/patch-share_functions_____fish__print__filesystems.fish11
3 files changed, 27 insertions, 15 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index d6c7da07f253..ec206d10c4cd 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fish
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
diff --git a/shells/fish/files/extra-patch-Makefile.in b/shells/fish/files/extra-patch-Makefile.in
index 64e5fd416a38..83ab3bc29588 100644
--- a/shells/fish/files/extra-patch-Makefile.in
+++ b/shells/fish/files/extra-patch-Makefile.in
@@ -1,21 +1,21 @@
---- ./Makefile.in.orig 2013-10-19 22:10:26.000000000 +0200
-+++ ./Makefile.in 2014-01-25 02:35:57.000000000 +0100
-@@ -639,12 +639,12 @@
+--- Makefile.in.orig 2017-01-17 16:12:49 UTC
++++ Makefile.in
+@@ -701,12 +701,12 @@ install-force: all install-translations
true; \
done;
-
-- $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
-- for i in user_doc/html/* ChangeLog; do \
+ @echo "Installing online user documentation";
+- $v $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
+- $v for i in user_doc/html/* CHANGELOG.md; do \
- if test -f $$i; then \
- $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
- fi; \
- done;
-+# $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
-+# for i in user_doc/html/* ChangeLog; do \
-+# if test -f $$i; then \
-+# $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
-+# fi; \
-+# done;
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
- for i in $(MANUALS); do \
- $(INSTALL) -m 644 $$i $(DESTDIR)$(mandir)/man1/; \
++# $v $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
++# $v for i in user_doc/html/* CHANGELOG.md; do \
++# if test -f $$i; then \
++# $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
++# fi; \
++# done;
+ @echo "Installing more man pages";
+ $v $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1;
+ $v for i in $(MANUALS); do \
diff --git a/shells/fish/files/patch-share_functions_____fish__print__filesystems.fish b/shells/fish/files/patch-share_functions_____fish__print__filesystems.fish
new file mode 100644
index 000000000000..9c8b7b183788
--- /dev/null
+++ b/shells/fish/files/patch-share_functions_____fish__print__filesystems.fish
@@ -0,0 +1,11 @@
+--- share/functions/__fish_print_filesystems.fish.orig 2017-01-13 15:45:46 UTC
++++ share/functions/__fish_print_filesystems.fish
+@@ -4,6 +4,6 @@ function __fish_print_filesystems -d "Pr
+ set fs $fs hfs hpfs iso9660 jfs minix msdos ncpfs nfs ntfs proc qnx4 ramfs
+ set fs $fs reiserfs romfs smbfs sysv tmpfs udf ufs umsdos vfat xenix xfs xiafs
+ # Mount has helper binaries to mount filesystems
+- # These are called mount.* and are placed somewhere in $PATH
+- printf "%s\n" $fs (string replace -ra ".*/mount." "" -- $PATH/mount.*)
++ # These are called mount_* and are placed somewhere in $PATH
++ printf "%s\n" $fs (string replace -ra ".*/mount_" "" -- $PATH/mount_*)
+ end