aboutsummaryrefslogtreecommitdiff
path: root/shells/fish
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-25 02:40:17 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-25 02:40:17 +0000
commit5c9573a6ed6b278537a9f3223436f3a33ed6874d (patch)
treef695e03448eeae6e71ef8b2152401ffdc17de590 /shells/fish
parenta4674e6a09e17719bef95bf56c9605659ed3ec86 (diff)
downloadports-5c9573a6ed6b278537a9f3223436f3a33ed6874d.tar.gz
ports-5c9573a6ed6b278537a9f3223436f3a33ed6874d.zip
- Add licenses (GPLv2)
- Fix DOCS Option, add extra-patch-Makefile.in Reviewed by: horia
Notes
Notes: svn path=/head/; revision=340982
Diffstat (limited to 'shells/fish')
-rw-r--r--shells/fish/Makefile8
-rw-r--r--shells/fish/files/extra-patch-Makefile.in21
2 files changed, 29 insertions, 0 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 086c0a288836..62affd5452be 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
MAINTAINER= nemysis@FreeBSD.org
COMMENT= User friendly command line shell
+LICENSE= GPLv2
+
USES= gmake iconv
USE_AUTOTOOLS= autoconf
@@ -24,6 +26,8 @@ NLS_USES= gettext
NLS_CONFIGURE_ENV= ac_cv_func_gettext=yes
NLS_CONFIGURE_OFF= --without-gettext
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
'/^all:/s|user_doc|| ; \
@@ -37,6 +41,10 @@ post-patch:
s|ncurses curses|curses| ; \
s|ncurses.h||' ${WRKSRC}/configure.ac
+.if ! ${PORT_OPTIONS:MDOCS}
+EXTRA_PATCHES+=${FILESDIR}/extra-patch-Makefile.in
+.endif
+
post-install:
.for i in fish fish_indent fish_pager fishd mimedb
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
diff --git a/shells/fish/files/extra-patch-Makefile.in b/shells/fish/files/extra-patch-Makefile.in
new file mode 100644
index 000000000000..64e5fd416a38
--- /dev/null
+++ b/shells/fish/files/extra-patch-Makefile.in
@@ -0,0 +1,21 @@
+--- ./Makefile.in.orig 2013-10-19 22:10:26.000000000 +0200
++++ ./Makefile.in 2014-01-25 02:35:57.000000000 +0100
+@@ -639,12 +639,12 @@
+ true; \
+ done;
+
+- $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
+- for i in user_doc/html/* ChangeLog; do \
+- if test -f $$i; then \
+- $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
+- fi; \
+- done;
++# $(INSTALL) -m 755 -d $(DESTDIR)$(docdir)
++# for i in user_doc/html/* ChangeLog; do \
++# if test -f $$i; then \
++# $(INSTALL) -m 644 $$i $(DESTDIR)$(docdir); \
++# fi; \
++# done;
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ for i in $(MANUALS); do \
+ $(INSTALL) -m 644 $$i $(DESTDIR)$(mandir)/man1/; \