aboutsummaryrefslogtreecommitdiff
path: root/shells/fish
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2018-12-31 21:38:49 +0000
committerAlan Somers <asomers@FreeBSD.org>2018-12-31 21:38:49 +0000
commita19d295cdab56fce3498f392a0efbb066672fa17 (patch)
tree0884fb7271f92138007efb3d6268f397ac7d092d /shells/fish
parent9311d7abf2945354aca2ec71902fb33d452dee39 (diff)
downloadports-a19d295cdab56fce3498f392a0efbb066672fa17.tar.gz
ports-a19d295cdab56fce3498f392a0efbb066672fa17.zip
shells/fish: upgrade to 3.0.0
This also switches the build system from autoconf to cmake, and adds an on-by-default MANPAGES option. MANPAGES are now optional because building them requires doxygen. PR: 234493 Reviewed by: koobs Approved by: koobs (ports)
Notes
Notes: svn path=/head/; revision=488840
Diffstat (limited to 'shells/fish')
-rw-r--r--shells/fish/Makefile37
-rw-r--r--shells/fish/distinfo6
-rw-r--r--shells/fish/files/patch-cmake_Install.cmake20
-rw-r--r--shells/fish/files/patch-src_common.h11
-rw-r--r--shells/fish/files/patch-src_wgetopt.h11
-rw-r--r--shells/fish/pkg-plist295
6 files changed, 211 insertions, 169 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index e1a05759e3de..b89f358b99af 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= fish
-PORTVERSION= 2.7.0
+PORTVERSION= 3.0.0
CATEGORIES= shells
-MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
+MASTER_SITES= https://github.com/fish-shell/fish-shell/releases/download/${PORTVERSION}/
MAINTAINER= asomers@FreeBSD.org
COMMENT= User friendly command line shell
@@ -13,42 +13,35 @@ LICENSE= GPLv2
LIB_DEPENDS+= libpcre2-32.so:devel/pcre2
-USES= autoreconf cpe gmake libtool ncurses pkgconfig pathfix python:3.4+ \
+# The python dependency is only needed by shebangfix. At runtime python is
+# only needed by some optional scripts that aren't in PATH.
+USES= cmake cpe ncurses python:3.4+:build \
localbase compiler:c++11-lang shebangfix
+
SHEBANG_FILES= share/tools/*.py share/tools/web_config/webconfig.py
CONFLICTS_INSTALL= comms/mlan3
-GNU_CONFIGURE= yes
-
CPE_VENDOR= fishshell
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
MANDIRS= ${DATADIR}/man/man1
-OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFAULT= MANPAGES DOCS NLS
+OPTIONS_DEFINE= MANPAGES DOCS NLS
OPTIONS_SUB= yes
+DOCS_BUILD_DEPENDS+= doxygen:devel/doxygen
+MANPAGES_BUILD_DEPENDS+= doxygen:devel/doxygen
NLS_USES= gettext
-NLS_CONFIGURE_ENV= ac_cv_func_gettext=yes
-NLS_CONFIGURE_OFF= --without-gettext
-
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^all:/s|user_doc|| ; \
- s| "$$(HAVE_GETTEXT)" = 1| x$$(HAVE_GETTEXT) = x1| ; \
- s| $$(HAVE_GETTEXT) = 1| x$$(HAVE_GETTEXT) = x1| ; \
- s|$$(DESTDIR)$$(bindir)/fish|$$(bindir)/fish|g' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
- 's|-rdynamic|-Wl,--export-dynamic| ; \
- /pthread_create/d ; \
- s|ncurses curses|curses| ; \
- s|ncurses.h||' ${WRKSRC}/configure.ac
+NLS_CMAKE_BOOL= WITH_GETTEXT
post-install:
.for i in fish fish_indent fish_key_reader
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}
.endfor
+post-stage-MANPAGES-off:
+ @${RM} -rf ${STAGEDIR}${MANPREFIX}/man/man1
+ @${RM} -rf ${STAGEDIR}${DATADIR}/man
+
.include <bsd.port.mk>
diff --git a/shells/fish/distinfo b/shells/fish/distinfo
index c9a7a2b60da3..1e17446b5619 100644
--- a/shells/fish/distinfo
+++ b/shells/fish/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513008736
-SHA256 (fish-2.7.0.tar.gz) = 3a76b7cae92f9f88863c35c832d2427fb66082f98e92a02203dc900b8fa87bcb
-SIZE (fish-2.7.0.tar.gz) = 5760470
+TIMESTAMP = 1546108347
+SHA256 (fish-3.0.0.tar.gz) = ea9dd3614bb0346829ce7319437c6a93e3e1dfde3b7f6a469b543b0d2c68f2cf
+SIZE (fish-3.0.0.tar.gz) = 6472393
diff --git a/shells/fish/files/patch-cmake_Install.cmake b/shells/fish/files/patch-cmake_Install.cmake
new file mode 100644
index 000000000000..ed75de06a5ce
--- /dev/null
+++ b/shells/fish/files/patch-cmake_Install.cmake
@@ -0,0 +1,20 @@
+--- cmake/Install.cmake.orig 2018-12-29 16:18:12 UTC
++++ cmake/Install.cmake
+@@ -113,7 +113,7 @@ INSTALL(FILES share/config.fish
+ # -$v $(INSTALL) -m 755 -d $(DESTDIR)$(extra_completionsdir)
+ # -$v $(INSTALL) -m 755 -d $(DESTDIR)$(extra_functionsdir)
+ # -$v $(INSTALL) -m 755 -d $(DESTDIR)$(extra_confdir)
+-FISH_CREATE_DIRS(${rel_datadir}/pkgconfig)
++FISH_CREATE_DIRS(${rel_datadir}/../libdata/pkgconfig)
+ # Don't try too hard to create these directories as they may be outside our writeable area
+ # https://github.com/Homebrew/homebrew-core/pull/2813
+ FISH_TRY_CREATE_DIRS(${extra_completionsdir} ${extra_functionsdir} ${extra_confdir})
+@@ -132,7 +132,7 @@ ADD_CUSTOM_COMMAND(OUTPUT fish.pc
+ ADD_CUSTOM_TARGET(build_fish_pc ALL DEPENDS fish.pc)
+
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/fish.pc
+- DESTINATION ${rel_datadir}/pkgconfig)
++ DESTINATION ${rel_datadir}/../libdata/pkgconfig)
+
+ # @echo "Installing the $(bo)fish completion library$(sgr0)...";
+ # $v $(INSTALL) -m 644 $(COMPLETIONS_DIR_FILES:%='%') $(DESTDIR)$(datadir)/fish/completions/
diff --git a/shells/fish/files/patch-src_common.h b/shells/fish/files/patch-src_common.h
deleted file mode 100644
index b544112bdbe7..000000000000
--- a/shells/fish/files/patch-src_common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/common.h.orig 2018-01-26 20:48:40 UTC
-+++ src/common.h
-@@ -658,7 +658,7 @@ wcstring vformat_string(const wchar_t *format, va_list
- void append_format(wcstring &str, const wchar_t *format, ...);
- void append_formatv(wcstring &str, const wchar_t *format, va_list ap);
-
--#ifdef __cpp_lib_make_unique
-+#if __cplusplus >= 201402L
- using std::make_unique;
- #else
- /// make_unique implementation
diff --git a/shells/fish/files/patch-src_wgetopt.h b/shells/fish/files/patch-src_wgetopt.h
deleted file mode 100644
index c819be768835..000000000000
--- a/shells/fish/files/patch-src_wgetopt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/wgetopt.h.orig 2017-12-11 21:47:12 UTC
-+++ src/wgetopt.h
-@@ -177,7 +177,7 @@ struct woption {
- int *flag;
- /// If \c flag is non-null, this is the value that flag will be set to. Otherwise, this is the
- /// return-value of the function call.
-- int val;
-+ wchar_t val;
- };
-
- // Names for the values of the `has_arg' field of `struct option'.
diff --git a/shells/fish/pkg-plist b/shells/fish/pkg-plist
index 71b9053239b4..c9a8c8fd607f 100644
--- a/shells/fish/pkg-plist
+++ b/shells/fish/pkg-plist
@@ -3,38 +3,16 @@ bin/fish_indent
bin/fish_key_reader
%%ETCDIR%%/config.fish
libdata/pkgconfig/fish.pc
-man/man1/fish.1.gz
-man/man1/fish_indent.1.gz
-man/man1/fish_key_reader.1.gz
+%%MANPAGES%%man/man1/fish.1.gz
+%%MANPAGES%%man/man1/fish_indent.1.gz
+%%MANPAGES%%man/man1/fish_key_reader.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.md
%%PORTDOCS%%%%DOCSDIR%%/ascii_fish.png
-%%PORTDOCS%%%%DOCSDIR%%/bc_s.png
-%%PORTDOCS%%%%DOCSDIR%%/bdwn.png
-%%PORTDOCS%%%%DOCSDIR%%/closed.png
%%PORTDOCS%%%%DOCSDIR%%/commands.html
%%PORTDOCS%%%%DOCSDIR%%/design.html
-%%PORTDOCS%%%%DOCSDIR%%/doc.png
-%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/faq.html
-%%PORTDOCS%%%%DOCSDIR%%/folderclosed.png
-%%PORTDOCS%%%%DOCSDIR%%/folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/jquery.js
%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/nav_f.png
-%%PORTDOCS%%%%DOCSDIR%%/nav_g.png
-%%PORTDOCS%%%%DOCSDIR%%/nav_h.png
-%%PORTDOCS%%%%DOCSDIR%%/open.png
-%%PORTDOCS%%%%DOCSDIR%%/pages.html
-%%PORTDOCS%%%%DOCSDIR%%/splitbar.png
-%%PORTDOCS%%%%DOCSDIR%%/sync_off.png
-%%PORTDOCS%%%%DOCSDIR%%/sync_on.png
-%%PORTDOCS%%%%DOCSDIR%%/tab_a.png
-%%PORTDOCS%%%%DOCSDIR%%/tab_b.png
-%%PORTDOCS%%%%DOCSDIR%%/tab_h.png
-%%PORTDOCS%%%%DOCSDIR%%/tab_s.png
-%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/tutorial.html
%%PORTDOCS%%%%DOCSDIR%%/user_doc.css
%%DATADIR%%/__fish_build_paths.fish
@@ -61,6 +39,10 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/amixer.fish
%%DATADIR%%/completions/and.fish
%%DATADIR%%/completions/animate.fish
+%%DATADIR%%/completions/ansible-galaxy.fish
+%%DATADIR%%/completions/ansible-playbook.fish
+%%DATADIR%%/completions/ansible-vault.fish
+%%DATADIR%%/completions/ansible.fish
%%DATADIR%%/completions/ant.fish
%%DATADIR%%/completions/apack.fish
%%DATADIR%%/completions/apm.fish
@@ -106,11 +88,14 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/awk.fish
%%DATADIR%%/completions/badblocks.fish
%%DATADIR%%/completions/base64.fish
+%%DATADIR%%/completions/bb-wrapper.fish
%%DATADIR%%/completions/bc.fish
+%%DATADIR%%/completions/bd.fish
%%DATADIR%%/completions/bg.fish
%%DATADIR%%/completions/bind.fish
%%DATADIR%%/completions/bison.fish
%%DATADIR%%/completions/block.fish
+%%DATADIR%%/completions/bower.fish
%%DATADIR%%/completions/break.fish
%%DATADIR%%/completions/brew.fish
%%DATADIR%%/completions/btdownloadcurses.py.fish
@@ -139,6 +124,8 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/chmod.fish
%%DATADIR%%/completions/chown.fish
%%DATADIR%%/completions/chsh.fish
+%%DATADIR%%/completions/clang++.fish
+%%DATADIR%%/completions/clang.fish
%%DATADIR%%/completions/climate.fish
%%DATADIR%%/completions/colordiff.fish
%%DATADIR%%/completions/colorsvn.fish
@@ -150,6 +137,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/composer.fish
%%DATADIR%%/completions/composer.phar.fish
%%DATADIR%%/completions/composite.fish
+%%DATADIR%%/completions/conda.fish
%%DATADIR%%/completions/configure.fish
%%DATADIR%%/completions/conjure.fish
%%DATADIR%%/completions/connmanctl.fish
@@ -163,6 +151,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/cupsdisable.fish
%%DATADIR%%/completions/cupsenable.fish
%%DATADIR%%/completions/cupsreject.fish
+%%DATADIR%%/completions/curl.fish
%%DATADIR%%/completions/cut.fish
%%DATADIR%%/completions/cvs.fish
%%DATADIR%%/completions/cygport.fish
@@ -182,6 +171,8 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/dlocate.fish
%%DATADIR%%/completions/dmesg.fish
%%DATADIR%%/completions/dnf.fish
+%%DATADIR%%/completions/doas.fish
+%%DATADIR%%/completions/docker.fish
%%DATADIR%%/completions/dpkg-reconfigure.fish
%%DATADIR%%/completions/dpkg.fish
%%DATADIR%%/completions/dropbox.fish
@@ -189,6 +180,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/duply.fish
%%DATADIR%%/completions/dvipdf.fish
%%DATADIR%%/completions/dvipdfm.fish
+%%DATADIR%%/completions/ebuild.fish
%%DATADIR%%/completions/echo.fish
%%DATADIR%%/completions/egrep.fish
%%DATADIR%%/completions/eix-sync.fish
@@ -196,16 +188,19 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/elatex.fish
%%DATADIR%%/completions/elixir.fish
%%DATADIR%%/completions/emacs.fish
+%%DATADIR%%/completions/emaint.fish
%%DATADIR%%/completions/emerge.fish
%%DATADIR%%/completions/encfs.fish
%%DATADIR%%/completions/entr.fish
%%DATADIR%%/completions/env.fish
+%%DATADIR%%/completions/eopkg.fish
%%DATADIR%%/completions/equery.fish
%%DATADIR%%/completions/eselect.fish
%%DATADIR%%/completions/etex.fish
%%DATADIR%%/completions/eval.fish
%%DATADIR%%/completions/evince.fish
%%DATADIR%%/completions/exec.fish
+%%DATADIR%%/completions/exercism.fish
%%DATADIR%%/completions/exit.fish
%%DATADIR%%/completions/expand.fish
%%DATADIR%%/completions/ezjail-admin.fish
@@ -262,7 +257,9 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/hg.fish
%%DATADIR%%/completions/highlight.fish
%%DATADIR%%/completions/history.fish
+%%DATADIR%%/completions/hjson.fish
%%DATADIR%%/completions/htop.fish
+%%DATADIR%%/completions/hugo.fish
%%DATADIR%%/completions/i3-msg.fish
%%DATADIR%%/completions/iconv.fish
%%DATADIR%%/completions/id.fish
@@ -277,7 +274,10 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/ip.fish
%%DATADIR%%/completions/ipset.fish
%%DATADIR%%/completions/iptables.fish
+%%DATADIR%%/completions/j.fish
+%%DATADIR%%/completions/jbake.fish
%%DATADIR%%/completions/jest.fish
+%%DATADIR%%/completions/jhipster.fish
%%DATADIR%%/completions/jobs.fish
%%DATADIR%%/completions/journalctl.fish
%%DATADIR%%/completions/jq.fish
@@ -286,6 +286,9 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/kill.fish
%%DATADIR%%/completions/killall.fish
%%DATADIR%%/completions/kitchen.fish
+%%DATADIR%%/completions/kitty.fish
+%%DATADIR%%/completions/kldload.fish
+%%DATADIR%%/completions/kldunload.fish
%%DATADIR%%/completions/la.fish
%%DATADIR%%/completions/latex.fish
%%DATADIR%%/completions/latexmk.fish
@@ -323,8 +326,10 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/magento.fish
%%DATADIR%%/completions/make.fish
%%DATADIR%%/completions/makedepend.fish
+%%DATADIR%%/completions/makensis.fish
%%DATADIR%%/completions/makepkg.fish
%%DATADIR%%/completions/man.fish
+%%DATADIR%%/completions/math.fish
%%DATADIR%%/completions/mc.fish
%%DATADIR%%/completions/md5sum.fish
%%DATADIR%%/completions/mdadm.fish
@@ -334,9 +339,11 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/mdimport.fish
%%DATADIR%%/completions/mdls.fish
%%DATADIR%%/completions/mdutil.fish
+%%DATADIR%%/completions/meson.fish
%%DATADIR%%/completions/minikube.fish
%%DATADIR%%/completions/mix.fish
%%DATADIR%%/completions/mkdir.fish
+%%DATADIR%%/completions/mkdocs.fish
%%DATADIR%%/completions/mkdosfs.fish
%%DATADIR%%/completions/mkfs.fat.fish
%%DATADIR%%/completions/mkfs.vfat.fish
@@ -365,6 +372,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/netctl.fish
%%DATADIR%%/completions/networkctl.fish
%%DATADIR%%/completions/nextd.fish
+%%DATADIR%%/completions/ngrok.fish
%%DATADIR%%/completions/nice.fish
%%DATADIR%%/completions/ninja.fish
%%DATADIR%%/completions/nl.fish
@@ -381,6 +389,9 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/omega.fish
%%DATADIR%%/completions/opam.fish
%%DATADIR%%/completions/open.fish
+%%DATADIR%%/completions/openocd.fish
+%%DATADIR%%/completions/opkg.fish
+%%DATADIR%%/completions/optipng.fish
%%DATADIR%%/completions/or.fish
%%DATADIR%%/completions/p4.fish
%%DATADIR%%/completions/pacaur.fish
@@ -392,6 +403,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/pacsrv.fish
%%DATADIR%%/completions/pactl.fish
%%DATADIR%%/completions/pactree.fish
+%%DATADIR%%/completions/pandoc.fish
%%DATADIR%%/completions/passwd.fish
%%DATADIR%%/completions/patch.fish
%%DATADIR%%/completions/pbget.fish
@@ -401,6 +413,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/pdftex.fish
%%DATADIR%%/completions/pdftotext.fish
%%DATADIR%%/completions/perl.fish
+%%DATADIR%%/completions/pfctl.fish
%%DATADIR%%/completions/pftp.fish
%%DATADIR%%/completions/pgrep.fish
%%DATADIR%%/completions/pine.fish
@@ -412,6 +425,9 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/pipenv.fish
%%DATADIR%%/completions/pkg-config.fish
%%DATADIR%%/completions/pkg.fish
+%%DATADIR%%/completions/pkg_add.fish
+%%DATADIR%%/completions/pkg_delete.fish
+%%DATADIR%%/completions/pkg_info.fish
%%DATADIR%%/completions/pkgadd.fish
%%DATADIR%%/completions/pkgfile.fish
%%DATADIR%%/completions/pkginfo.fish
@@ -420,14 +436,17 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/pkill.fish
%%DATADIR%%/completions/poff.fish
%%DATADIR%%/completions/pon.fish
+%%DATADIR%%/completions/port.fish
%%DATADIR%%/completions/portmaster.fish
%%DATADIR%%/completions/ports.fish
%%DATADIR%%/completions/poweroff.fish
+%%DATADIR%%/completions/powerpill.fish
%%DATADIR%%/completions/prevd.fish
%%DATADIR%%/completions/prt-get.fish
%%DATADIR%%/completions/ps.fish
%%DATADIR%%/completions/ps2pdf.fish
%%DATADIR%%/completions/psql.fish
+%%DATADIR%%/completions/pstack.fish
%%DATADIR%%/completions/psub.fish
%%DATADIR%%/completions/pushd.fish
%%DATADIR%%/completions/pv.fish
@@ -443,6 +462,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/rc-service.fish
%%DATADIR%%/completions/rc-update.fish
%%DATADIR%%/completions/rc.d.fish
+%%DATADIR%%/completions/rcctl.fish
%%DATADIR%%/completions/read.fish
%%DATADIR%%/completions/readlink.fish
%%DATADIR%%/completions/realpath.fish
@@ -473,6 +493,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/scss.fish
%%DATADIR%%/completions/sed.fish
%%DATADIR%%/completions/seq.fish
+%%DATADIR%%/completions/serve.fish
%%DATADIR%%/completions/service.fish
%%DATADIR%%/completions/set.fish
%%DATADIR%%/completions/set_color.fish
@@ -484,6 +505,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/sha256sum.fish
%%DATADIR%%/completions/sha384sum.fish
%%DATADIR%%/completions/sha512sum.fish
+%%DATADIR%%/completions/signify.fish
%%DATADIR%%/completions/snap.fish
%%DATADIR%%/completions/sort.fish
%%DATADIR%%/completions/ssh.fish
@@ -525,14 +547,17 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/trap.fish
%%DATADIR%%/completions/travis.fish
%%DATADIR%%/completions/tree.fish
+%%DATADIR%%/completions/ttx.fish
%%DATADIR%%/completions/type.fish
%%DATADIR%%/completions/udisksctl.fish
%%DATADIR%%/completions/ulimit.fish
+%%DATADIR%%/completions/umask.fish
%%DATADIR%%/completions/umount.fish
%%DATADIR%%/completions/uname.fish
%%DATADIR%%/completions/unexpand.fish
%%DATADIR%%/completions/uniq.fish
%%DATADIR%%/completions/unrar.fish
+%%DATADIR%%/completions/unzip.fish
%%DATADIR%%/completions/update-eix-remote.fish
%%DATADIR%%/completions/update-eix.fish
%%DATADIR%%/completions/useradd.fish
@@ -544,6 +569,8 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/vim-addons.fish
%%DATADIR%%/completions/vim.fish
%%DATADIR%%/completions/vimdiff.fish
+%%DATADIR%%/completions/virsh.fish
+%%DATADIR%%/completions/vmctl.fish
%%DATADIR%%/completions/w.fish
%%DATADIR%%/completions/wajig.fish
%%DATADIR%%/completions/watch.fish
@@ -559,6 +586,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/wpa_cli.fish
%%DATADIR%%/completions/wvdial.fish
%%DATADIR%%/completions/xargs.fish
+%%DATADIR%%/completions/xclip.fish
%%DATADIR%%/completions/xdg-mime.fish
%%DATADIR%%/completions/xdvi.fish
%%DATADIR%%/completions/xelatex.fish
@@ -570,6 +598,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/xrandr.fish
%%DATADIR%%/completions/xrdb.fish
%%DATADIR%%/completions/xsel.fish
+%%DATADIR%%/completions/xsv.fish
%%DATADIR%%/completions/xterm.fish
%%DATADIR%%/completions/xz.fish
%%DATADIR%%/completions/yaourt.fish
@@ -577,15 +606,20 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/completions/yast2.fish
%%DATADIR%%/completions/yum.fish
%%DATADIR%%/completions/zcat.fish
+%%DATADIR%%/completions/zfs.fish
%%DATADIR%%/completions/zip.fish
+%%DATADIR%%/completions/zpool.fish
%%DATADIR%%/completions/zypper.fish
%%DATADIR%%/config.fish
%%DATADIR%%/functions/N_.fish
%%DATADIR%%/functions/_.fish
+%%DATADIR%%/functions/__fish_abbr_old.fish
%%DATADIR%%/functions/__fish_append.fish
%%DATADIR%%/functions/__fish_bind_test1.fish
%%DATADIR%%/functions/__fish_bind_test2.fish
+%%DATADIR%%/functions/__fish_can_complete_switches.fish
%%DATADIR%%/functions/__fish_cancel_commandline.fish
+%%DATADIR%%/functions/__fish_clang_complete.fish
%%DATADIR%%/functions/__fish_commandline_is_singlequoted.fish
%%DATADIR%%/functions/__fish_commandline_test.fish
%%DATADIR%%/functions/__fish_complete_abook_formats.fish
@@ -623,6 +657,11 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/__fish_complete_user_at_hosts.fish
%%DATADIR%%/functions/__fish_complete_users.fish
%%DATADIR%%/functions/__fish_complete_wvdial_peers.fish
+%%DATADIR%%/functions/__fish_complete_zfs_mountpoint_properties.fish
+%%DATADIR%%/functions/__fish_complete_zfs_pools.fish
+%%DATADIR%%/functions/__fish_complete_zfs_ro_properties.fish
+%%DATADIR%%/functions/__fish_complete_zfs_rw_properties.fish
+%%DATADIR%%/functions/__fish_complete_zfs_write_once_properties.fish
%%DATADIR%%/functions/__fish_config_interactive.fish
%%DATADIR%%/functions/__fish_contains_opt.fish
%%DATADIR%%/functions/__fish_crux_packages.fish
@@ -631,12 +670,16 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/__fish_cursor_xterm.fish
%%DATADIR%%/functions/__fish_describe_command.fish
%%DATADIR%%/functions/__fish_filter_ant_targets.fish
+%%DATADIR%%/functions/__fish_first_token.fish
%%DATADIR%%/functions/__fish_git_prompt.fish
%%DATADIR%%/functions/__fish_gnu_complete.fish
%%DATADIR%%/functions/__fish_hg_prompt.fish
+%%DATADIR%%/functions/__fish_is_first_arg.fish
%%DATADIR%%/functions/__fish_is_first_token.fish
%%DATADIR%%/functions/__fish_is_git_repository.fish
+%%DATADIR%%/functions/__fish_is_switch.fish
%%DATADIR%%/functions/__fish_is_token_n.fish
+%%DATADIR%%/functions/__fish_is_zfs_feature_enabled.fish
%%DATADIR%%/functions/__fish_list_current_token.fish
%%DATADIR%%/functions/__fish_make_completion_signals.fish
%%DATADIR%%/functions/__fish_man_page.fish
@@ -645,7 +688,14 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/__fish_not_contain_opt.fish
%%DATADIR%%/functions/__fish_number_of_cmd_args_wo_opts.fish
%%DATADIR%%/functions/__fish_paginate.fish
+%%DATADIR%%/functions/__fish_parent_directories.fish
+%%DATADIR%%/functions/__fish_parse_configure.fish
+%%DATADIR%%/functions/__fish_portage_print_available_pkgs.fish
+%%DATADIR%%/functions/__fish_portage_print_installed_pkgs.fish
+%%DATADIR%%/functions/__fish_portage_print_repository_names.fish
+%%DATADIR%%/functions/__fish_portage_print_repository_paths.fish
%%DATADIR%%/functions/__fish_ports_dirs.fish
+%%DATADIR%%/functions/__fish_prev_arg_in.fish
%%DATADIR%%/functions/__fish_print_VBox_vms.fish
%%DATADIR%%/functions/__fish_print_abook_emails.fish
%%DATADIR%%/functions/__fish_print_addresses.fish
@@ -660,6 +710,7 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/__fish_print_encodings.fish
%%DATADIR%%/functions/__fish_print_filesystems.fish
%%DATADIR%%/functions/__fish_print_function_prototypes.fish
+%%DATADIR%%/functions/__fish_print_groups.fish
%%DATADIR%%/functions/__fish_print_help.fish
%%DATADIR%%/functions/__fish_print_hostnames.fish
%%DATADIR%%/functions/__fish_print_interfaces.fish
@@ -682,36 +733,33 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/__fish_print_xrandr_modes.fish
%%DATADIR%%/functions/__fish_print_xrandr_outputs.fish
%%DATADIR%%/functions/__fish_print_xwindows.fish
+%%DATADIR%%/functions/__fish_print_zfs_bookmarks.fish
+%%DATADIR%%/functions/__fish_print_zfs_filesystems.fish
+%%DATADIR%%/functions/__fish_print_zfs_snapshots.fish
+%%DATADIR%%/functions/__fish_print_zfs_volumes.fish
%%DATADIR%%/functions/__fish_prt_no_subcommand.fish
%%DATADIR%%/functions/__fish_prt_packages.fish
%%DATADIR%%/functions/__fish_prt_ports.fish
%%DATADIR%%/functions/__fish_prt_use_package.fish
%%DATADIR%%/functions/__fish_prt_use_port.fish
%%DATADIR%%/functions/__fish_pwd.fish
+%%DATADIR%%/functions/__fish_seen_argument.fish
%%DATADIR%%/functions/__fish_seen_subcommand_from.fish
%%DATADIR%%/functions/__fish_set_locale.fish
%%DATADIR%%/functions/__fish_sgrep.fish
%%DATADIR%%/functions/__fish_shared_key_bindings.fish
+%%DATADIR%%/functions/__fish_should_complete_switches.fish
%%DATADIR%%/functions/__fish_svn_prompt.fish
-%%DATADIR%%/functions/__fish_systemctl_automounts.fish
-%%DATADIR%%/functions/__fish_systemctl_devices.fish
-%%DATADIR%%/functions/__fish_systemctl_mounts.fish
-%%DATADIR%%/functions/__fish_systemctl_scopes.fish
-%%DATADIR%%/functions/__fish_systemctl_service_paths.fish
%%DATADIR%%/functions/__fish_systemctl_services.fish
-%%DATADIR%%/functions/__fish_systemctl_slices.fish
-%%DATADIR%%/functions/__fish_systemctl_snapshots.fish
-%%DATADIR%%/functions/__fish_systemctl_sockets.fish
-%%DATADIR%%/functions/__fish_systemctl_swaps.fish
-%%DATADIR%%/functions/__fish_systemctl_targets.fish
-%%DATADIR%%/functions/__fish_systemctl_timers.fish
%%DATADIR%%/functions/__fish_systemd_machine_images.fish
%%DATADIR%%/functions/__fish_systemd_machines.fish
%%DATADIR%%/functions/__fish_test_arg.fish
%%DATADIR%%/functions/__fish_toggle_comment_commandline.fish
%%DATADIR%%/functions/__fish_use_subcommand.fish
%%DATADIR%%/functions/__fish_vcs_prompt.fish
+%%DATADIR%%/functions/__fish_whatis.fish
%%DATADIR%%/functions/__terlar_git_prompt.fish
+%%DATADIR%%/functions/_fish_systemctl.fish
%%DATADIR%%/functions/_validate_int.fish
%%DATADIR%%/functions/abbr.fish
%%DATADIR%%/functions/alias.fish
@@ -738,7 +786,9 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/fish_md5.fish
%%DATADIR%%/functions/fish_mode_prompt.fish
%%DATADIR%%/functions/fish_opt.fish
+%%DATADIR%%/functions/fish_print_hg_root.fish
%%DATADIR%%/functions/fish_prompt.fish
+%%DATADIR%%/functions/fish_title.fish
%%DATADIR%%/functions/fish_update_completions.fish
%%DATADIR%%/functions/fish_vi_cursor.fish
%%DATADIR%%/functions/fish_vi_key_bindings.fish
@@ -754,7 +804,6 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/ll.fish
%%DATADIR%%/functions/ls.fish
%%DATADIR%%/functions/man.fish
-%%DATADIR%%/functions/math.fish
%%DATADIR%%/functions/nextd-or-forward-word.fish
%%DATADIR%%/functions/nextd.fish
%%DATADIR%%/functions/open.fish
@@ -777,90 +826,91 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/functions/vared.fish
%%DATADIR%%/groff/fish.tmac
%%DATADIR%%/lynx.lss
-%%DATADIR%%/man/man1/abbr.1.gz
-%%DATADIR%%/man/man1/alias.1.gz
-%%DATADIR%%/man/man1/and.1.gz
-%%DATADIR%%/man/man1/argparse.1.gz
-%%DATADIR%%/man/man1/begin.1.gz
-%%DATADIR%%/man/man1/bg.1.gz
-%%DATADIR%%/man/man1/bind.1.gz
-%%DATADIR%%/man/man1/block.1.gz
-%%DATADIR%%/man/man1/break.1.gz
-%%DATADIR%%/man/man1/breakpoint.1.gz
-%%DATADIR%%/man/man1/builtin.1.gz
-%%DATADIR%%/man/man1/case.1.gz
-%%DATADIR%%/man/man1/cd.1.gz
-%%DATADIR%%/man/man1/cdh.1.gz
-%%DATADIR%%/man/man1/command.1.gz
-%%DATADIR%%/man/man1/commandline.1.gz
-%%DATADIR%%/man/man1/complete.1.gz
-%%DATADIR%%/man/man1/contains.1.gz
-%%DATADIR%%/man/man1/continue.1.gz
-%%DATADIR%%/man/man1/count.1.gz
-%%DATADIR%%/man/man1/dirh.1.gz
-%%DATADIR%%/man/man1/dirs.1.gz
-%%DATADIR%%/man/man1/disown.1.gz
-%%DATADIR%%/man/man1/echo.1.gz
-%%DATADIR%%/man/man1/else.1.gz
-%%DATADIR%%/man/man1/emit.1.gz
-%%DATADIR%%/man/man1/end.1.gz
-%%DATADIR%%/man/man1/eval.1.gz
-%%DATADIR%%/man/man1/exec.1.gz
-%%DATADIR%%/man/man1/exit.1.gz
-%%DATADIR%%/man/man1/false.1.gz
-%%DATADIR%%/man/man1/fg.1.gz
-%%DATADIR%%/man/man1/fish.1.gz
-%%DATADIR%%/man/man1/fish_breakpoint_prompt.1.gz
-%%DATADIR%%/man/man1/fish_config.1.gz
-%%DATADIR%%/man/man1/fish_indent.1.gz
-%%DATADIR%%/man/man1/fish_key_reader.1.gz
-%%DATADIR%%/man/man1/fish_mode_prompt.1.gz
-%%DATADIR%%/man/man1/fish_opt.1.gz
-%%DATADIR%%/man/man1/fish_prompt.1.gz
-%%DATADIR%%/man/man1/fish_right_prompt.1.gz
-%%DATADIR%%/man/man1/fish_update_completions.1.gz
-%%DATADIR%%/man/man1/fish_vi_mode.1.gz
-%%DATADIR%%/man/man1/for.1.gz
-%%DATADIR%%/man/man1/funced.1.gz
-%%DATADIR%%/man/man1/funcsave.1.gz
-%%DATADIR%%/man/man1/function.1.gz
-%%DATADIR%%/man/man1/functions.1.gz
-%%DATADIR%%/man/man1/help.1.gz
-%%DATADIR%%/man/man1/history.1.gz
-%%DATADIR%%/man/man1/if.1.gz
-%%DATADIR%%/man/man1/isatty.1.gz
-%%DATADIR%%/man/man1/jobs.1.gz
-%%DATADIR%%/man/man1/math.1.gz
-%%DATADIR%%/man/man1/nextd.1.gz
-%%DATADIR%%/man/man1/not.1.gz
-%%DATADIR%%/man/man1/open.1.gz
-%%DATADIR%%/man/man1/or.1.gz
-%%DATADIR%%/man/man1/popd.1.gz
-%%DATADIR%%/man/man1/prevd.1.gz
-%%DATADIR%%/man/man1/printf.1.gz
-%%DATADIR%%/man/man1/prompt_pwd.1.gz
-%%DATADIR%%/man/man1/psub.1.gz
-%%DATADIR%%/man/man1/pushd.1.gz
-%%DATADIR%%/man/man1/pwd.1.gz
-%%DATADIR%%/man/man1/random.1.gz
-%%DATADIR%%/man/man1/read.1.gz
-%%DATADIR%%/man/man1/realpath.1.gz
-%%DATADIR%%/man/man1/return.1.gz
-%%DATADIR%%/man/man1/set.1.gz
-%%DATADIR%%/man/man1/set_color.1.gz
-%%DATADIR%%/man/man1/source.1.gz
-%%DATADIR%%/man/man1/status.1.gz
-%%DATADIR%%/man/man1/string.1.gz
-%%DATADIR%%/man/man1/suspend.1.gz
-%%DATADIR%%/man/man1/switch.1.gz
-%%DATADIR%%/man/man1/test.1.gz
-%%DATADIR%%/man/man1/trap.1.gz
-%%DATADIR%%/man/man1/true.1.gz
-%%DATADIR%%/man/man1/type.1.gz
-%%DATADIR%%/man/man1/ulimit.1.gz
-%%DATADIR%%/man/man1/umask.1.gz
-%%DATADIR%%/man/man1/vared.1.gz
-%%DATADIR%%/man/man1/while.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/abbr.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/alias.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/and.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/argparse.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/begin.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/bg.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/bind.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/block.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/break.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/breakpoint.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/builtin.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/case.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/cd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/cdh.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/command.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/commandline.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/complete.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/contains.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/continue.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/count.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/dirh.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/dirs.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/disown.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/echo.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/else.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/emit.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/end.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/eval.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/exec.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/exit.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/false.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fg.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_breakpoint_prompt.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_config.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_indent.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_key_reader.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_mode_prompt.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_opt.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_prompt.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_right_prompt.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_update_completions.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/fish_vi_mode.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/for.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/funced.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/funcsave.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/function.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/functions.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/help.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/history.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/if.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/isatty.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/jobs.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/math.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/nextd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/not.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/open.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/or.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/popd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/prevd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/printf.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/prompt_pwd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/psub.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/pushd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/pwd.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/random.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/read.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/realpath.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/return.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/set.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/set_color.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/source.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/status.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/string.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/suspend.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/switch.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/test.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/trap.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/true.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/type.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/ulimit.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/umask.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/vared.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/wait.1.gz
+%%MANPAGES%%%%DATADIR%%/man/man1/while.1.gz
%%DATADIR%%/tools/create_manpage_completions.py
%%DATADIR%%/tools/deroff.py
%%DATADIR%%/tools/web_config/delete.png
@@ -896,7 +946,6 @@ man/man1/fish_key_reader.1.gz
%%DATADIR%%/tools/web_config/sample_prompts/screen_savvy.fish
%%DATADIR%%/tools/web_config/sample_prompts/sorin.fish
%%DATADIR%%/tools/web_config/sample_prompts/terlar.fish
-%%DATADIR%%/tools/web_config/sample_prompts/user_host_path.fish
%%DATADIR%%/tools/web_config/webconfig.py
%%NLS%%share/locale/de/LC_MESSAGES/fish.mo
%%NLS%%share/locale/en/LC_MESSAGES/fish.mo
@@ -907,7 +956,9 @@ man/man1/fish_key_reader.1.gz
%%NLS%%share/locale/pt_BR/LC_MESSAGES/fish.mo
%%NLS%%share/locale/sv/LC_MESSAGES/fish.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/fish.mo
+@dir %%ETCDIR%%/completions
@dir %%ETCDIR%%/conf.d
+@dir %%ETCDIR%%/functions
@dir %%DATADIR%%/vendor_completions.d
@dir %%DATADIR%%/vendor_conf.d
@dir %%DATADIR%%/vendor_functions.d