aboutsummaryrefslogtreecommitdiff
path: root/shells/fish
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2020-04-18 21:01:52 +0000
committerAlan Somers <asomers@FreeBSD.org>2020-04-18 21:01:52 +0000
commitf28bbddabfc0988f6f80360f36b6a0a25d5efd5a (patch)
tree4796091560700cd26b06dddba942e3ff0cae1606 /shells/fish
parent1007ca9d599d8cbd4ca17bc5e08f577056998598 (diff)
downloadports-f28bbddabfc0988f6f80360f36b6a0a25d5efd5a.tar.gz
ports-f28bbddabfc0988f6f80360f36b6a0a25d5efd5a.zip
shells/fish: cherry-pick upstream fix for SVN performance
Upstream bug #6681 causes fish to run _very_ slowly inside of large Subversion repositories. The bug will be fixed in release 3.1.1. But it's worthwhile to cherry-pick the fix since all FreeBSD developers use large Subversion repositories. https://github.com/fish-shell/fish-shell/issues/6681
Notes
Notes: svn path=/head/; revision=532045
Diffstat (limited to 'shells/fish')
-rw-r--r--shells/fish/Makefile1
-rw-r--r--shells/fish/files/patch-share_functions_fish__vcs__prompt.fish12
2 files changed, 13 insertions, 0 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index bc49c45a95af..46b3de8abbd5 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fish
PORTVERSION= 3.1.0
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= https://github.com/fish-shell/fish-shell/releases/download/${PORTVERSION}/
diff --git a/shells/fish/files/patch-share_functions_fish__vcs__prompt.fish b/shells/fish/files/patch-share_functions_fish__vcs__prompt.fish
new file mode 100644
index 000000000000..9dd8f2f2c6f2
--- /dev/null
+++ b/shells/fish/files/patch-share_functions_fish__vcs__prompt.fish
@@ -0,0 +1,12 @@
+--- share/functions/fish_vcs_prompt.fish.orig 2020-04-18 20:32:19 UTC
++++ share/functions/fish_vcs_prompt.fish
+@@ -3,5 +3,8 @@ function fish_vcs_prompt --description "Print the prom
+ # This is so we don't try svn if git already worked.
+ fish_git_prompt
+ or fish_hg_prompt
+- or fish_svn_prompt
++ # The svn prompt is disabled by default because it's quite slow on common svn repositories.
++ # To enable it uncomment it.
++ # You can also only use it in specific directories by checking $PWD.
++ # or fish_svn_prompt
+ end