aboutsummaryrefslogtreecommitdiff
path: root/shells/ion
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-12-17 07:56:33 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-12-17 07:56:33 +0000
commit3b660c3a93548bd5c5bfad1eace35b8ce3b3b419 (patch)
tree6297236737a086c6281c17b66edf3f707cc4f7c5 /shells/ion
parenteea8c9e351ce78054f70b1536f29efbd7700af16 (diff)
downloadports-3b660c3a93548bd5c5bfad1eace35b8ce3b3b419.tar.gz
ports-3b660c3a93548bd5c5bfad1eace35b8ce3b3b419.zip
shells/ion: Unbreak build with Rust 1.40.0 (D22843)
error[E0503]: cannot use `self.key_bindings` because it was mutably borrowed --> /wrkdirs/usr/ports/shells/ion/work/ion-a8872014dbce730ccd00aaa722397dc394a52bf4-a8872014dbce730ccd00aaa722397dc394a52bf4/cargo-crates/liner-0.4.4/src/context.rs:98:17 | 96 | let ed = try!(Editor::new_with_init_buffer(stdout, prompt, self, buffer)); | ---- borrow of `*self` occurs here 97 | match self.key_bindings { 98 | KeyBindings::Emacs => Self::handle_keys(keymap::Emacs::new(ed), handler), | ^^^^^^^^^^^^^^^^^^ use of borrowed `*self` 99 | KeyBindings::Vi => Self::handle_keys(keymap::Vi::new(ed), handler), | -- borrow later used here error: aborting due to previous error
Notes
Notes: svn path=/head/; revision=520313
Diffstat (limited to 'shells/ion')
-rw-r--r--shells/ion/Makefile9
-rw-r--r--shells/ion/distinfo4
2 files changed, 8 insertions, 5 deletions
diff --git a/shells/ion/Makefile b/shells/ion/Makefile
index 1c4b59d8ec93..69956c4d9ceb 100644
--- a/shells/ion/Makefile
+++ b/shells/ion/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ion
DISTVERSION= 1.0.5-1355
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= shells
PKGNAMESUFFIX= -shell
@@ -118,7 +118,6 @@ CARGO_CRATES= adler32-1.0.3 \
libc-0.2.60 \
libloading-0.5.2 \
line_drawing-0.7.0 \
- liner-0.4.4 \
lock_api-0.1.5 \
log-0.4.7 \
lzw-0.10.0 \
@@ -261,6 +260,12 @@ CONFLICTS_INSTALL= ion
OPTIONS_DEFINE= DOCS EXAMPLES
+# liner-0.4.4 does not build with Rust 1.40.0. Use the newer copy
+# that is also already available.
+post-patch:
+ @${REINPLACE_CMD} 's,^liner = .*,liner = \{ path = "${WRKSRC_liner}" \},' \
+ ${WRKSRC_calculate}/Cargo.toml
+
post-configure:
${ECHO_CMD} ${GL_COMMIT} > ${WRKSRC}/git_revision.txt
diff --git a/shells/ion/distinfo b/shells/ion/distinfo
index a80d3a8cff33..a34ed5e73f50 100644
--- a/shells/ion/distinfo
+++ b/shells/ion/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1565075757
+TIMESTAMP = 1576567883
SHA256 (rust/crates/adler32-1.0.3.tar.gz) = 7e522997b529f05601e05166c07ed17789691f562762c7f3b987263d2dedee5c
SIZE (rust/crates/adler32-1.0.3.tar.gz) = 5734
SHA256 (rust/crates/aho-corasick-0.7.4.tar.gz) = 36b7aa1ccb7d7ea3f437cf025a2ab1c47cc6c1bc9fc84918ff449def12f5e282
@@ -187,8 +187,6 @@ SHA256 (rust/crates/libloading-0.5.2.tar.gz) = f2b111a074963af1d37a139918ac6d49a
SIZE (rust/crates/libloading-0.5.2.tar.gz) = 16420
SHA256 (rust/crates/line_drawing-0.7.0.tar.gz) = 5cc7ad3d82c845bdb5dde34ffdcc7a5fb4d2996e1e1ee0f19c33bc80e15196b9
SIZE (rust/crates/line_drawing-0.7.0.tar.gz) = 10452
-SHA256 (rust/crates/liner-0.4.4.tar.gz) = e21c5e49e5d73f18124fd3c751a0823f754c5ae7193cb9e8aa467b03b161241c
-SIZE (rust/crates/liner-0.4.4.tar.gz) = 29857
SHA256 (rust/crates/lock_api-0.1.5.tar.gz) = 62ebf1391f6acad60e5c8b43706dde4582df75c06698ab44511d15016bc2442c
SIZE (rust/crates/lock_api-0.1.5.tar.gz) = 16967
SHA256 (rust/crates/log-0.4.7.tar.gz) = c275b6ad54070ac2d665eef9197db647b32239c9d244bfb6f041a766d00da5b3