aboutsummaryrefslogtreecommitdiff
path: root/shells/ksh93
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-05-28 02:35:40 +0000
committerCy Schubert <cy@FreeBSD.org>2019-05-28 02:35:40 +0000
commit2a0731944ad16e93f8c8023b338c7381b61637c6 (patch)
tree8d37ef60172e2b660894439e7f9afc13d4ba26b8 /shells/ksh93
parentc08fd5ebb4853f6b18354358b0c710e5b9a02dd1 (diff)
downloadports-2a0731944ad16e93f8c8023b338c7381b61637c6.tar.gz
ports-2a0731944ad16e93f8c8023b338c7381b61637c6.zip
This is the second part of a two part commit Updating shells/ksh93 to
2020.0.0-alpha1. This commit: 1. Deletes shells/ksh93, completed by r502844. 2. svn copies shells/ksh93-devel to shells/ksh93 -- this commit. 3. Replaces the git tag with DISTVERSION 2020.0.0-alpha1 -- this commit. PR: 237332 Reviewed by: crees@ Approved by: maintainer timeout Reminded by: Siteshwar Vashisht <svashisht@redhat.com> (ksh93 upstream maintainer)
Notes
Notes: svn path=/head/; revision=502845
Diffstat (limited to 'shells/ksh93')
-rw-r--r--shells/ksh93/Makefile50
-rw-r--r--shells/ksh93/distinfo3
-rw-r--r--shells/ksh93/files/extra-patch-install-as-ksh9325
-rw-r--r--shells/ksh93/pkg-descr13
-rw-r--r--shells/ksh93/pkg-plist3
5 files changed, 94 insertions, 0 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
new file mode 100644
index 000000000000..b99229df0f24
--- /dev/null
+++ b/shells/ksh93/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= ksh93
+DISTVERSION=2020.0.0-alpha1
+CATEGORIES= shells
+
+MAINTAINER= saper@saper.info
+COMMENT= AT&T KornShell 93
+
+LICENSE= EPL
+
+USES= compiler:c11 meson ninja python:build
+
+USE_GITHUB= yes
+GH_ACCOUNT= att
+GH_PROJECT= ast
+GH_TAGNAME= ${HASH}
+
+KSH_CONFLICTS= pdksh-*
+KSH93_CONFLICTS= ksh93-devel
+
+LDFLAGS+= -lm
+MESON_BUILD_DIR= build
+MAKE_ENV= CCFLAGS="${CFLAGS}"
+
+OPTIONS_DEFAULT= KSH93
+OPTIONS_SINGLE= BIN_KSH
+OPTIONS_SINGLE_BIN_KSH= KSH KSH93
+KSH_DESC= Install to ${PREFIX}/bin/ksh
+KSH93_DESC= Install to ${PREFIX}/bin/ksh93
+
+KSH93_EXTRA_PATCHES= ${FILESDIR}/extra-patch-install-as-ksh93
+KSH93_DESC= Install to ${PREFIX}/bin/ksh93
+
+KSH_PLIST_SUB= 93=""
+KSH93_PLIST_SUB= 93="93"
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e '/for name in/ s|python.*|${PYTHON_CMD}|g' ${WRKSRC}/scripts/python.sh
+ @${REINPLACE_CMD} -e 's|SF_FLAGS|SFIO_FLAGS|g' ${WRKSRC}/src/lib/libast/include/sfio*.h ${WRKSRC}/src/lib/libast/sfio/*.c
+.if ${PORT_OPTIONS:MKSH93}
+ @${MV} ${WRKSRC}/src/cmd/ksh93/ksh.1 ${WRKSRC}/src/cmd/ksh93/ksh93.1
+.endif
+.if ${PORT_OPTIONS:MKSH}
+ @# Keep portlint happy
+.endif
+
+.include <bsd.port.mk>
diff --git a/shells/ksh93/distinfo b/shells/ksh93/distinfo
new file mode 100644
index 000000000000..cfaf9203cb5b
--- /dev/null
+++ b/shells/ksh93/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556307803
+SHA256 (att-ast-2020.0.0-alpha1_GH0.tar.gz) = a9c6a9291ee1a2a5169cdebfe601124e53ae15f83d0857c166d9f2d86c1d4294
+SIZE (att-ast-2020.0.0-alpha1_GH0.tar.gz) = 2041318
diff --git a/shells/ksh93/files/extra-patch-install-as-ksh93 b/shells/ksh93/files/extra-patch-install-as-ksh93
new file mode 100644
index 000000000000..a40b59eae157
--- /dev/null
+++ b/shells/ksh93/files/extra-patch-install-as-ksh93
@@ -0,0 +1,25 @@
+--- src/cmd/ksh93/meson.build.orig 2018-09-25 15:33:55.000000000 -0700
++++ src/cmd/ksh93/meson.build 2018-09-25 19:00:44.313649000 -0700
+@@ -26,19 +26,19 @@
+ dependencies: [libm_dep, libexecinfo_dep, libdl_dep],
+ install: false)
+
+-ksh93_exe = executable('ksh', ['sh/pmain.c'], c_args: shared_c_args,
++ksh93_exe = executable('ksh93', ['sh/pmain.c'], c_args: shared_c_args,
+ include_directories: [configuration_incdir, ksh93_incdir],
+ link_with: [libksh, libast, libcmd, libdll],
+ dependencies: [libm_dep, libexecinfo_dep, libdl_dep],
+ install: true)
+
+-shcomp_exe = executable('shcomp', ['sh/shcomp.c'], c_args: shared_c_args,
++shcomp_exe = executable('shcomp93', ['sh/shcomp.c'], c_args: shared_c_args,
+ include_directories: [configuration_incdir, ksh93_incdir],
+ link_with: [libksh, libast, libcmd, libdll],
+ dependencies: [libm_dep, libexecinfo_dep, libdl_dep],
+ install: true)
+
+-install_man('ksh.1')
++install_man('ksh93.1')
+
+ test_dir = join_paths(meson.current_source_dir(), 'tests')
+ test_driver = join_paths(test_dir, 'util', 'run_test.sh')
diff --git a/shells/ksh93/pkg-descr b/shells/ksh93/pkg-descr
new file mode 100644
index 000000000000..ee3150bac1cd
--- /dev/null
+++ b/shells/ksh93/pkg-descr
@@ -0,0 +1,13 @@
+KSH-93 is the most recent version of the KornShell Language described
+in "The KornShell Command and Programming Language," by Morris
+Bolsky and David Korn of AT&T Bell Laboratories. The KornShell is
+a shell programming language, which is upward compatible with "sh"
+(the Bourne Shell), and is intended to conform to the IEEE P1003.2/ISO
+9945.2 Shell and Utilities standard. KSH-93 provides an enhanced
+programming environment in addition to the major command-entry
+features of the BSD shell "csh". With KSH-93, medium-sized programming
+tasks can be performed at shell-level without a significant loss
+in performance. In addition, "sh" scripts can be run on KSH-93
+without modification.
+
+WWW: http://www.kornshell.com/
diff --git a/shells/ksh93/pkg-plist b/shells/ksh93/pkg-plist
new file mode 100644
index 000000000000..6dab70e96c94
--- /dev/null
+++ b/shells/ksh93/pkg-plist
@@ -0,0 +1,3 @@
+@shell bin/ksh%%93%%
+bin/shcomp%%93%%
+man/man1/ksh%%93%%.1.gz