aboutsummaryrefslogtreecommitdiff
path: root/shells/ksh93
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-08-12 07:17:09 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-08-12 07:17:09 +0000
commitd6eb7151b7f447560213c851c1f491efd280d435 (patch)
tree4099b5226ccf9512fcad5e7348be05ffad70b653 /shells/ksh93
parent41fa9d89f7bdb79b5e7b5ec46d23fa3382845436 (diff)
downloadports-d6eb7151b7f447560213c851c1f491efd280d435.tar.gz
ports-d6eb7151b7f447560213c851c1f491efd280d435.zip
shells/ksh93: Attempt to fix r508705 and unbreak index
It fails basic sanity checks: make: "/usr/ports/shells/ksh93/Makefile" line 16: Malformed conditional (${USE_GCC} == "9") make: Fatal errors encountered -- cannot continue make: stopped in /usr/ports/shells/ksh93 PR: 239644 Pointy hat: cy
Notes
Notes: svn path=/head/; revision=508709
Diffstat (limited to 'shells/ksh93')
-rw-r--r--shells/ksh93/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index c522487e449b..f33d860f18b3 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -13,10 +13,6 @@ LICENSE= EPL
USES= compiler:c11 meson ninja python:build
-.if ${USE_GCC} == "9"
-BROKEN= GCC 9.1 changes the output of `gcc -E` which breaks the conf.sh script, fixed in shells/ksh93-devel
-.endif
-
USE_GITHUB= yes
GH_ACCOUNT= att
GH_PROJECT= ast
@@ -38,7 +34,11 @@ KSH93_EXTRA_PATCHES= ${FILESDIR}/extra-patch-install-as-ksh93
KSH_PLIST_SUB= 93=""
KSH93_PLIST_SUB= 93="93"
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} >= 90
+BROKEN= GCC 9.1 changes the output of `gcc -E` which breaks the conf.sh script, fixed in shells/ksh93-devel
+.endif
post-patch:
@${REINPLACE_CMD} -e '/for name in/ s|python.*|${PYTHON_CMD}|g' ${WRKSRC}/scripts/python.sh
@@ -50,4 +50,4 @@ post-patch:
@# Keep portlint happy
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>