aboutsummaryrefslogtreecommitdiff
path: root/shells/oksh
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 06:11:19 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-01 06:11:19 +0000
commite1f939c1b46f9d9f542844f656ac9e370531f235 (patch)
treea6615c14d0b9f123a11b7e29bb605277cf9ea8b9 /shells/oksh
parent8dd9c1d2e1a89665df0eae710f8767a293b8e080 (diff)
downloadports-e1f939c1b46f9d9f542844f656ac9e370531f235.tar.gz
ports-e1f939c1b46f9d9f542844f656ac9e370531f235.zip
shells/oksh: Convert to options helpers
Notes
Notes: svn path=/head/; revision=491793
Diffstat (limited to 'shells/oksh')
-rw-r--r--shells/oksh/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/shells/oksh/Makefile b/shells/oksh/Makefile
index ca97e30665b3..75cb17fd9a48 100644
--- a/shells/oksh/Makefile
+++ b/shells/oksh/Makefile
@@ -10,25 +10,17 @@ COMMENT= Portable OpenBSD Korn shell
LICENSE= PD
+HAS_CONFIGURE= yes
+
OPTIONS_DEFINE= CURSES STATIC
OPTIONS_DEFAULT= CURSES
CURSES_DESC= Use ncurses for screen clearing routines
-CURSES_USES= ncurses
-
-HAS_CONFIGURE= yes
-
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSTATIC}
-CONFIGURE_ARGS+= --enable-static
-.endif
+CURSES_CONFIGURE_ENABLE= curses
+CURSES_USES= ncurses
-.if ${PORT_OPTIONS:MCURSES}
-CONFIGURE_ARGS+= --enable-curses
-.else
-CONFIGURE_ARGS+= --disable-curses
-.endif
+STATIC_CONFIGURE_ENABLE= static
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin