aboutsummaryrefslogtreecommitdiff
path: root/shells/osh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:43:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 08:43:20 +0000
commit1dd1c7ab75671c2abd5320cb53ef953aad56343d (patch)
tree4091113179a6f28d9262c2d4e39c0ef491ad4367 /shells/osh
parentd285778c00f0198c6a9ca1f08234fb511fee49b8 (diff)
downloadports-1dd1c7ab75671c2abd5320cb53ef953aad56343d.tar.gz
ports-1dd1c7ab75671c2abd5320cb53ef953aad56343d.zip
Notes
Diffstat (limited to 'shells/osh')
-rw-r--r--shells/osh/Makefile28
-rw-r--r--shells/osh/pkg-plist6
2 files changed, 8 insertions, 26 deletions
diff --git a/shells/osh/Makefile b/shells/osh/Makefile
index eb3e53dbee1c..5bced94eb247 100644
--- a/shells/osh/Makefile
+++ b/shells/osh/Makefile
@@ -7,41 +7,17 @@ CATEGORIES= shells
MASTER_SITES= http://v6shell.org/src/
MAINTAINER= miwi@FreeBSD.org
-COMMENT= An implementation of the UNIX 6th Edition shell
+COMMENT= Implementation of the UNIX 6th Edition shell
MAKE_ENV+= DOCDIR=${DOCSDIR} \
DESTEXPDIR=${EXAMPLESDIR} \
MANDIR=${MANPREFIX}/man/man1
-MAN1= fd2.1 goto.1 if.1 osh.1 sh6.1 glob6.1
-
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -E -e 's|(DESTEXPDIR)=|\1?=|' \
${WRKSRC}/Makefile
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e /^install-doc/d \
- -e /\ $$\(DESTDOCDIR\)/d \
- -e 's/install-doc//' \
- ${WRKSRC}/Makefile
-.endif
-.if defined(NOPORTEXAMPLES)
- @${REINPLACE_CMD} -e /^install-exp/d \
- -e /\ $$\(DESTEXPDIR\)/d \
- -e 's/install-exp//' \
- ${WRKSRC}/Makefile
-.endif
-
-post-install:
- @${ECHO_MSG} "updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @(${GREP} -v ${PREFIX}/bin/osh /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/osh) > /etc/shells
- @${RM} /etc/shells.bak
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/osh/pkg-plist b/shells/osh/pkg-plist
index 64188eec4002..23249c25b3db 100644
--- a/shells/osh/pkg-plist
+++ b/shells/osh/pkg-plist
@@ -4,5 +4,11 @@ bin/if
bin/osh
bin/sh6
bin/glob6
+man/man1/fd2.1.gz
+man/man1/glob6.1.gz
+man/man1/goto.1.gz
+man/man1/if.1.gz
+man/man1/osh.1.gz
+man/man1/sh6.1.gz
@exec echo "updating ${DESTDIR}/etc/shells"; cp ${DESTDIR}/etc/shells ${DESTDIR}/etc/shells.bak; (grep -v %D/%F ${DESTDIR}/etc/shells.bak; echo %D/%F) >${DESTDIR}/etc/shells
@unexec echo "updating ${DESTDIR}/etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells