aboutsummaryrefslogtreecommitdiff
path: root/shells/v7sh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-20 22:16:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-20 22:16:38 +0000
commitf4058c48e5cba0758cb1a60bf3f9a943f75a9839 (patch)
treefac29c92f7999f8b0504b3637755d4c30912a87c /shells/v7sh
parentd2d851bba81427db22a4b3ddfd418dd12a1491a9 (diff)
downloadports-f4058c48e5cba0758cb1a60bf3f9a943f75a9839.tar.gz
ports-f4058c48e5cba0758cb1a60bf3f9a943f75a9839.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=301258
Diffstat (limited to 'shells/v7sh')
-rw-r--r--shells/v7sh/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/shells/v7sh/Makefile b/shells/v7sh/Makefile
index 209ac769f491..e6111230bd39 100644
--- a/shells/v7sh/Makefile
+++ b/shells/v7sh/Makefile
@@ -31,19 +31,21 @@ NO_WRKSUBDIR= yes
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
-OPTIONS= V7SH_SYSIII "System III enhancements" on \
- V7SH_RENO "4.3BSD-Reno enhancements" on \
- V7SH_ULTRIX "Ultrix 3.1 enhancements" on
+OPTIONS_DEFINE= SYSIII RENO ULTRIX
+OPTIONS_DEFAULT= SYSIII RENO ULTRIX
+SYSIII_DESC= System III enhancements
+RENO_DESC= 4.3BSD-Reno enhancements
+ULTRIX_DESC= Ultrix 3.1 enhancements
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_V7SH_SYSIII)
+.if ${PORT_OPTIONS:MSYSIII}
CFLAGS+= -DSYSIII
.endif
-.if !defined(WITHOUT_V7SH_RENO)
+.if ${PORT_OPTIONS:MRENO}
CFLAGS+= -DRENO
.endif
-.if !defined(WITHOUT_V7SH_ULTRIX)
+.if ${PORT_OPTIONS:MULTRIX}
CFLAGS+= -DULTRIX
.endif
@@ -60,4 +62,4 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/${PORTNAME}) > /etc/shells
@${RM} /etc/shells.bak
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>