aboutsummaryrefslogtreecommitdiff
path: root/shells/xonsh
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2017-09-22 14:57:41 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2017-09-22 14:57:41 +0000
commita99b06d58b8814c043cbea23a1cd87fd8b3a6e8f (patch)
tree5b743034ac0b7e422656b532399187f26aecacfb /shells/xonsh
parentcdad5a196f5ca31095fbfe2ed4eee181c1f59754 (diff)
downloadports-a99b06d58b8814c043cbea23a1cd87fd8b3a6e8f.tar.gz
ports-a99b06d58b8814c043cbea23a1cd87fd8b3a6e8f.zip
xonsh is a Python-ish, BASHwards-looking shell language and command prompt.
The language is a superset of Python 3.4+ with additional shell primitives. xonsh (pronounced conch) is meant for the daily use of experts and novices alike. WWW: http://xon.sh PR: 220596 Submitted by: roberfern@gmail.com
Notes
Notes: svn path=/head/; revision=450378
Diffstat (limited to 'shells/xonsh')
-rw-r--r--shells/xonsh/Makefile21
-rw-r--r--shells/xonsh/distinfo3
-rw-r--r--shells/xonsh/files/patch-xonsh_platform.py11
-rw-r--r--shells/xonsh/files/patch-xonsh_xoreutils_uptime.py11
-rw-r--r--shells/xonsh/pkg-descr7
5 files changed, 53 insertions, 0 deletions
diff --git a/shells/xonsh/Makefile b/shells/xonsh/Makefile
new file mode 100644
index 000000000000..6ff3dc0bb8c3
--- /dev/null
+++ b/shells/xonsh/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= xonsh
+PORTVERSION= 0.5.12
+CATEGORIES= shells python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= roberfern@gmail.com
+COMMENT= Python-ish BASH-wards shell
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}amalgamate>=0:devel/py-amalgamate
+
+NO_ARCH= yes
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist concurrent
+
+.include <bsd.port.mk>
diff --git a/shells/xonsh/distinfo b/shells/xonsh/distinfo
new file mode 100644
index 000000000000..51bf7ebc43b8
--- /dev/null
+++ b/shells/xonsh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1506080374
+SHA256 (xonsh-0.5.12.tar.gz) = 4ca8fd5f1ce5532fba252132a7a7db26b38d80429d8d538928d1aed26149e5fb
+SIZE (xonsh-0.5.12.tar.gz) = 686495
diff --git a/shells/xonsh/files/patch-xonsh_platform.py b/shells/xonsh/files/patch-xonsh_platform.py
new file mode 100644
index 000000000000..cca4ca00ecfc
--- /dev/null
+++ b/shells/xonsh/files/patch-xonsh_platform.py
@@ -0,0 +1,11 @@
+--- xonsh/platform.py.orig 2017-03-12 02:36:40 UTC
++++ xonsh/platform.py
+@@ -491,7 +491,7 @@ def LIBC():
+ libc = ctypes.CDLL('cygwin1.dll')
+ elif ON_BSD:
+ try:
+- libc = ctypes.CDLL('libc.so')
++ libc = ctypes.CDLL(ctypes.util.find_library("c"))
+ except AttributeError:
+ libc = None
+ except OSError:
diff --git a/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py b/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
new file mode 100644
index 000000000000..8d0525adf5e3
--- /dev/null
+++ b/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
@@ -0,0 +1,11 @@
+--- xonsh/xoreutils/uptime.py.orig 2017-02-11 16:24:07 UTC
++++ xonsh/xoreutils/uptime.py
+@@ -100,7 +100,7 @@ def _uptime_bsd():
+ return None
+ # Determine how much space we need for the response.
+ sz = ctypes.c_uint(0)
+- xp.LIBC.sysctlbyname('kern.boottime', None, ctypes.byref(sz), None, 0)
++ xp.LIBC.sysctlbyname(b'kern.boottime', None, ctypes.byref(sz), None, 0)
+ if sz.value != struct.calcsize('@LL'):
+ # Unexpected, let's give up.
+ return None
diff --git a/shells/xonsh/pkg-descr b/shells/xonsh/pkg-descr
new file mode 100644
index 000000000000..1c0aa70c84cd
--- /dev/null
+++ b/shells/xonsh/pkg-descr
@@ -0,0 +1,7 @@
+xonsh is a Python-ish, BASHwards-looking shell language and command prompt.
+
+The language is a superset of Python 3.4+ with additional shell primitives.
+xonsh (pronounced conch) is meant for the daily use of experts and novices
+alike.
+
+WWW: http://xon.sh