aboutsummaryrefslogtreecommitdiff
path: root/shells/yash
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2019-06-30 16:42:57 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2019-06-30 16:42:57 +0000
commitf4cad688e1fceb4897f7f2aaecabb0957d49a74d (patch)
tree5722dd82be94600c2baba2367f4924c34396d98c /shells/yash
parentb477e8a9bc3b92da6d31ae2fe5a8a3efa587f7a3 (diff)
downloadports-f4cad688e1fceb4897f7f2aaecabb0957d49a74d.tar.gz
ports-f4cad688e1fceb4897f7f2aaecabb0957d49a74d.zip
Yash is explicitly written in C99. GCC 4.2 can handle this without
requiring a C11 compiler.
Notes
Notes: svn path=/head/; revision=505439
Diffstat (limited to 'shells/yash')
-rw-r--r--shells/yash/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/shells/yash/Makefile b/shells/yash/Makefile
index 908e35a5480e..e0e649002cbb 100644
--- a/shells/yash/Makefile
+++ b/shells/yash/Makefile
@@ -11,10 +11,11 @@ COMMENT= POSIX-compliant command line shell
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c11 tar:xz
+USES= tar:xz
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
+CPPFLAGS+= -std=c99
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes