aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh-antigen
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-06-18 04:59:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-06-18 04:59:40 +0000
commit8e41b33ef0ef9951fef07674aaea15342eaca3de (patch)
tree2bacf687e0187caa7e1a873c1a1bcd77ba99a2b9 /shells/zsh-antigen
parent89626e215e7c8bead2792061d0961914486ac15a (diff)
downloadports-8e41b33ef0ef9951fef07674aaea15342eaca3de.tar.gz
ports-8e41b33ef0ef9951fef07674aaea15342eaca3de.zip
New port: shells/zsh-antigen
Antigen is a small set of functions that help you easily manage your Z shell (zsh) plugins, called bundles. The concept is pretty much the same as bundles in a typical vim+pathogen setup. Antigen is to zsh, what Vundle is to vim. WWW: https://github.com/zsh-users/antigen PR: 217706 Submitted by: Victor <gudfitz@gmail.com>
Notes
Notes: svn path=/head/; revision=472672
Diffstat (limited to 'shells/zsh-antigen')
-rw-r--r--shells/zsh-antigen/Makefile30
-rw-r--r--shells/zsh-antigen/distinfo3
-rw-r--r--shells/zsh-antigen/files/pkg-message.in1
-rw-r--r--shells/zsh-antigen/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/shells/zsh-antigen/Makefile b/shells/zsh-antigen/Makefile
new file mode 100644
index 000000000000..c506b9892c03
--- /dev/null
+++ b/shells/zsh-antigen/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= zsh-antigen
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.2.3
+CATEGORIES= shells
+
+MAINTAINER= gudfitz@gmail.com
+COMMENT= Tool for managing Zshell plugins inspired by Vundle
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zsh>=4.3.11:shells/zsh \
+ git:devel/git
+
+USE_GITHUB= yes
+GH_ACCOUNT= zsh-users
+GH_PROJECT= antigen
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= ${DATADIR}/antigen.zsh
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/antigen.zsh ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/shells/zsh-antigen/distinfo b/shells/zsh-antigen/distinfo
new file mode 100644
index 000000000000..d926a3e39877
--- /dev/null
+++ b/shells/zsh-antigen/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529013823
+SHA256 (zsh-users-antigen-v2.2.3_GH0.tar.gz) = bd3f1077050d52f459bc30fa3f025c44c528d625b4924a2f487fd2bacb89d61e
+SIZE (zsh-users-antigen-v2.2.3_GH0.tar.gz) = 72679
diff --git a/shells/zsh-antigen/files/pkg-message.in b/shells/zsh-antigen/files/pkg-message.in
new file mode 100644
index 000000000000..7f44543fee12
--- /dev/null
+++ b/shells/zsh-antigen/files/pkg-message.in
@@ -0,0 +1 @@
+Antigen can be found at %%DATADIR%%/antigen.zsh
diff --git a/shells/zsh-antigen/pkg-descr b/shells/zsh-antigen/pkg-descr
new file mode 100644
index 000000000000..35d3efca375e
--- /dev/null
+++ b/shells/zsh-antigen/pkg-descr
@@ -0,0 +1,6 @@
+Antigen is a small set of functions that help you easily manage
+your Z shell (zsh) plugins, called bundles. The concept is pretty
+much the same as bundles in a typical vim+pathogen setup. Antigen
+is to zsh, what Vundle is to vim.
+
+WWW: https://github.com/zsh-users/antigen