aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-01-27 16:43:30 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-01-27 16:43:30 +0000
commit3f35201af5d39563a8dbd5b58074643c9dde8a17 (patch)
tree112c99945f72eb840be5d4fded04259a5f953b1b /shells/zsh
parent85d4d7813b791d01de3d07f21a20449a2a7ceb86 (diff)
downloadports-3f35201af5d39563a8dbd5b58074643c9dde8a17.tar.gz
ports-3f35201af5d39563a8dbd5b58074643c9dde8a17.zip
Notes
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile3
-rw-r--r--shells/zsh/files/vcs_info_p4.patch35
2 files changed, 38 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index a0ea7a2d076f..9cdbdfb85d50 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zsh
DISTVERSION= 5.7
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://www.zsh.org/pub/ \
SF \
@@ -22,6 +23,8 @@ MAKE_JOBS_UNSAFE= yes
USES= autoreconf iconv ncurses shebangfix tar:xz
+EXTRA_PATCHES= ${FILESDIR}/vcs_info_p4.patch:-p1
+
SHEBANG_LANG= zsh
zsh_OLD_CMD= zsh # shebang appears as /bin/zsh and just zsh
SHEBANG_FILES= Functions/Calendar/* \
diff --git a/shells/zsh/files/vcs_info_p4.patch b/shells/zsh/files/vcs_info_p4.patch
new file mode 100644
index 000000000000..042b948b23d7
--- /dev/null
+++ b/shells/zsh/files/vcs_info_p4.patch
@@ -0,0 +1,35 @@
+From b70919e0d9dadc93893e9d18bc3ef13b88756ecf Mon Sep 17 00:00:00 2001
+From: dana <dana@dana.is>
+Date: Sun, 27 Jan 2019 00:26:31 -0600
+Subject: [PATCH] 44020: VCS_INFO_detect_p4: Fix infinite recursion
+
+---
+ ChangeLog | 5 +++++
+ Functions/VCS_Info/Backends/VCS_INFO_detect_p4 | 1 -
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index 81668ccc9..be243c1b8 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,8 @@
++2018-01-27 dana <dana@dana.is>
++
++ * 44020: Functions/VCS_Info/Backends/VCS_INFO_detect_p4: Fix
++ infinite recursion
++
+ 2018-01-24 dana <dana@dana.is>
+
+ * unposted: Config/version.mk: Post-release version bump
+diff --git a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4 b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+index d171c68ee..5ec21da9f 100644
+--- a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
++++ b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+@@ -44,7 +44,6 @@ VCS_INFO_p4_get_server() {
+ }
+
+
+-(( ${+functions[VCS_INFO_detect_p4]} )) ||
+ VCS_INFO_detect_p4() {
+ local serverport p4where
+