aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-12-23 22:56:46 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-12-23 22:56:46 +0000
commit625ae90c2288d9a04f57a2bd81e00b3c5ed994e9 (patch)
tree5885b525a59df4fafae85712c969449461cb8711 /shells/zsh
parent97f14f4839a23770f4f166fda3e8990735bd4d7c (diff)
downloadports-625ae90c2288d9a04f57a2bd81e00b3c5ed994e9.tar.gz
ports-625ae90c2288d9a04f57a2bd81e00b3c5ed994e9.zip
Partially revert r403755. It can't build the curses module against ncurses from
ports. It probably can, but configure is too smart to figure that out. I have no confidence that linking against curses from ports results in a properly working zshell. So, for now, back out the change. It will build a shared lib zsh against ncurses from ports, but breaks statically-linked zsh's. Mark the port as IGNORE if we're using ncurses from ports and building a static zsh. Also, remove a regression-test target that isn't useful anymore (thanks to bapt for the reminder about this). I am not enthused about this change. It doesn't really "fix" the below PR, so much as shoot ourselves in the other foot instead. PR: 205500
Notes
Notes: svn path=/head/; revision=404326
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index bebc9657da26..0b685a6ff5ed 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -41,7 +41,7 @@ TEST_TARGET= test
CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
CONFIGURE_ENV+= zsh_cv_sys_path_dev_fd=no
-CONFIGURE_ARGS= --with-term-lib="tinfow tinfo" --with-tcsetpgrp \
+CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
--enable-function-subdirs --enable-multibyte \
--sysconfdir=${PREFIX}/etc
@@ -86,6 +86,10 @@ DEBUG_CONFIGURE_ENABLE= zsh-debug
CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
.endif
+.if (${NCURSESBASE} == ${LOCALBASE}) && ${PORT_OPTIONS:MSTATIC}
+IGNORE= cannot statically link against ncurses from ports. Either deinstall the ncurses port or turn off the STATIC option
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' -e '1s|zsh|${zsh_CMD}|' ${WRKSRC}/Functions/Misc/run-help-ip
@${REINPLACE_CMD} -e '/LIBS/s/-lrt//' ${WRKSRC}/configure
@@ -133,7 +137,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
-regression-test:
- @(cd ${WRKSRC}; ${SETENV} -i ${MAKE} check)
-
.include <bsd.port.post.mk>