aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-06-15 12:36:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-06-15 12:36:13 +0000
commit641184f77fa6de1b05bd09bf582324b9de93d3df (patch)
tree44fcdd97ba66dda9249f02c9ea500e01f7302fb3 /shells/zsh
parente9073fdf784f0de3e8fa23ad11b97939f9d5d546 (diff)
downloadports-641184f77fa6de1b05bd09bf582324b9de93d3df.tar.gz
ports-641184f77fa6de1b05bd09bf582324b9de93d3df.zip
Fix du(1) completion
PR: 200768 Obtained from: ZSH upstream
Notes
Notes: svn path=/head/; revision=389703
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile2
-rw-r--r--shells/zsh/files/patch-Completion_Unix_Command___du9
2 files changed, 10 insertions, 1 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index c97c3e719cde..7e3982df7cf1 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zsh
PORTVERSION= 5.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
MASTER_SITES= http://www.zsh.org/pub/ \
http://www.zsh.org/pub/:doc \
diff --git a/shells/zsh/files/patch-Completion_Unix_Command___du b/shells/zsh/files/patch-Completion_Unix_Command___du
new file mode 100644
index 000000000000..f990131d725c
--- /dev/null
+++ b/shells/zsh/files/patch-Completion_Unix_Command___du
@@ -0,0 +1,9 @@
+--- Completion/Unix/Command/_du.orig 2015-05-03 17:57:18 UTC
++++ Completion/Unix/Command/_du
+@@ -74,5 +74,5 @@ else
+ do
+ [[ $OSTYPE = $~pattern ]] && args+=( $arg )
+ done
+- _arguments -s -A "-*" $args
++ _arguments -s -A "-*" $args '*:file:_files'
+ fi