aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-06-02 18:51:15 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-06-02 18:51:15 +0000
commit648b6ac9620914466695dc62f3e021c23b96c1ea (patch)
treeebb2f5081950aa91e44eb7f327f872681e10169d /shells/zsh
parent74f7c1bb9c4debd7c4b3b608d29a4dade31199e4 (diff)
downloadports-648b6ac9620914466695dc62f3e021c23b96c1ea.tar.gz
ports-648b6ac9620914466695dc62f3e021c23b96c1ea.zip
Update to 5.0.8
Among the usual updates, users will be happy to discover plenty of new FreeBSD related completion as well as zpty working out of box (which wasn't the case anymore for a while)
Notes
Notes: svn path=/head/; revision=388381
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile7
-rw-r--r--shells/zsh/distinfo8
-rw-r--r--shells/zsh/files/patch-Completion_BSD_Command___kld11
-rw-r--r--shells/zsh/files/patch-Src_Modules_zpty.c11
-rw-r--r--shells/zsh/files/patch-Src_zsh.mdd22
5 files changed, 19 insertions, 40 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 00b70c51c991..371d26f8a4c0 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= zsh
-PORTVERSION= 5.0.7
-PORTREVISION= 4
+PORTVERSION= 5.0.8
CATEGORIES= shells
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
+MASTER_SITES= http://www.zsh.org/pub/ \
+ http://www.zsh.org/pub/:doc \
+ SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/shells/zsh/distinfo b/shells/zsh/distinfo
index 0b2c9b69b08c..046abd2a84ba 100644
--- a/shells/zsh/distinfo
+++ b/shells/zsh/distinfo
@@ -1,4 +1,4 @@
-SHA256 (zsh-5.0.7.tar.bz2) = 544e27de81740286b916d1d77c9f48ad7c26ad7943ed96d278abee67cf6704b3
-SIZE (zsh-5.0.7.tar.bz2) = 3181030
-SHA256 (zsh-5.0.7-doc.tar.bz2) = 43e8665ba9d9eca8370c64e2d4846e84f9111c628e5792f2aa639a7fb209fcf1
-SIZE (zsh-5.0.7-doc.tar.bz2) = 3005587
+SHA256 (zsh-5.0.8.tar.bz2) = 8079cf08cb8beff22f84b56bd72bb6e6962ff4718d816f3d83a633b4c9e17d23
+SIZE (zsh-5.0.8.tar.bz2) = 3250542
+SHA256 (zsh-5.0.8-doc.tar.bz2) = 0ee5088c47fa5ceac6e087c7e00f2ede3f5920a03d32220772342ce980339e40
+SIZE (zsh-5.0.8-doc.tar.bz2) = 3204865
diff --git a/shells/zsh/files/patch-Completion_BSD_Command___kld b/shells/zsh/files/patch-Completion_BSD_Command___kld
deleted file mode 100644
index 7a49642520dc..000000000000
--- a/shells/zsh/files/patch-Completion_BSD_Command___kld
+++ /dev/null
@@ -1,11 +0,0 @@
---- Completion/BSD/Command/_kld.orig 2013-11-27 19:00:18 UTC
-+++ Completion/BSD/Command/_kld
-@@ -4,7 +4,7 @@
- _kld_module() {
- local ret=1
-
-- compadd "$@" - /boot/kernel/*.ko(-.:t) /modules/*.ko(-.:t) && ret=0
-+ compadd "$@" - /boot/{kernel,modules}/*.ko(-.:t) && ret=0
- _files "$@" -g '*.ko(-.)' && ret=0
-
- return ret
diff --git a/shells/zsh/files/patch-Src_Modules_zpty.c b/shells/zsh/files/patch-Src_Modules_zpty.c
new file mode 100644
index 000000000000..f0e3b199d8d2
--- /dev/null
+++ b/shells/zsh/files/patch-Src_Modules_zpty.c
@@ -0,0 +1,11 @@
+--- Src/Modules/zpty.c.orig 2015-06-02 06:51:05.604875000 +0200
++++ Src/Modules/zpty.c 2015-06-02 00:07:36.672596000 +0200
+@@ -154,7 +154,7 @@ getptycmd(char *name)
+ return NULL;
+ }
+
+-#ifdef USE_DEV_PTMX
++#if defined(HAVE_POSIX_OPENPT) || defined(USE_DEV_PTMX)
+
+ #ifdef HAVE_SYS_STROPTS_H
+ #include <sys/stropts.h>
diff --git a/shells/zsh/files/patch-Src_zsh.mdd b/shells/zsh/files/patch-Src_zsh.mdd
deleted file mode 100644
index 9cf32f03afb4..000000000000
--- a/shells/zsh/files/patch-Src_zsh.mdd
+++ /dev/null
@@ -1,22 +0,0 @@
---- Src/zsh.mdd.orig 2014-09-20 19:01:46 UTC
-+++ Src/zsh.mdd
-@@ -21,9 +21,18 @@ hdrdeps="zshcurses.h zshterm.h"
- :<<\Make
- @CONFIG_MK@
-
-+# If we're using gcc as the preprocessor, get rid of the additional
-+# lines generated by the preprocessor as they can confuse the script.
-+# We don't need these in other cases either, but can't necessarily rely
-+# on the option to remove them being the same.
- signames.c: signames1.awk signames2.awk ../config.h @SIGNAL_H@
- $(AWK) -f $(sdir)/signames1.awk @SIGNAL_H@ >sigtmp.c
-- $(CPP) sigtmp.c >sigtmp.out
-+ case "`$(CPP) --version </dev/null 2>&1`" in \
-+ *"Free Software Foundation"*) \
-+ $(CPP) -P sigtmp.c >sigtmp.out;; \
-+ *) \
-+ $(CPP) sigtmp.c >sigtmp.out;; \
-+ esac
- $(AWK) -f $(sdir)/signames2.awk sigtmp.out > $@
- rm -f sigtmp.c sigtmp.out
-