aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-12-24 17:50:56 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-12-24 17:50:56 +0000
commit69d974e963637bc89336ca472914bf7d686b0754 (patch)
treecf711ff971bfd8dec3c00b3272df2b818ffde2f8 /shells/zsh
parent5eea2045926d07b20405d0df90cf960245ea6540 (diff)
downloadports-69d974e963637bc89336ca472914bf7d686b0754.tar.gz
ports-69d974e963637bc89336ca472914bf7d686b0754.zip
Fix ncurses detection properly. Now zsh builds and packages properly with
base and ports ncurses, static or non-static. Many thanks to bapt for showing me the magic trick here!
Notes
Notes: svn path=/head/; revision=404382
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 0b685a6ff5ed..cd233595b06e 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -41,7 +41,7 @@ TEST_TARGET= test
CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
CONFIGURE_ENV+= zsh_cv_sys_path_dev_fd=no
-CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
+CONFIGURE_ARGS= --with-tcsetpgrp \
--enable-function-subdirs --enable-multibyte \
--sysconfdir=${PREFIX}/etc
@@ -76,8 +76,8 @@ MEM_CONFIGURE_ENABLE= zsh-mem
SECURE_FREE_CONFIGURE_ENABLE= zsh-secure-free
MAILDIR_CONFIGURE_ENABLE= maildir-support
STATIC_LDFLAGS= -static
-STATIC_CONFIGURE_ON= --disable-dynamic
-STATIC_CONFIGURE_OFF= --enable-dynamic
+STATIC_CONFIGURE_ON= --disable-dynamic --with-term-lib="tinfow tinfo"
+STATIC_CONFIGURE_OFF= --enable-dynamic --with-term-lib="ncursesw ncurses"
DEBUG_CONFIGURE_ENABLE= zsh-debug
.include <bsd.port.pre.mk>
@@ -86,10 +86,6 @@ DEBUG_CONFIGURE_ENABLE= zsh-debug
CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
.endif
-.if (${NCURSESBASE} == ${LOCALBASE}) && ${PORT_OPTIONS:MSTATIC}
-IGNORE= cannot statically link against ncurses from ports. Either deinstall the ncurses port or turn off the STATIC option
-.endif
-
post-patch:
@${REINPLACE_CMD} -i '' -e '1s|zsh|${zsh_CMD}|' ${WRKSRC}/Functions/Misc/run-help-ip
@${REINPLACE_CMD} -e '/LIBS/s/-lrt//' ${WRKSRC}/configure