aboutsummaryrefslogtreecommitdiff
path: root/shells/zsh
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-31 14:35:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-07-31 14:35:39 +0000
commitcc1adc655e0072ee710ff8abb30b64165c07db55 (patch)
tree932411a771a610f87c1668a2e4af18daae30f979 /shells/zsh
parent4b507dc05452f7ead78cd0355843c8fe8dd9b445 (diff)
downloadports-cc1adc655e0072ee710ff8abb30b64165c07db55.tar.gz
ports-cc1adc655e0072ee710ff8abb30b64165c07db55.zip
- Fix shebangs
Approved by: portmgr blanket MFH: 2015Q3 (blanket)
Notes
Notes: svn path=/head/; revision=393309
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index d1199e7763d6..a93fb60c3689 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zsh
PORTVERSION= 5.0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MASTER_SITES= \
SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
@@ -24,7 +24,17 @@ MAKE_JOBS_UNSAFE= yes
ZSH_VER= ${PORTVERSION}
-USES= iconv ncurses tar:bzip2
+USES= iconv ncurses shebangfix tar:bzip2
+SHEBANG_FILES= Functions/Calendar/calendar_add \
+ Functions/Misc/checkmail \
+ Functions/Misc/run-help \
+ Functions/Misc/sticky-note \
+ Functions/Misc/zcalc \
+ Functions/Misc/zed \
+ Functions/Misc/zkbd
+SHEBANG_LANG= zsh
+zsh_OLD_CMD= /bin/zsh
+zsh_CMD= ${PREFIX}/bin/zsh
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
@@ -76,6 +86,7 @@ CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
.endif
post-patch:
+ @${REINPLACE_CMD} -i '' -e '1s|zsh|${zsh_CMD}|' ${WRKSRC}/Functions/Misc/run-help-ip
@${REINPLACE_CMD} -e '/LIBS/s/-lrt//' ${WRKSRC}/configure
@${SED} -i "" -e "s,link=dynamic,link=either," \
${WRKSRC}/Src/Modules/*.mdd