aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2008-10-08 07:52:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2008-10-08 07:52:48 +0000
commit27f99df1124d197dcbfa24af98c1a0cc5a94310b (patch)
tree3a1b60e1ec31bb26d33a5bc1785965af17588a4f /shells
parent6be1a757a06077a38add7c704229a9038655a3fa (diff)
downloadports-27f99df1124d197dcbfa24af98c1a0cc5a94310b.tar.gz
ports-27f99df1124d197dcbfa24af98c1a0cc5a94310b.zip
Update to 3.00c.
Notes
Notes: svn path=/head/; revision=221322
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile9
-rw-r--r--shells/fd/distinfo6
-rw-r--r--shells/fd/files/patch-_fdrc80
-rw-r--r--shells/fd/files/patch-ungetkey294
4 files changed, 71 insertions, 118 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index df212f4b68c0..12f0f4ca5935 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= fd
-PORTVERSION= 2.09i
-PORTREVISION= 1
-CATEGORIES= shells
-MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/old/ \
- ftp://ftp.unixusers.net/src/fdclone/old/
+PORTVERSION= 3.00c
+CATEGORIES= shells net
+MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
+ ftp://ftp.unixusers.net/src/fdclone/
DISTNAME= FD-${PORTVERSION}
MAINTAINER= knu@FreeBSD.org
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index db153351b7cd..128cec725d62 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1,3 +1,3 @@
-MD5 (FD-2.09i.tar.gz) = 460a1a1df609f1d0acfb4806c1548de6
-SHA256 (FD-2.09i.tar.gz) = c020389f5cd843104f12c12d416e2dacc47386c79f4bdb227f27f999ef332c88
-SIZE (FD-2.09i.tar.gz) = 807362
+MD5 (FD-3.00c.tar.gz) = 4abb712a04c1f6b332d61f86dcc91bd5
+SHA256 (FD-3.00c.tar.gz) = 37e3a7cb6a0f8d4d2051f4a728c00a0fc193f96223874c42984061331ad354ce
+SIZE (FD-3.00c.tar.gz) = 917865
diff --git a/shells/fd/files/patch-_fdrc b/shells/fd/files/patch-_fdrc
index ec19e2e368c9..1d09363c5e48 100644
--- a/shells/fd/files/patch-_fdrc
+++ b/shells/fd/files/patch-_fdrc
@@ -1,47 +1,87 @@
---- _fdrc.orig Thu Mar 30 00:00:00 2006
-+++ _fdrc Fri Apr 7 13:20:15 2006
-@@ -13,2 +13,3 @@
+--- _fdrc.orig 2008-07-27 00:00:00.000000000 +0900
++++ _fdrc 2008-10-08 16:44:12.000000000 +0900
+@@ -17,6 +17,7 @@
+ # 200-213: preserve previous sort type also in the archive browser
+ # (the least 2 digits are effective just after initialize)
#SORTTYPE=0
+FD_SORTTYPE=101
-@@ -29,2 +30,3 @@
+ # default display mode
+ # 0: normal (Default)
+@@ -33,12 +34,14 @@
+ # 0: not sort (Default)
+ # >= 1: sort according to SORTTYPE
#SORTTREE=0
+FD_SORTTREE=1
-@@ -35,2 +37,3 @@
+ # behavior about writing over directory on file system
+ # 0: confirm to write or not, after directory arranged (Default)
+ # 1: write directory only if commanded
+ # 2: never write over directory even if commanded
#WRITEFS=0
+FD_WRITEFS=1
-@@ -45,2 +48,3 @@
+ # whether if ignore uppercase or lowercase in filename comparison
+ # 0: not ignore (Default)
+@@ -49,6 +52,7 @@
+ # 0: not inherit (Default)
+ # >= 1: inherit
#INHERITCOPY=0
+FD_INHERITCOPY=1
-@@ -62,2 +66,3 @@
+ # whether if display progress bar on copying/moving files
+ # 0: not dislpay (Default)
+@@ -76,6 +80,7 @@
+ # 3: 3 columns
+ # 5: 5 columns
#DEFCOLUMNS=2
+FD_DEFCOLUMNS=1
-@@ -113,2 +118,3 @@
+ # minimum columns of filename field
+ # Default: 12
+@@ -156,6 +161,7 @@
+ # 2: color & force background to blacken
+ # 3: color & force foreground to blacken
#ANSICOLOR=0
+FD_ANSICOLOR=1
-@@ -226,2 +232,3 @@
+ # color palette in the ANSI color mode
+ # Default: none
+@@ -270,6 +276,7 @@
+ # 0: evaluate arguments (Default)
+ # >= 1: pass through
#THRUARGS=0
+FD_THRUARGS=1
-@@ -246,2 +253,3 @@
+ # whether if make URL drive effective
+ # 0: not use (Default)
+@@ -365,6 +372,7 @@
+ # utf8-iconv, UTF8-ICONV: UTF-8 for iconv
+ # en, EN, C: English
#LANGUAGE=""
+FD_LANGUAGE=$LANG
-@@ -356,2 +364,3 @@
+ # system default Kanji code
+ # Default: No convert
+@@ -507,13 +515,52 @@
+ #NOCONVPATH=""
+
#PAGER=more%K
+FD_PAGER=${PAGER:-/usr/bin/more}%K
#EDITOR=vi
-@@ -363,2 +372,38 @@
- # launcher definition
+ #SHELL=/bin/sh
+
+ # for Mischievous Japanese OS (see `man fd')
+ #export LANG=C
+
+-# launcher definition
++# launcher definitions
+tar="tar"
+tar_format="%a %u/%g %s %m %d %t %y %f"
+
-+launch "/.tar" "$tar tvf" "$tar_format"
++for ext in /.tar .gem; do
++ launch "$ext" "$tar tvf" "$tar_format"
++done
+
+for ext in .tar.Z .taZ .TAZ; do
+ launch "$ext" "$tar Ztvf %C" "$tar_format"
@@ -75,7 +115,11 @@
+arch "/.aa" "echo ERROR" "cat %X.?? | $tar zxf - %TA"
+
#(Default)
-@@ -476,2 +521,39 @@
+ #launch ".lzh" "lha l" \
+ # -f "%a %u/%g %s %x %m %d %{yt} %*f" \
+@@ -634,6 +681,43 @@
+ #launch ".zip" "pkunzip -vb %S" " %s %x %x %x %y-%m-%d %t %*f" 14 2
+
# archiver definition
+
+for ext in /.tar; do
@@ -115,7 +159,11 @@
+arch ".uu" "_uuencode %C %TA" "uudecode -ic < %C"
+
#(Default)
-@@ -569 +651,5 @@
+ #arch ".lzh" "lha aq %C %TA" "lha xq %C %TA"
+ #arch ".tar" "tar cf %C %T" "tar xf %C %TA"
+@@ -727,3 +811,7 @@
+ # keymap definition
+ #(Example)
#keymap DEL "\033[3~"
+
+if [ -f /etc/fd2rc.local ]; then
diff --git a/shells/fd/files/patch-ungetkey2 b/shells/fd/files/patch-ungetkey2
deleted file mode 100644
index 2a8309a171dc..000000000000
--- a/shells/fd/files/patch-ungetkey2
+++ /dev/null
@@ -1,94 +0,0 @@
---- input.c.orig 2008-04-19 00:00:00.000000000 +0900
-+++ input.c 2008-07-16 15:11:17.000000000 +0900
-@@ -256,7 +256,7 @@ int key;
- else if ((c = getch2()) == EOF) /*EMPTY*/;
- else if (c != K_ESC) /*EMPTY*/;
- else if (kbhit2(WAITKEYPAD * 1000L)) {
-- ungetkey2(c);
-+ ungetkey2(c, 0);
- c = EOF;
- }
-
-@@ -266,7 +266,7 @@ int key;
- else fprintf2(stderr, "%k\n", INTR_K);
- }
- else {
-- ungetkey2(c);
-+ ungetkey2(c, 0);
- c = EOF;
- }
- errno = duperrno;
-@@ -372,7 +372,7 @@ int sig;
- {
- int n;
-
-- for (n = ungetnum3 - 1; n >= 0; n--) ungetkey2((int)ungetbuf3[n]);
-+ for (n = 0; n < ungetnum3; n++) ungetkey2((int)ungetbuf3[n], 0);
- # ifndef _NOIME
- if (imemode && !ungetnum3 && getime(sig, &n, 0) >= 0) /*EMPTY*/;
- else
---- main.c.orig 2008-04-19 00:00:00.000000000 +0900
-+++ main.c 2008-07-16 15:08:58.000000000 +0900
-@@ -681,7 +681,7 @@ int forced;
- checkscreen(-1, -1);
- if (isorgpid()) {
- if (x != n_column || y != n_line) rewritefile(1);
-- if (subwindow) ungetkey2(K_CTRL('L'));
-+ if (subwindow) ungetkey2(K_CTRL('L'), 1);
- }
- }
- }
---- term.c.orig 2008-04-19 00:00:00.000000000 +0900
-+++ term.c 2008-07-16 15:08:58.000000000 +0900
-@@ -2905,14 +2905,17 @@ int sig, code;
- return(ch);
- }
-
--int ungetkey2(c)
--int c;
-+int ungetkey2(c, desc)
-+int c, desc;
- {
- if (c == EOF || ttyio < 0) return(EOF);
- if (ungetnum >= arraysize(ungetbuf)) return(EOF);
-- memmove((char *)&(ungetbuf[1]), (char *)&(ungetbuf[0]),
-- ungetnum * sizeof(u_char));
-- ungetbuf[0] = (u_char)c;
-+ if (!desc) ungetbuf[ungetnum] = (u_char)c;
-+ else {
-+ memmove((char *)&(ungetbuf[1]),
-+ (char *)&(ungetbuf[0]), ungetnum * sizeof(u_char));
-+ ungetbuf[0] = (u_char)c;
-+ }
- ungetnum++;
-
- return(c);
-@@ -3155,14 +3158,15 @@ int sig, code;
- return(alternate(ch));
- }
-
--int ungetkey2(c)
--int c;
-+int ungetkey2(c, desc)
-+int c, desc;
- {
- # ifdef TIOCSTI
- u_char ch;
- # endif
-
- if (c == EOF || ttyio < 0) return(EOF);
-+ if (!desc) return(ungetch2(c));
- # ifdef TIOCSTI
- ch = c;
- Xioctl(ttyio, TIOCSTI, &ch);
---- term.h.orig 2008-04-19 00:00:00.000000000 +0900
-+++ term.h 2008-07-16 15:08:58.000000000 +0900
-@@ -217,7 +217,7 @@ extern int getkey2 __P_((int, int));
- #else
- extern int getkey3 __P_((int, int));
- #endif
--extern int ungetkey2 __P_((int));
-+extern int ungetkey2 __P_((int, int));
- extern int setscroll __P_((int, int));
- extern int locate __P_((int, int));
- extern int tflush __P_((VOID_A));