aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2018-09-15 12:34:47 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2018-09-15 12:34:47 +0000
commit83f0bf94f0007e4e7789e5847ef1267731fcb7aa (patch)
tree4574e7d4f22897f391201652d163ae5d7ae945e7 /shells
parentecbeb4d9347f26399ac1d2b3d2557904438c39ad (diff)
downloadports-83f0bf94f0007e4e7789e5847ef1267731fcb7aa.tar.gz
ports-83f0bf94f0007e4e7789e5847ef1267731fcb7aa.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/xonsh/Makefile3
-rw-r--r--shells/xonsh/distinfo6
-rw-r--r--shells/xonsh/files/patch-xonsh_platform.py10
-rw-r--r--shells/xonsh/files/patch-xonsh_xoreutils_uptime.py17
4 files changed, 22 insertions, 14 deletions
diff --git a/shells/xonsh/Makefile b/shells/xonsh/Makefile
index 5f42c711afc7..d072140995ee 100644
--- a/shells/xonsh/Makefile
+++ b/shells/xonsh/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xonsh
-PORTVERSION= 0.6.0
+PORTVERSION= 0.7.8
CATEGORIES= shells python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,6 +10,7 @@ MAINTAINER= roberfern@gmail.com
COMMENT= Python-ish BASH-wards shell
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/license
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}amalgamate>=0:devel/py-amalgamate@${PY_FLAVOR}
diff --git a/shells/xonsh/distinfo b/shells/xonsh/distinfo
index a7ec6c8dca18..d7791f37757e 100644
--- a/shells/xonsh/distinfo
+++ b/shells/xonsh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1511473787
-SHA256 (xonsh-0.6.0.tar.gz) = 19aa4c075378aef8476b8b2cdb0bea6fa5e10933163de443b958fa485e0f6dc6
-SIZE (xonsh-0.6.0.tar.gz) = 652164
+TIMESTAMP = 1536835442
+SHA256 (xonsh-0.7.8.tar.gz) = 956c7fbf19968afaade11fa5cb627a7f2c177a9e05f8cb03f7efa86b5fe4cb08
+SIZE (xonsh-0.7.8.tar.gz) = 827000
diff --git a/shells/xonsh/files/patch-xonsh_platform.py b/shells/xonsh/files/patch-xonsh_platform.py
index cca4ca00ecfc..dc2b4163d3c6 100644
--- a/shells/xonsh/files/patch-xonsh_platform.py
+++ b/shells/xonsh/files/patch-xonsh_platform.py
@@ -1,11 +1,11 @@
---- xonsh/platform.py.orig 2017-03-12 02:36:40 UTC
+--- xonsh/platform.py.orig 2018-09-05 14:16:47 UTC
+++ xonsh/platform.py
-@@ -491,7 +491,7 @@ def LIBC():
- libc = ctypes.CDLL('cygwin1.dll')
+@@ -571,7 +571,7 @@ def LIBC():
+ libc = ctypes.CDLL("msys-2.0.dll")
elif ON_BSD:
try:
-- libc = ctypes.CDLL('libc.so')
-+ libc = ctypes.CDLL(ctypes.util.find_library("c"))
+- libc = ctypes.CDLL("libc.so")
++ libc = ctypes.CDLL(ctypes.util.find_library("c"))
except AttributeError:
libc = None
except OSError:
diff --git a/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py b/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
index 8d0525adf5e3..8dc2873ddacf 100644
--- a/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
+++ b/shells/xonsh/files/patch-xonsh_xoreutils_uptime.py
@@ -1,11 +1,18 @@
---- xonsh/xoreutils/uptime.py.orig 2017-02-11 16:24:07 UTC
+--- xonsh/xoreutils/uptime.py.orig 2018-09-05 14:16:47 UTC
+++ xonsh/xoreutils/uptime.py
-@@ -100,7 +100,7 @@ def _uptime_bsd():
+@@ -100,13 +100,13 @@ def _uptime_bsd():
return None
# Determine how much space we need for the response.
sz = ctypes.c_uint(0)
-- xp.LIBC.sysctlbyname('kern.boottime', None, ctypes.byref(sz), None, 0)
-+ xp.LIBC.sysctlbyname(b'kern.boottime', None, ctypes.byref(sz), None, 0)
- if sz.value != struct.calcsize('@LL'):
+- xp.LIBC.sysctlbyname("kern.boottime", None, ctypes.byref(sz), None, 0)
++ xp.LIBC.sysctlbyname(b"kern.boottime", None, ctypes.byref(sz), None, 0)
+ if sz.value != struct.calcsize("@LL"):
# Unexpected, let's give up.
return None
+ # For real now.
+ buf = ctypes.create_string_buffer(sz.value)
+- xp.LIBC.sysctlbyname("kern.boottime", buf, ctypes.byref(sz), None, 0)
++ xp.LIBC.sysctlbyname(b"kern.boottime", buf, ctypes.byref(sz), None, 0)
+ sec, usec = struct.unpack_from("@LL", buf.raw)
+ # OS X disagrees what that second value is.
+ if usec > 1000000: