aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-11-03 13:30:38 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-11-03 13:30:38 +0000
commit87fe7293c3d2edcde16a74d11ef7e804af67438a (patch)
tree2c230367eea6876cd332d81a55dda9654b5da3c3 /shells
parentc1e5d000e7f4f50059e05748a410163b5e181d6f (diff)
downloadports-87fe7293c3d2edcde16a74d11ef7e804af67438a.tar.gz
ports-87fe7293c3d2edcde16a74d11ef7e804af67438a.zip
Switch to USES=localbase:ldflags
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=553982
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 9b313819588c..a3d2f9928d84 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -20,7 +20,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
MAKE_JOBS_UNSAFE= yes
-USES= autoreconf iconv ncurses shebangfix tar:xz
+USES= autoreconf iconv localbase:ldflags ncurses shebangfix tar:xz
SHEBANG_LANG= zsh
zsh_OLD_CMD= zsh # shebang appears as /bin/zsh and just zsh
@@ -42,8 +42,8 @@ CONFIGURE_ENV+= zsh_cv_sys_path_dev_fd=no \
ac_cv_header_sys_capability_h=no
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
-LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
+CPPFLAGS+= -DBOOL_DEFINED
+LDFLAGS+= -Wl,--as-needed
TEST_TARGET= test
OPTIONS_DEFINE= DEBUG ETCDIR GDBM MEM PCRE STATIC \