aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-12-19 21:10:41 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-12-19 21:10:41 +0000
commit890b1d38118c8f9c143b498c0f8b67578ca41045 (patch)
treecdef85fd680dcfbf0f43ee5d20582b1ec0421819 /shells
parent56b51cbe583a8e4eeec4c64de3071e1bac07f254 (diff)
downloadports-890b1d38118c8f9c143b498c0f8b67578ca41045.tar.gz
ports-890b1d38118c8f9c143b498c0f8b67578ca41045.zip
Update to 5.1.4
Notes
Notes: svn path=/head/; revision=558684
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile18
-rw-r--r--shells/bash/distinfo10
-rw-r--r--shells/bash/files/patch-Makefile.in13
3 files changed, 18 insertions, 23 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 075a9158e757..32255f1df1fc 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -1,24 +1,20 @@
# Created by: Oliver Eikemeier
# $FreeBSD$
-# Please don't remove commented lines, they become relevant once the first
-# patch for 5.1 has been released.
-
PORTNAME= bash
-#PATCHLEVEL= 0
-#PORTVERSION= 5.0.${PATCHLEVEL:S/^0//g}
-PORTVERSION= 5.1
+PATCHLEVEL= 4
+PORTVERSION= 5.1.${PATCHLEVEL:S/^0//g}
PORTREVISION?= 0
CATEGORIES= shells
MASTER_SITES= GNU
-#DISTNAME= ${PORTNAME}-${PORTVERSION:R}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-#PATCH_SITES= GNU/${PORTNAME}/${DISTNAME}-patches/
-#PATCHFILES!= /usr/bin/jot -s " " -w \
-# ${PORTNAME}${PORTVERSION:R:S/.//g}-%03d \
-# ${PATCHLEVEL} 1 ${PATCHLEVEL}
+PATCH_SITES= GNU/${PORTNAME}/${DISTNAME}-patches/
+PATCHFILES!= /usr/bin/jot -s " " -w \
+ ${PORTNAME}${PORTVERSION:R:S/.//g}-%03d \
+ ${PATCHLEVEL} 1 ${PATCHLEVEL}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= GNU Project's Bourne Again SHell
diff --git a/shells/bash/distinfo b/shells/bash/distinfo
index f754592a38b8..0eb703f1c071 100644
--- a/shells/bash/distinfo
+++ b/shells/bash/distinfo
@@ -1,3 +1,11 @@
-TIMESTAMP = 1607529799
+TIMESTAMP = 1608411498
SHA256 (bash/bash-5.1.tar.gz) = cc012bc860406dcf42f64431bcd3d2fa7560c02915a601aba9cd597a39329baa
SIZE (bash/bash-5.1.tar.gz) = 10458638
+SHA256 (bash/bash51-001) = ebb07b3dbadd98598f078125d0ae0d699295978a5cdaef6282fe19adef45b5fa
+SIZE (bash/bash51-001) = 2894
+SHA256 (bash/bash51-002) = 15ea6121a801e48e658ceee712ea9b88d4ded022046a6147550790caf04f5dbe
+SIZE (bash/bash51-002) = 1575
+SHA256 (bash/bash51-003) = 22f2cc262f056b22966281babf4b0a2f84cb7dd2223422e5dcd013c3dcbab6b1
+SIZE (bash/bash51-003) = 1800
+SHA256 (bash/bash51-004) = 9aaeb65664ef0d28c0067e47ba5652b518298b3b92d33327d84b98b28d873c86
+SIZE (bash/bash51-004) = 3745
diff --git a/shells/bash/files/patch-Makefile.in b/shells/bash/files/patch-Makefile.in
index 2eae4f4c910f..9cae991db7d5 100644
--- a/shells/bash/files/patch-Makefile.in
+++ b/shells/bash/files/patch-Makefile.in
@@ -1,15 +1,6 @@
---- Makefile.in.orig 2020-12-04 14:51:19 UTC
+--- Makefile.in.orig 2020-12-19 20:55:00 UTC
+++ Makefile.in
-@@ -584,6 +584,8 @@ $(Program): .build $(OBJECTS) $(BUILTINS_DEP) $(LIBDE
- ls -l $(Program)
- -$(SIZE) $(Program)
-
-+$(CSOURCES): $(DEFDIR)/builtext.h
-+
- .build: $(SOURCES) config.h Makefile version.h $(VERSPROG)
- @echo
- @echo " ***********************************************************"
-@@ -831,7 +833,9 @@ install: .made installdirs
+@@ -824,7 +824,9 @@ install: .made installdirs
infodir=$(infodir) htmldir=$(htmldir) DESTDIR=$(DESTDIR) $@ )
-( cd $(DEFDIR) ; $(MAKE) $(MFLAGS) DESTDIR=$(DESTDIR) $@ )
-( cd $(PO_DIR) ; $(MAKE) $(MFLAGS) DESTDIR=$(DESTDIR) $@ )