aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-10-02 14:36:03 +0000
committerStefan Eßer <se@FreeBSD.org>2020-10-02 14:36:03 +0000
commita0554ec901561107fcd1db14498dec35120ac5ad (patch)
treef2749a453db7bd1f9f4de8f00dfcc265df304697 /shells
parentc7d73fdded73fb9cf2489a0264e3f80bebb41fbb (diff)
downloadports-a0554ec901561107fcd1db14498dec35120ac5ad.tar.gz
ports-a0554ec901561107fcd1db14498dec35120ac5ad.zip
Fix build with -fno-common
Notes
Notes: svn path=/head/; revision=551216
Diffstat (limited to 'shells')
-rw-r--r--shells/ibsh/Makefile3
-rw-r--r--shells/ibsh/files/patch-ibsh.h28
-rw-r--r--shells/ibsh/files/patch-main.c20
3 files changed, 50 insertions, 1 deletions
diff --git a/shells/ibsh/Makefile b/shells/ibsh/Makefile
index fc2ef1d9d315..4d4e0dd47124 100644
--- a/shells/ibsh/Makefile
+++ b/shells/ibsh/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ibsh
PORTVERSION= 0.3e
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,9 +14,9 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= dos2unix gmake
+MAKE_ARGS= CC="${CC}" PREFIX="${STAGEDIR}${PREFIX}"
ALL_TARGET= ibsh
INSTALL_TARGET= ibsh_install
-MAKE_ARGS= CC="${CC}" PREFIX="${STAGEDIR}${PREFIX}"
SUB_FILES= pkg-message
PORTDOCS= AUTHORS BUGS CONTRIBUTORS COPYING COPYRIGHT ChangeLog \
diff --git a/shells/ibsh/files/patch-ibsh.h b/shells/ibsh/files/patch-ibsh.h
new file mode 100644
index 000000000000..6b05751fdcc2
--- /dev/null
+++ b/shells/ibsh/files/patch-ibsh.h
@@ -0,0 +1,28 @@
+--- ibsh.h.orig 2020-10-02 14:29:21 UTC
++++ ibsh.h
+@@ -88,17 +88,15 @@ typedef struct theuser {
+
+ typedef char Strng[STRING_SIZE];
+
+-theuser loggedin; /* user info */
++extern theuser loggedin; /* user info */
+
+-//static Strng commands[MAX_ITEMS]; /* permitted commands */
+-Strng commands[MAX_ITEMS];
+-Strng extensions[MAX_ITEMS];
+-/*static Strng extensions[MAX_ITEMS]; permitted extensions */
+-char real_path[STRING_SIZE]; /* absolute path */
+-char jail_path[STRING_SIZE]; /* path inside the jail */
+-char user_command[STRING_SIZE]; /* whatever the user types */
+-char filtered_command[STRING_SIZE]; /* this one will be executed */
+-int exitcode;
++extern Strng commands[MAX_ITEMS]; /* permitted commands */
++extern Strng extensions[MAX_ITEMS]; /* permitted extensions */
++extern char real_path[STRING_SIZE]; /* absolute path */
++extern char jail_path[STRING_SIZE]; /* path inside the jail */
++extern char user_command[STRING_SIZE]; /* whatever the user types */
++extern char filtered_command[STRING_SIZE]; /* this one will be executed */
++extern int exitcode;
+ extern char **environ;
+
+
diff --git a/shells/ibsh/files/patch-main.c b/shells/ibsh/files/patch-main.c
new file mode 100644
index 000000000000..a515e2915f1e
--- /dev/null
+++ b/shells/ibsh/files/patch-main.c
@@ -0,0 +1,20 @@
+--- main.c.orig 2020-10-02 14:29:21 UTC
++++ main.c
+@@ -38,6 +38,17 @@
+ /* Header files */
+ #include "ibsh.h"
+
++theuser loggedin; /* user info */
++
++Strng commands[MAX_ITEMS]; /* permitted commands */
++Strng extensions[MAX_ITEMS]; /* permitted extensions */
++char real_path[STRING_SIZE]; /* absolute path */
++char jail_path[STRING_SIZE]; /* path inside the jail */
++char user_command[STRING_SIZE]; /* whatever the user types */
++char filtered_command[STRING_SIZE]; /* this one will be executed */
++int exitcode;
++
++
+ /* Main: */
+ /* Handle arguments, read config files, start command processing. */
+ /* IBSH doesnt use any command line arguments, but my text editor */