aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2020-09-13 02:49:35 +0000
committerFukang Chen <loader@FreeBSD.org>2020-09-13 02:49:35 +0000
commitba1c6ab949f3cc661e19db68b61a32fcacda9bc1 (patch)
tree0f0dae9201063580218800ee2b31b5974411cfa4 /shells
parentccb152c80301ca2f4767db23791a9aff1db45092 (diff)
downloadports-ba1c6ab949f3cc661e19db68b61a32fcacda9bc1.tar.gz
ports-ba1c6ab949f3cc661e19db68b61a32fcacda9bc1.zip
Notes
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile4
-rw-r--r--shells/zsh/files/extra-patch-Src_Modules_curses__keys.awk18
2 files changed, 22 insertions, 0 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 5f5b23e87ff6..9b313819588c 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -88,6 +88,10 @@ SUB_FILES= pkg-message
CONFIGURE_ENV+= ac_cv_lib_iconv_libiconv=no
.endif
+.if ${ncurses_ARGS} == port
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Src_Modules_curses__keys.awk
+.endif
+
post-patch:
# FreeBSD's clock_gettime(2) is in libc, not librt; see PR 167857
@${REINPLACE_CMD} -e '/LIBS/s|-lrt||' ${WRKSRC}/configure
diff --git a/shells/zsh/files/extra-patch-Src_Modules_curses__keys.awk b/shells/zsh/files/extra-patch-Src_Modules_curses__keys.awk
new file mode 100644
index 000000000000..4fb2b5aa27b9
--- /dev/null
+++ b/shells/zsh/files/extra-patch-Src_Modules_curses__keys.awk
@@ -0,0 +1,18 @@
+https://sourceforge.net/p/zsh/code/ci/c6a85163619ed1cee89ab047a0d98108ed46828d/
+--- Src/Modules/curses_keys.awk.orig 2017-12-04 14:09:36 UTC
++++ Src/Modules/curses_keys.awk
+@@ -12,8 +12,13 @@ BEGIN {nkeydefs = 0}
+
+ END {
+ printf("static const struct zcurses_namenumberpair keypad_names[] = {\n")
+- for (i = 0; i < 0 + nkeydefs; i++)
++ for (i = 0; i < 0 + nkeydefs; i++) {
++ if (name[i] == "EVENT")
++ printf("#ifdef KEY_EVENT\n")
+ printf(" {\"%s\", KEY_%s},\n", name[i], name[i])
++ if (name[i] == "EVENT")
++ printf("#endif\n")
++ }
+ printf(" {NULL, 0}\n")
+ printf("};\n")
+ }