aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-01-07 13:22:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-01-07 13:22:20 +0000
commitdd57d39c944a034905def396ee7204acfcadd387 (patch)
treeebe8beec00ce770ceb2d4d0ebf391331cafc840a /shells
parentd3f27fda59d4dda635a4422b830dc3f1df924e66 (diff)
downloadports-dd57d39c944a034905def396ee7204acfcadd387.tar.gz
ports-dd57d39c944a034905def396ee7204acfcadd387.zip
Enforce using libncursesw like the rest of the ports
The whole ports tree has been enforced on libncursesw (widechar) version for a while. With the exception of a few ports including bash. This is even more problematic in the case of bash because it links to libreadline which is linked to libncursesw.so
Notes
Notes: svn path=/head/; revision=560707
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 32255f1df1fc..ea917fd655c0 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 4
PORTVERSION= 5.1.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= shells
MASTER_SITES= GNU
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -56,6 +56,8 @@ CONFIGURE_ARGS+= --without-bash-malloc \
--enable-disabled-builtins \
--with-libiconv-prefix=${ICONV_PREFIX}
+MAKE_ARGS+= TERMCAP_LIB=-lncursesw
+
.if empty(PKGNAMESUFFIX)
CONFLICTS+= bash-static-[0-9]*
.else