aboutsummaryrefslogtreecommitdiff
path: root/sysutils/3dm
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-01 11:47:55 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-01 11:47:55 +0000
commit3e57ed7120630fceb6352e4e8337644dcd51292c (patch)
tree015cb3162bc7d1a7a07a94f43d86c3fed425c546 /sysutils/3dm
parentfe6d327cd4ecd55d6d6650964441b8c9cdd3dcdb (diff)
downloadports-3e57ed7120630fceb6352e4e8337644dcd51292c.tar.gz
ports-3e57ed7120630fceb6352e4e8337644dcd51292c.zip
- Update to v2.11.00.009 on 7.x and earlier
- Removes BROKEN and updates to v2.09.01.004 on 8.x and later. PR: ports/148216 Submitted by: Darren Pilgrim <ports.maintainer@evilphi.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=257264
Diffstat (limited to 'sysutils/3dm')
-rw-r--r--sysutils/3dm/Makefile75
-rw-r--r--sysutils/3dm/distinfo12
-rw-r--r--sysutils/3dm/files/3dm2.conf.sample4
-rw-r--r--sysutils/3dm/files/3dm2.sh.in1
-rw-r--r--sysutils/3dm/pkg-plist75
5 files changed, 76 insertions, 91 deletions
diff --git a/sysutils/3dm/Makefile b/sysutils/3dm/Makefile
index e705c46cd530..0951aa6f43a6 100644
--- a/sysutils/3dm/Makefile
+++ b/sysutils/3dm/Makefile
@@ -6,57 +6,62 @@
#
PORTNAME= 3dm
-PORTVERSION= 2.09.01.004
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= sysutils
-MASTER_SITES= http://vivi.cat.pdx.edu/3dm2/
+MASTER_SITES= http://www.lsi.com/DistributionSystem/AssetDocument/ \
+ http://vivi.cat.pdx.edu/3dm2/
MAINTAINER= ports.maintainer@evilphi.com
COMMENT= 3ware RAID controller monitoring daemon and web server
USE_RC_SUBR= 3dm2.sh
-USE_BZIP2= yes
+USE_ZIP= yes
.include <bsd.port.pre.mk>
-DISTFILES= 3dm2_${PORTVERSION}_${ARCH}.tar.bz2
-
-.if ${OSVERSION} >= 800000
-BROKEN=Requires KSE support for static-linked binaries.
-.endif
-
ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
NO_WRKSUBDIR= yes
-OPTSRC= ${WRKSRC}/opt/AMCC/3DM2
-HELPSRC= ${OPTSRC}/help/en
-MSGSRC= ${OPTSRC}/msg
+.if ${OSVERSION} < 800000
+PORTVERSION= 2.11.00.009
+DISTFILES= 3DM2_CLI-FreeBSD-10.1.zip
+BINSRC= ${WRKSRC}
+.else
+PORTVERSION= 2.09.01.004
+DISTFILES= 3DM2_CLI-Linux-non-java-installer-9.5.3.zip
+BINSRC= ${WRKSRC}/7x
+.endif
+
+.if ${ARCH} == "i386"
+BINSUFFIX= x86
+.elif ${ARCH} == "amd64"
+BINSUFFIX= x86_64
+.endif
+
+HELPSRC= ${WRKSRC}/en
HELPDIR= ${PREFIX}/share/3dm2/help/en
-MSGDIR= ${PREFIX}/etc/3dm2/msg
+ETCDIR= ${PREFIX}/etc/3dm2
+MSGDIR= ${ETCDIR}/msg
-post-patch:
- @${REINPLACE_CMD} -e 's|AMCC-logo\.jpg|AMCC-logo-smaler\.jpg|g' \
- ${WRKSRC}/opt/AMCC/3DM2/help/en/*.html
+post-extract:
+ ${TAR} zxf ${WRKSRC}/tdmCliBSD.tgz -C ${WRKSRC}
+ ${TAR} zxf ${WRKSRC}/tdm2Help.tgz -C ${WRKSRC}
+ ${TAR} zxf ${WRKSRC}/tdm2Msg.tgz -C ${WRKSRC}
post-configure:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
< ${FILESDIR}/3dm2.conf.sample > ${WRKSRC}/3dm2.conf.sample
do-install:
-.if !exists(${HELPDIR}/css)
- @${MKDIR} ${HELPDIR}/css
-.endif
-
-.if !exists(${HELPDIR}/images)
- @${MKDIR} ${HELPDIR}/images
-.endif
-
-.if !exists(${HELPDIR}/scripts)
- @${MKDIR} ${HELPDIR}/scripts
+.for i in ${ETCDIR} ${MSGDIR} ${HELPDIR}/css ${HELPDIR}/images ${HELPDIR}/scripts
+.if !exists(${i})
+ ${MKDIR} ${i}
.endif
+.endfor
${INSTALL_DATA} ${HELPSRC}/*.html ${HELPDIR}
${INSTALL_DATA} ${HELPSRC}/*.gif ${HELPDIR}
@@ -65,21 +70,13 @@ do-install:
${INSTALL_DATA} ${HELPSRC}/images/* ${HELPDIR}/images
${INSTALL_DATA} ${HELPSRC}/scripts/* ${HELPDIR}/scripts
- ${INSTALL_PROGRAM} ${WRKSRC}/usr/sbin/3dm2 ${PREFIX}/sbin/3dm2
-
-.if !exists(${PREFIX}/etc/3dm2)
- @${MKDIR} ${PREFIX}/etc/3dm2
-.endif
-
-.if !exists(${MSGDIR})
- @${MKDIR} ${MSGDIR}
-.endif
+ ${INSTALL_PROGRAM} ${BINSRC}/3dm2.${BINSUFFIX} ${PREFIX}/sbin/3dm2
- ${INSTALL_DATA} ${MSGSRC}/tdm_msg_en ${MSGDIR}
- ${INSTALL_DATA} ${MSGSRC}/tw_msg_en ${MSGDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tdm_msg_en ${MSGDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tw_msg_en ${MSGDIR}
- ${INSTALL_DATA} ${WRKSRC}/3dm2.conf.sample ${PREFIX}/etc/3dm2/
- ${CHMOD} 400 ${PREFIX}/etc/3dm2/3dm2.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/3dm2.conf.sample ${ETCDIR}
+ ${CHMOD} 400 ${ETCDIR}/3dm2.conf.sample
post-install:
.if !exists(${PREFIX}/etc/3dm2/3dm2.conf)
diff --git a/sysutils/3dm/distinfo b/sysutils/3dm/distinfo
index 8881bff1c1d5..0893feb94c0b 100644
--- a/sysutils/3dm/distinfo
+++ b/sysutils/3dm/distinfo
@@ -1,6 +1,6 @@
-MD5 (3dm2_2.09.01.004_amd64.tar.bz2) = 6ebc0303eb1968098486cbfb99ac7929
-SHA256 (3dm2_2.09.01.004_amd64.tar.bz2) = 441869618740bd49e4911c62f99de226f6ddc4d4e8475c4451682bcac4edd882
-SIZE (3dm2_2.09.01.004_amd64.tar.bz2) = 2565176
-MD5 (3dm2_2.09.01.004_i386.tar.bz2) = 1ae85f606df5788a5688dbdc6093bf9f
-SHA256 (3dm2_2.09.01.004_i386.tar.bz2) = da7b0c5ebc4b3188b9fd4b37a3aa11ff4deee569d3abb755dea265ae228ef92b
-SIZE (3dm2_2.09.01.004_i386.tar.bz2) = 2461126
+MD5 (3DM2_CLI-Linux-non-java-installer-9.5.3.zip) = 2aebdd38a4df46659100ec6fe915738a
+SHA256 (3DM2_CLI-Linux-non-java-installer-9.5.3.zip) = 8b912cb4ece56c65b148d8c467376aa8c13443e2d718b3a8afed86fa9eccabab
+SIZE (3DM2_CLI-Linux-non-java-installer-9.5.3.zip) = 7626223
+MD5 (3DM2_CLI-FreeBSD-10.1.zip) = 2a51b5328583cc92fc5d88f18288cfa2
+SHA256 (3DM2_CLI-FreeBSD-10.1.zip) = 5c0b2376ed61a0039c7567e0314d2c9d295fbb2641b5c87f9c46be7790d4d1aa
+SIZE (3DM2_CLI-FreeBSD-10.1.zip) = 5592890
diff --git a/sysutils/3dm/files/3dm2.conf.sample b/sysutils/3dm/files/3dm2.conf.sample
index 391a5a984058..1497fc8de941 100644
--- a/sysutils/3dm/files/3dm2.conf.sample
+++ b/sysutils/3dm/files/3dm2.conf.sample
@@ -19,10 +19,10 @@ Refresh 5
BGRate 3333333333333333
MsgPath %%PREFIX%%/etc/3dm2/msg
imgPath %%PREFIX%%/etc/3dm2
-Help %%PREFIX%%/share/3dm2/help/en
+Help %%PREFIX%%/share/3dm2/help
OEM 0
OEMBrand 3ware
AutoLogout 0
-CommandLog 0
+CommandLog 1
EnclosureMonitor 1
EnclMonitorSleepMinutes 2
diff --git a/sysutils/3dm/files/3dm2.sh.in b/sysutils/3dm/files/3dm2.sh.in
index a0fbd500b1e1..b6dde38fe688 100644
--- a/sysutils/3dm/files/3dm2.sh.in
+++ b/sysutils/3dm/files/3dm2.sh.in
@@ -21,6 +21,7 @@ rcvar=`set_rcvar`
start_precmd=twdm2_precmd
command="%%PREFIX%%/sbin/3dm2"
required_files=%%PREFIX%%/etc/3dm2/3dm2.conf
+sig_stop=INT
twdm2_precmd()
{
diff --git a/sysutils/3dm/pkg-plist b/sysutils/3dm/pkg-plist
index d1e43ecf55ce..13d600cdf231 100644
--- a/sysutils/3dm/pkg-plist
+++ b/sysutils/3dm/pkg-plist
@@ -101,8 +101,6 @@ share/3dm2/help/en/AEN_004D.html
share/3dm2/help/en/AEN_004E.html
share/3dm2/help/en/AEN_004F.html
share/3dm2/help/en/AEN_0050.html
-share/3dm2/help/en/AEN_0051.html
-share/3dm2/help/en/AEN_0052.html
share/3dm2/help/en/AEN_0053.html
share/3dm2/help/en/AEN_0055.html
share/3dm2/help/en/AEN_0056.html
@@ -112,13 +110,16 @@ share/3dm2/help/en/AEN_0059.html
share/3dm2/help/en/AEN_005A.html
share/3dm2/help/en/AEN_005B.html
share/3dm2/help/en/AEN_005C.html
-share/3dm2/help/en/AEN_005D.html
share/3dm2/help/en/AEN_005E.html
share/3dm2/help/en/AEN_005F.html
share/3dm2/help/en/AEN_0062.html
share/3dm2/help/en/AEN_0063.html
share/3dm2/help/en/AEN_0064.html
share/3dm2/help/en/AEN_0065.html
+share/3dm2/help/en/AEN_0066.html
+share/3dm2/help/en/AEN_0070.html
+share/3dm2/help/en/AEN_0080.html
+share/3dm2/help/en/AEN_0081.html
share/3dm2/help/en/AEN_8000.html
share/3dm2/help/en/AEN_8001.html
share/3dm2/help/en/AEN_8002.html
@@ -153,14 +154,10 @@ share/3dm2/help/en/AEN_8049.html
share/3dm2/help/en/AEN_804A.html
share/3dm2/help/en/AEN_804B.html
share/3dm2/help/en/AEN_Not_Yet.html
-share/3dm2/help/en/AMCC-logo-larger.jpg
-share/3dm2/help/en/AMCC-logo-smaller.jpg
-share/3dm2/help/en/AMCC-logo.jpg
share/3dm2/help/en/Alarms.html
share/3dm2/help/en/Battery_Backup.html
share/3dm2/help/en/Config_Controller.5.1.html
share/3dm2/help/en/Config_Controller.5.10.html
-share/3dm2/help/en/Config_Controller.5.11.html
share/3dm2/help/en/Config_Controller.5.2.html
share/3dm2/help/en/Config_Controller.5.3.html
share/3dm2/help/en/Config_Controller.5.4.html
@@ -189,7 +186,6 @@ share/3dm2/help/en/Config_Units.6.24.html
share/3dm2/help/en/Config_Units.6.25.html
share/3dm2/help/en/Config_Units.6.26.html
share/3dm2/help/en/Config_Units.6.27.html
-share/3dm2/help/en/Config_Units.6.28.html
share/3dm2/help/en/Config_Units.6.3.html
share/3dm2/help/en/Config_Units.6.4.html
share/3dm2/help/en/Config_Units.6.5.html
@@ -207,6 +203,8 @@ share/3dm2/help/en/Drive_Information.html
share/3dm2/help/en/Enclosure_Details.html
share/3dm2/help/en/Enclosure_Information.html
share/3dm2/help/en/Enclosure_Management.9.1.html
+share/3dm2/help/en/Enclosure_Management.9.10.html
+share/3dm2/help/en/Enclosure_Management.9.11.html
share/3dm2/help/en/Enclosure_Management.9.2.html
share/3dm2/help/en/Enclosure_Management.9.3.html
share/3dm2/help/en/Enclosure_Management.9.4.html
@@ -219,14 +217,12 @@ share/3dm2/help/en/Exclamation.gif
share/3dm2/help/en/First.html
share/3dm2/help/en/GetStart.html
share/3dm2/help/en/Glossary.html
+share/3dm2/help/en/LSI-logo.gif
+share/3dm2/help/en/LSI-logo.jpg
share/3dm2/help/en/Lightening.gif
share/3dm2/help/en/MaintainController.8.1.html
share/3dm2/help/en/MaintainController.8.10.html
share/3dm2/help/en/MaintainController.8.11.html
-share/3dm2/help/en/MaintainController.8.12.html
-share/3dm2/help/en/MaintainController.8.13.html
-share/3dm2/help/en/MaintainController.8.14.html
-share/3dm2/help/en/MaintainController.8.15.html
share/3dm2/help/en/MaintainController.8.2.html
share/3dm2/help/en/MaintainController.8.3.html
share/3dm2/help/en/MaintainController.8.4.html
@@ -259,6 +255,8 @@ share/3dm2/help/en/Maintain_Units.7.28.html
share/3dm2/help/en/Maintain_Units.7.29.html
share/3dm2/help/en/Maintain_Units.7.3.html
share/3dm2/help/en/Maintain_Units.7.30.html
+share/3dm2/help/en/Maintain_Units.7.31.html
+share/3dm2/help/en/Maintain_Units.7.32.html
share/3dm2/help/en/Maintain_Units.7.4.html
share/3dm2/help/en/Maintain_Units.7.5.html
share/3dm2/help/en/Maintain_Units.7.6.html
@@ -270,7 +268,6 @@ share/3dm2/help/en/Note.gif
share/3dm2/help/en/OLH_3DM_2_First.html
share/3dm2/help/en/Scheduling.html
share/3dm2/help/en/Trbleshoot.11.1.html
-share/3dm2/help/en/Trbleshoot.11.10.html
share/3dm2/help/en/Trbleshoot.11.2.html
share/3dm2/help/en/Trbleshoot.11.3.html
share/3dm2/help/en/Trbleshoot.11.4.html
@@ -278,7 +275,6 @@ share/3dm2/help/en/Trbleshoot.11.5.html
share/3dm2/help/en/Trbleshoot.11.6.html
share/3dm2/help/en/Trbleshoot.11.7.html
share/3dm2/help/en/Trbleshoot.11.8.html
-share/3dm2/help/en/Trbleshoot.11.9.html
share/3dm2/help/en/Unit_Details.html
share/3dm2/help/en/Unit_Information.html
share/3dm2/help/en/css/3DM-Intro.css
@@ -298,40 +294,38 @@ share/3dm2/help/en/css/webworks.css
share/3dm2/help/en/error_messages.html
share/3dm2/help/en/images/3DM-Intro.4.4.1.jpg
share/3dm2/help/en/images/3DM-Intro.4.8.1.jpg
-share/3dm2/help/en/images/3dm-background-task-rate.jpg
+share/3dm2/help/en/images/3bm_enclosure_screen_with_alarm_activated.jpg
share/3dm2/help/en/images/3dm-maint-page-mac-with-callouts-2-buttons.jpg
share/3dm2/help/en/images/3dm-maint-page-mac-with-callouts.jpg
share/3dm2/help/en/images/3dm-menu-mac.jpg
share/3dm2/help/en/images/3dm-schedule-select-type.gif
-share/3dm2/help/en/images/3wUpdate-GetInfo.jpg
-share/3dm2/help/en/images/3wUpdate-Reboot.jpg
-share/3dm2/help/en/images/3ware-update-final-new.JPG
+share/3dm2/help/en/images/3dm_Command_logging-with-callout.JPG
+share/3dm2/help/en/images/3dm_Command_logging.jpg
+share/3dm2/help/en/images/3dm_Enclosure_Details_page.jpg
+share/3dm2/help/en/images/3dm_background_task_settings.png
+share/3dm2/help/en/images/3dm_controller_settings_page_with_BTAP-with-callout.png
+share/3dm2/help/en/images/3dm_controller_settings_page_with_BTAP_warning-boxes.png
+share/3dm2/help/en/images/3dm_controller_settings_with_read_cache_options-callout.png
+share/3dm2/help/en/images/3dm_enclosure_support_with_alarm_activated.jpg
share/3dm2/help/en/images/951_CreateUnit_3DM.jpg
-share/3dm2/help/en/images/9690_3DM2Settings.png
share/3dm2/help/en/images/9690_Alarms.png
share/3dm2/help/en/images/9690_ContollerPhySummary.png
share/3dm2/help/en/images/9690_ControllerDetails.png
share/3dm2/help/en/images/9690_ControllerSummary.png
share/3dm2/help/en/images/9690_DriveInformation.png
-share/3dm2/help/en/images/9690_DriveInformationLIst.png
-share/3dm2/help/en/images/9690_EnclosureSummary.png
+share/3dm2/help/en/images/9690_EnclosureDetails_Full.jpg
share/3dm2/help/en/images/9690_ExtraDriveInfo.png
share/3dm2/help/en/images/9690_MIgrate.png
-share/3dm2/help/en/images/9690_Maintenance.png
share/3dm2/help/en/images/9690_Scheduling_9.5.png
-share/3dm2/help/en/images/9690_UnitInformaiton.png
-share/3dm2/help/en/images/9690_UnitInformaiton2.png
-share/3dm2/help/en/images/9690_enclosure_details.png
-share/3dm2/help/en/images/Config_Units.6.16.1.jpg
-share/3dm2/help/en/images/Enclosure_Management.9.2.1.jpg
-share/3dm2/help/en/images/Enclosure_Management.9.3.1.jpg
-share/3dm2/help/en/images/MaintainController.8.7.2.jpg
-share/3dm2/help/en/images/MaintainController.8.7.3.jpg
-share/3dm2/help/en/images/MaintainController.8.7.4.jpg
-share/3dm2/help/en/images/MaintainController.8.7.5.jpg
-share/3dm2/help/en/images/MaintainController.8.8.1.jpg
-share/3dm2/help/en/images/Maintain_Units.7.29.1.jpg
-share/3dm2/help/en/images/Maintain_Units.7.30.1.jpg
+share/3dm2/help/en/images/9750_ContollerPhySummary.png
+share/3dm2/help/en/images/9750_DriveInformationLIst.png
+share/3dm2/help/en/images/9750_Enclosure_Summary_Page.jpg
+share/3dm2/help/en/images/9750_Maintenance.png
+share/3dm2/help/en/images/9750_UnitInformaiton.png
+share/3dm2/help/en/images/9750_UnitInformaiton2.png
+share/3dm2/help/en/images/Config_Units.6.17.1.jpg
+share/3dm2/help/en/images/Maintain_Units.7.31.1.jpg
+share/3dm2/help/en/images/Maintain_Units.7.32.1.jpg
share/3dm2/help/en/images/RAID-0.gif
share/3dm2/help/en/images/RAID-1.gif
share/3dm2/help/en/images/RAID-10.gif
@@ -348,15 +342,8 @@ share/3dm2/help/en/images/SAS_DeletedUnit.gif
share/3dm2/help/en/images/SAS_WinAVAlarm.jpg
share/3dm2/help/en/images/SAS_bbu.gif
share/3dm2/help/en/images/WinAVAlarm_tray.gif
-share/3dm2/help/en/images/XP-53.jpg
-share/3dm2/help/en/images/XP-Update01.jpg
-share/3dm2/help/en/images/XP-Update02.jpg
-share/3dm2/help/en/images/XP-Update03.jpg
-share/3dm2/help/en/images/XP-Update04.jpg
-share/3dm2/help/en/images/XP-Update05.jpg
-share/3dm2/help/en/images/XP-Update07.jpg
-share/3dm2/help/en/images/XP-Update10.jpg
-share/3dm2/help/en/images/XP-Update12.jpg
+share/3dm2/help/en/images/Windows_DriverInstall-Done.JPG
+share/3dm2/help/en/images/Windows_DriverInstall-Start.JPG
share/3dm2/help/en/images/alarms-sample-3dm.gif
share/3dm2/help/en/images/collapse.gif
share/3dm2/help/en/images/enable-write-cache.gif