aboutsummaryrefslogtreecommitdiff
path: root/sysutils/R-cran-fs/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-01-05 23:21:59 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-01-05 23:21:59 +0000
commit08e70b90547b2b7d4baf6b69eb0271211c37811a (patch)
treed4468f0b278cdb33ad1853871bad8e4ea8183d79 /sysutils/R-cran-fs/Makefile
parent8b3b4560993af470a4cccee721258fa2fab341d8 (diff)
downloadports-08e70b90547b2b7d4baf6b69eb0271211c37811a.tar.gz
ports-08e70b90547b2b7d4baf6b69eb0271211c37811a.zip
new port: sysutils/R-cran-fs: Cross-Platform File System Operations
Approved by: lwhsu
Notes
Notes: svn path=/head/; revision=560444
Diffstat (limited to 'sysutils/R-cran-fs/Makefile')
-rw-r--r--sysutils/R-cran-fs/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/sysutils/R-cran-fs/Makefile b/sysutils/R-cran-fs/Makefile
new file mode 100644
index 000000000000..e81673f83728
--- /dev/null
+++ b/sysutils/R-cran-fs/Makefile
@@ -0,0 +1,27 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fs
+DISTVERSION= 1.5.0
+CATEGORIES= sysutils
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Cross-Platform File System Operations Based on 'libuv'
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= R-cran-knitr>0:print/R-cran-knitr
+TEST_DEPENDS= R-cran-covr>0:devel/R-cran-covr \
+ R-cran-crayon>0:devel/R-cran-crayon \
+ R-cran-pillar>=1.0.0:devel/R-cran-pillar \
+ R-cran-testthat>0:devel/R-cran-testthat \
+ R-cran-tibble>=1.1.0:devel/R-cran-tibble \
+ R-cran-vctrs>=0.3.0:devel/R-cran-vctrs \
+ R-cran-withr>0:devel/R-cran-withr \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown
+
+USES= cran:auto-plist,compiles
+
+.include <bsd.port.mk>