aboutsummaryrefslogtreecommitdiff
path: root/sysutils/abduco
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-07-14 09:29:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-07-14 09:29:04 +0000
commit44673c8f1486a1ec368033c109bbb333ea21cea2 (patch)
tree356bfc7f2ee43bed06710caff64ac59a1c10d5f2 /sysutils/abduco
parenta9e57d01602e36fa1e1c9034743a72d1a48fd43a (diff)
downloadports-44673c8f1486a1ec368033c109bbb333ea21cea2.tar.gz
ports-44673c8f1486a1ec368033c109bbb333ea21cea2.zip
sysutils/abduco: add new port
PR: 210287 Submitted by: David Wildasin <swdragonmaus@gmail.com> abduco provides session management i.e., it allows programs to be run independently from their controlling terminal. That is programs can be detached - run in the background - and then later reattached. Together with dvtm it provides a simpler and cleaner alternative to tmux or screen. abduco is in many ways very similar to dtach but is a completely independent implementation which is actively maintained, contains no legacy code, provides a few additional features, has a cleaner, more robust implementation and is distributed under the ISC license. http://www.brain-dump.org/projects/abduco/
Notes
Notes: svn path=/head/; revision=418526
Diffstat (limited to 'sysutils/abduco')
-rw-r--r--sysutils/abduco/Makefile29
-rw-r--r--sysutils/abduco/distinfo3
-rw-r--r--sysutils/abduco/pkg-descr12
3 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/abduco/Makefile b/sysutils/abduco/Makefile
new file mode 100644
index 000000000000..4f0685e1c910
--- /dev/null
+++ b/sysutils/abduco/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= abduco
+PORTVERSION= 0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.brain-dump.org/projects/abduco/
+
+MAINTAINER= swdragonmaus@gmail.com
+COMMENT= Session management in a clean and simple way
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MAKE_ARGS= CPPFLAGS="${CPPFLAGS}" STRIP="${STRIP_CMD}" \
+ MANPREFIX="${MANPREFIX}/man"
+PLIST_FILES= bin/abduco \
+ man/man1/abduco.1.gz
+
+pre-everything::
+ @${ECHO_MSG} "You can build abduco with your own config.h using the ABDUCO_CONF knob:"
+ @${ECHO_MSG} "make ABDUCO_CONF=/path/to/abduco/config.h install clean"
+
+post-extract:
+ @if [ -e "${ABDUCO_CONF}" ]; then \
+ ${ECHO_MSG} "Creating symlink: config.h -> ${ABDUCO_CONF}"; \
+ ${LN} -fs "${ABDUCO_CONF}" ${WRKSRC}/config.h; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/sysutils/abduco/distinfo b/sysutils/abduco/distinfo
new file mode 100644
index 000000000000..91b6263ace6a
--- /dev/null
+++ b/sysutils/abduco/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465579293
+SHA256 (abduco-0.6.tar.gz) = c90909e13fa95770b5afc3b59f311b3d3d2fdfae23f9569fa4f96a3e192a35f4
+SIZE (abduco-0.6.tar.gz) = 15829
diff --git a/sysutils/abduco/pkg-descr b/sysutils/abduco/pkg-descr
new file mode 100644
index 000000000000..07466ea9779d
--- /dev/null
+++ b/sysutils/abduco/pkg-descr
@@ -0,0 +1,12 @@
+abduco provides session management i.e., it allows programs to be run
+independently from their controlling terminal. That is programs can be
+detached - run in the background - and then later reattached. Together
+with dvtm it provides a simpler and cleaner alternative to tmux or
+screen.
+
+abduco is in many ways very similar to dtach but is a completely
+independent implementation which is actively maintained, contains no
+legacy code, provides a few additional features, has a cleaner, more
+robust implementation and is distributed under the ISC license.
+
+WWW: http://www.brain-dump.org/projects/abduco/