aboutsummaryrefslogtreecommitdiff
path: root/sysutils/adtool
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 22:53:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-29 22:53:20 +0000
commit928565fd41c144ac059b21b53a51d913e65bff1e (patch)
treeb039955fe6c7b5e4417d73308bb9466642398df7 /sysutils/adtool
parent9f83ac40aecc1985fdd00a9505d4e4e9899dc642 (diff)
downloadports-928565fd41c144ac059b21b53a51d913e65bff1e.tar.gz
ports-928565fd41c144ac059b21b53a51d913e65bff1e.zip
NEW PORT: sysutils/adtool
adtool is a unix command line utility for Active Directory administration. Features include user and group creation, deletion, modification, password setting and directory query and search capabilities. PR: ports/51320 Submitted by: Joseph Scott <joseph@randomnetworks.com>
Notes
Notes: svn path=/head/; revision=89845
Diffstat (limited to 'sysutils/adtool')
-rw-r--r--sysutils/adtool/Makefile27
-rw-r--r--sysutils/adtool/distinfo1
-rw-r--r--sysutils/adtool/files/patch-src::tools::Makefile.in11
-rw-r--r--sysutils/adtool/pkg-descr5
-rw-r--r--sysutils/adtool/pkg-plist2
5 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/adtool/Makefile b/sysutils/adtool/Makefile
new file mode 100644
index 000000000000..b79f815a8ff7
--- /dev/null
+++ b/sysutils/adtool/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: adtool
+# Date created: Wed 23 Apr 2003
+# Whom: joseph@randomnetworks.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= adtool
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= joseph@randomnetworks.com
+COMMENT= Active Directory administration tool
+
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap21
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-ldap=${LOCALBASE}
+
+MAN1= adtool.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/adtool/distinfo b/sysutils/adtool/distinfo
new file mode 100644
index 000000000000..f65d4e33a13a
--- /dev/null
+++ b/sysutils/adtool/distinfo
@@ -0,0 +1 @@
+MD5 (adtool-1.1.tar.gz) = 3e729dc1b2463fbe5d1afe66bdad4d91
diff --git a/sysutils/adtool/files/patch-src::tools::Makefile.in b/sysutils/adtool/files/patch-src::tools::Makefile.in
new file mode 100644
index 000000000000..fd5f8a7fa446
--- /dev/null
+++ b/sysutils/adtool/files/patch-src::tools::Makefile.in
@@ -0,0 +1,11 @@
+--- src/tools/Makefile.in.orig Wed Apr 23 10:12:21 2003
++++ src/tools/Makefile.in Wed Apr 23 10:12:37 2003
+@@ -76,7 +76,7 @@
+
+ INCLUDES = -I@top_srcdir@/src/lib
+ CFLAGS = -Wall @CFLAGS@
+-LDFLAGS = -lldap -llber -lldap_r -lpthread -lresolv @LDFLAGS@
++LDFLAGS = -lldap -llber -lldap_r -pthread @LDFLAGS@
+
+ bin_PROGRAMS = adtool
+
diff --git a/sysutils/adtool/pkg-descr b/sysutils/adtool/pkg-descr
new file mode 100644
index 000000000000..6d741debbc6b
--- /dev/null
+++ b/sysutils/adtool/pkg-descr
@@ -0,0 +1,5 @@
+adtool is a unix command line utility for Active Directory administration.
+Features include user and group creation, deletion, modification, password
+setting and directory query and search capabilities.
+
+WWW: http://adtool.sourceforge.net/
diff --git a/sysutils/adtool/pkg-plist b/sysutils/adtool/pkg-plist
new file mode 100644
index 000000000000..08f4604fb693
--- /dev/null
+++ b/sysutils/adtool/pkg-plist
@@ -0,0 +1,2 @@
+bin/adtool
+etc/adtool.cfg.dist