aboutsummaryrefslogtreecommitdiff
path: root/sysutils/afflib/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:18:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-26 15:18:09 +0000
commit5c837b6f61782088143ad88f7287833100ed9ec0 (patch)
treece4a21732e51b9fe51b93b5b67177c5b2265e675 /sysutils/afflib/Makefile
parentf70644a0c571843996b3ce4e3f103855797a50f2 (diff)
downloadports-5c837b6f61782088143ad88f7287833100ed9ec0.tar.gz
ports-5c837b6f61782088143ad88f7287833100ed9ec0.zip
Notes
Diffstat (limited to 'sysutils/afflib/Makefile')
-rw-r--r--sysutils/afflib/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/afflib/Makefile b/sysutils/afflib/Makefile
new file mode 100644
index 000000000000..4a1ef379f967
--- /dev/null
+++ b/sysutils/afflib/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: afflib
+#
+# Date created: 15/02/2008
+# Whom: Chris Calvey <chris@securityforensics.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= afflib
+PORTVERSION= 3.0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.afflib.org/downloads/
+
+MAINTAINER= chris@securityforensics.co.uk
+COMMENT= The Advanced Forensics Format library and utilities
+
+LIB_DEPENDS= fuse:${PORTSDIR}/sysutils/fusefs-libs \
+ expat.6:${PORTSDIR}/textproc/expat2
+
+USE_OPENSSL= yes
+USE_ICONV = yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:261
+CONFIGURE_ENV= CPPFLAGS='-DFUSE_USE_VERSION=26' \
+ LDFLAGS='${PTHREAD_LIBS}'
+CFLAGS+= ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>