aboutsummaryrefslogtreecommitdiff
path: root/sysutils/android-file-transfer
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /sysutils/android-file-transfer
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'sysutils/android-file-transfer')
-rw-r--r--sysutils/android-file-transfer/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/sysutils/android-file-transfer/Makefile b/sysutils/android-file-transfer/Makefile
index c5da45c02da1..36d7db0f48b8 100644
--- a/sysutils/android-file-transfer/Makefile
+++ b/sysutils/android-file-transfer/Makefile
@@ -45,11 +45,13 @@ QT_PLIST_FILES= bin/android-file-transfer \
share/icons/hicolor/512x512/apps/android-file-transfer.png \
share/metainfo/android-file-transfer.appdata.xml
-QT4_USE= QT4=qmake_build,moc_build,rcc_build,uic_build,corelib,gui
+QT4_USES= qt:4
+QT4_USE= QT=qmake_build,moc_build,rcc_build,uic_build,corelib,gui
QT4_CMAKE_ON= -DDESIRED_QT_VERSION:STRING=4
QT4_IMPLIES= QT
-QT5_USE= QT5=qmake_build,buildtools_build,core,gui,widgets
+QT5_USES= qt:5
+QT5_USE= QT=qmake_build,buildtools_build,core,gui,widgets
QT5_CMAKE_ON= -DDESIRED_QT_VERSION:STRING=5
QT5_IMPLIES= QT