aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-06-02 19:47:53 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-06-02 19:47:53 +0000
commitbfa9c102f82b524970a1aaed693cc7feb1710d72 (patch)
tree7ae1a84e8b9000a943a366146f47813a70311d99 /sysutils/ansible
parent76802e60d7bc4707fd0d73145d36156cdb53bc36 (diff)
downloadports-bfa9c102f82b524970a1aaed693cc7feb1710d72.tar.gz
ports-bfa9c102f82b524970a1aaed693cc7feb1710d72.zip
update sysutils/ansible to 2.3.1.0
Relnotes: https://github.com/ansible/ansible/blob/v2.3.1.0-1/CHANGELOG.md Security: 15a04b9f-47cb-11e7-a853-001fbc0f280f
Notes
Notes: svn path=/head/; revision=442458
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile6
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/extra-patch-f82d95a23
3 files changed, 6 insertions, 29 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 07186078bda6..5a9a050009a9 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION?= 2.3.0.0
-PORTREVISION?= 2
+PORTVERSION?= 2.3.1.0
+PORTREVISION?= 0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -20,7 +20,7 @@ RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2 \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml
-EXTRA_PATCHES?= ${FILESDIR}/extra-patch-f82d95a
+EXTRA_PATCHES?= #
NO_ARCH= yes
USES?= cpe python
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index a3137e184ca3..c162d5d6ec44 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492010911
-SHA256 (ansible-2.3.0.0.tar.gz) = 299f3907cd566a20e163942fa82b6afc86ef89c2726ba503b90c1a651e82a458
-SIZE (ansible-2.3.0.0.tar.gz) = 4251730
+TIMESTAMP = 1496432079
+SHA256 (ansible-2.3.1.0.tar.gz) = cd4b8f53720fcd0c351156b840fdd15ecfbec22c951b5406ec503de49d40b9f5
+SIZE (ansible-2.3.1.0.tar.gz) = 4263357
diff --git a/sysutils/ansible/files/extra-patch-f82d95a b/sysutils/ansible/files/extra-patch-f82d95a
deleted file mode 100644
index 53e239a04974..000000000000
--- a/sysutils/ansible/files/extra-patch-f82d95a
+++ /dev/null
@@ -1,23 +0,0 @@
-From f82d95ae288cccae8245236e4d7e6188f0a7d389 Mon Sep 17 00:00:00 2001
-From: Matt Martz <matt@sivel.net>
-Date: Tue, 18 Apr 2017 11:34:07 -0500
-Subject: [PATCH] When become_method is su, self._play_context.prompt is a
- function. Fixes #23689
-
----
- lib/ansible/plugins/connection/__init__.py | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/lib/ansible/plugins/connection/__init__.py b/lib/ansible/plugins/connection/__init__.py
-index 8a94d6e..6ba4aa2 100644
---- lib/ansible/plugins/connection/__init__.py
-+++ lib/ansible/plugins/connection/__init__.py
-@@ -258,6 +258,8 @@ def check_password_prompt(self, b_output):
- if not b_lines:
- return False
- return b_lines[-1].strip().endswith(b_prompt) or b_lines[0].strip().endswith(b_prompt)
-+ else:
-+ return self._play_context.prompt(b_output)
-
- def check_incorrect_password(self, b_output):
- b_incorrect_password = to_bytes(gettext.dgettext(self._play_context.become_method, C.BECOME_ERROR_STRINGS[self._play_context.become_method]))