aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-07-29 14:10:36 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-07-29 14:10:36 +0000
commite809a4a93b58334a393fc98707c9e831bcd111b2 (patch)
tree90234be56370127d0002893118959f6a0e2c291b /sysutils/ansible
parent015949a885a71c8c69e6184171a2e8fdb5ede440 (diff)
downloadports-e809a4a93b58334a393fc98707c9e831bcd111b2.tar.gz
ports-e809a4a93b58334a393fc98707c9e831bcd111b2.zip
Notes
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile5
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/extra-patch-b5e012b29
3 files changed, 4 insertions, 36 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 52de7ba2d4b0..1a943a7fdf3c 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION?= 2.1.0.0
-PORTREVISION?= 1
+PORTVERSION?= 2.1.1.0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -18,8 +17,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
-EXTRA_PATCHES?= ${FILESDIR}/extra-patch-b5e012b
-
NO_ARCH= yes
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 9c8d7bbae135..c56f87c36502 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464277776
-SHA256 (ansible-2.1.0.0.tar.gz) = 403443b55f6522cf86f9b41544a9b6b81f7d27f088446e85334d5d7a6317ccad
-SIZE (ansible-2.1.0.0.tar.gz) = 1877209
+TIMESTAMP = 1469792931
+SHA256 (ansible-2.1.1.0.tar.gz) = 61e739c123923ba90169f42c54e5f51df759ed40b4e332a7160d7db963d5678b
+SIZE (ansible-2.1.1.0.tar.gz) = 1844349
diff --git a/sysutils/ansible/files/extra-patch-b5e012b b/sysutils/ansible/files/extra-patch-b5e012b
deleted file mode 100644
index 1d83c2233a59..000000000000
--- a/sysutils/ansible/files/extra-patch-b5e012b
+++ /dev/null
@@ -1,29 +0,0 @@
-commit b5e012b47fa9e242a38c3f66678aa2f47946a9c9
-Author: Dmitry Marakasov <amdmi3@amdmi3.ru>
-Date: Thu May 26 17:37:28 2016 +0300
-
- Fix crontab argument order for writing
-
- Currently, when writing user's crontab, ansible calls
-
- crontab <file> -u <user>
-
- This is incorrect according to crontab(1) on both FreeBSD and Linux,
- which suggest that file argument should be the last.
-
- At least on FreeBSD, this leads to incorrect cron module bahavior which
- writes to root's crontab instead of users's
-
-diff --git system/cron.py system/cron.py
-index ab97606..b9f0940 100644
---- lib/ansible/modules/core/system/cron.py
-+++ lib/ansible/modules/core/system/cron.py
-@@ -488,7 +488,7 @@ class CronTab(object):
- return "chown %s %s ; su '%s' -c '%s %s'" % (pipes.quote(self.user), pipes.quote(path), pipes.quote(self.user), CRONCMD, pipes.quote(path))
- else:
- user = '-u %s' % pipes.quote(self.user)
-- return "%s %s %s" % (CRONCMD , pipes.quote(path), user)
-+ return "%s %s %s" % (CRONCMD , user, pipes.quote(path))
-
-
-