aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ansible
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-04-12 15:51:13 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-04-12 15:51:13 +0000
commited84edccde8bff0e823df2474d73d7b9210f3f95 (patch)
treedbf9feb93fd6589867144dcdf07442c839b4e9ea /sysutils/ansible
parentcd3a45672c21219dc64d413124fd81102c0039b6 (diff)
downloadports-ed84edccde8bff0e823df2474d73d7b9210f3f95.tar.gz
ports-ed84edccde8bff0e823df2474d73d7b9210f3f95.zip
Notes
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile22
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/pkg-message.in15
3 files changed, 15 insertions, 28 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 36271307f0b9..a54b3bc285cb 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION?= 2.2.2.0
+PORTVERSION?= 2.3.0.0
PORTREVISION?= 0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -16,21 +16,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr
NO_ARCH= yes
-USES?= cpe python shebangfix
+USES?= cpe python
USE_PYTHON= autoplist distutils
-python_CMD= ${LOCALBASE}/bin/python
-SHEBANG_FILES+= lib/ansible/modules/core/*/*.py \
- lib/ansible/modules/core/*/*/*.py \
- lib/ansible/modules/extras/*/*.py \
- lib/ansible/modules/extras/*/*/*.py
CPE_VENDOR= ansibleworks
SUB_FILES= pkg-message
+SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
-PLIST_FILES+= man/man1/ansible-doc.1.gz \
+PLIST_FILES+= man/man1/ansible-console.1.gz \
+ man/man1/ansible-doc.1.gz \
man/man1/ansible-galaxy.1.gz \
man/man1/ansible-playbook.1.gz \
man/man1/ansible-pull.1.gz \
@@ -39,11 +37,7 @@ PLIST_FILES+= man/man1/ansible-doc.1.gz \
PORTEXAMPLES= ansible.cfg hosts
-OPTIONS_DEFINE= DOCS EXAMPLES NETADDR
-OPTIONS_DEFAULT=NETADDR
-
-NETADDR_DESC= Dependency on py-netaddr for ipaddr() filter
-NETADDR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
.for f in bin/ansible docs/man/man1/* examples/* lib/ansible/*.py \
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 9d667baab5e8..a3137e184ca3 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490707549
-SHA256 (ansible-2.2.2.0.tar.gz) = efd9c574168ac1916dd57f7c88d4dd2e13ef816af0ee49a8d34c77567886e4c2
-SIZE (ansible-2.2.2.0.tar.gz) = 2510182
+TIMESTAMP = 1492010911
+SHA256 (ansible-2.3.0.0.tar.gz) = 299f3907cd566a20e163942fa82b6afc86ef89c2726ba503b90c1a651e82a458
+SIZE (ansible-2.3.0.0.tar.gz) = 4251730
diff --git a/sysutils/ansible/files/pkg-message.in b/sysutils/ansible/files/pkg-message.in
index ef541fdaa198..c94524d97dbc 100644
--- a/sysutils/ansible/files/pkg-message.in
+++ b/sysutils/ansible/files/pkg-message.in
@@ -8,22 +8,15 @@ host database and a sample configuration file:
%%EXAMPLESDIR%%/ansible.cfg
To use Ansible to control FreeBSD hosts, you need to
-install the lang/python package on remote machines.
-
-To use Ansible to control systems other than FreeBSD,
-set the Python interpreter in the host database for
-that system. Example:
+install the lang/python package on remote machines
+and set up a path to the python interpreter. Example:
[freebsd]
host1
host2
- [centos]
- host3
- host4
-
- [centos:vars]
- ansible_python_interpreter=/usr/bin/python
+ [freebsd:vars]
+ ansible_python_interpreter=%%PYTHON_CMD%%
Python notes: