aboutsummaryrefslogtreecommitdiff
path: root/sysutils/anvil
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-08-11 19:17:47 +0000
committerDan Langille <dvl@FreeBSD.org>2017-08-11 19:17:47 +0000
commitcba2760d64c7979c20d60e27aa0078426cc12b67 (patch)
tree95d34ad6898e07a804bc837d7cc8fc58e09dd261 /sysutils/anvil
parentfeeb5a15e8d042f3cc92040e2284ded3cc159b85 (diff)
downloadports-cba2760d64c7979c20d60e27aa0078426cc12b67.tar.gz
ports-cba2760d64c7979c20d60e27aa0078426cc12b67.zip
Add options to install wget or curl as run-time dependencies
Notes
Notes: svn path=/head/; revision=447788
Diffstat (limited to 'sysutils/anvil')
-rw-r--r--sysutils/anvil/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/sysutils/anvil/Makefile b/sysutils/anvil/Makefile
index 70756a165ea3..b3362ff0330b 100644
--- a/sysutils/anvil/Makefile
+++ b/sysutils/anvil/Makefile
@@ -2,6 +2,7 @@
PORTNAME= anvil
PORTVERSION= 0.0.10
+PORTREVISON= 1
CATEGORIES= sysutils
MAINTAINER= dvl@FreeBSD.org
@@ -19,6 +20,16 @@ SUB_FILES+= cert-shifter.conf.sample cert-puller.conf.sample pkg-install pkg-mes
NO_BUILD= yes
+OPTIONS_SINGLE= SG1
+OPTIONS_SINGLE_SG1= FETCH CURL WGET
+OPTIONS_DEFAULT= FETCH
+FETCH_DESC= Use fetch
+CURL_DESC= Use curl, not fetch
+WGET_DESC= Use wget, not fetch
+
+CURL_RUN_DEPENDS= curl:ftp/curl
+WGET_RUN_DEPENDS= wget:ftp/wget
+
do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${MKDIR} ${STAGEDIR}/var/db/anvil