aboutsummaryrefslogtreecommitdiff
path: root/sysutils/apcupsd
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-09-04 23:39:38 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-09-04 23:39:38 +0000
commit5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3 (patch)
tree5fabcc634cecf93be203c8148aa87c49a54dee8d /sysutils/apcupsd
parentf52117b52944f049bdcf74db61c4f89a54cd7b68 (diff)
downloadports-5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3.tar.gz
ports-5158fdadabc0e2db1f8b1cd8a7d456bc999d83d3.zip
sysutils/apcupsd: Add patch to fix APC BE600M1 reporting
Patch not enabled as default (initially), so we can have more users testing it. PR: 249041 Submitted by: Derek Schrock <dereks@lifeofadishwasher.com> Differential Revision: https://reviews.freebsd.org/D26259
Notes
Notes: svn path=/head/; revision=547577
Diffstat (limited to 'sysutils/apcupsd')
-rw-r--r--sysutils/apcupsd/Makefile7
-rw-r--r--sysutils/apcupsd/files/extra-patch-usb-reporting51
-rw-r--r--sysutils/apcupsd/files/pkg-message.in4
3 files changed, 60 insertions, 2 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 93f9b130241f..7e9bf9df70b1 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apcupsd
PORTVERSION= 3.14.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20Stable/${PORTVERSION}
@@ -31,7 +31,7 @@ CONFLICTS_INSTALL= apcctrl
OPTIONS_DEFINE= APCDUMB_DRV APCSMART_DRV CGI CLIENT_ONLY GAPCMON MODBUS \
MODBUS_USB PCNET_DRV SHUTDOWN_POWEROFF SNMP_DRV SNMP_DRV_OLD \
- TCP_WRAPPERS TEST_DRV USB_DRV
+ TCP_WRAPPERS TEST_DRV USB_DRV USB_REPORTING
OPTIONS_DEFAULT= APCDUMB_DRV APCSMART_DRV MODBUS MODBUS_USB PCNET_DRV \
SNMP_DRV TCP_WRAPPERS USB_DRV
OPTIONS_SUB= yes
@@ -50,6 +50,7 @@ SNMP_DRV_OLD_DESC= Old SNMP driver support
TCP_WRAPPERS_DESC= ${LIBWRAP_DESC}
TEST_DRV_DESC= Test driver support
USB_DRV_DESC= USB driver support
+USB_REPORTING_DESC= Experimental patch for faulty USB reporting
APCDUMB_DRV_CONFIGURE_ENABLE= dumb
APCSMART_DRV_CONFIGURE_ENABLE= apcsmart
@@ -75,6 +76,8 @@ TCP_WRAPPERS_CONFIGURE_WITH= libwrap=yes
TEST_DRV_CONFIGURE_ENABLE= test
USB_DRV_CONFIGURE_ENABLE= usb
+USB_REPORTING_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-usb-reporting
+
.include <bsd.port.options.mk>
post-patch-SHUTDOWN_POWEROFF-on:
diff --git a/sysutils/apcupsd/files/extra-patch-usb-reporting b/sysutils/apcupsd/files/extra-patch-usb-reporting
new file mode 100644
index 000000000000..b926c5b10db9
--- /dev/null
+++ b/sysutils/apcupsd/files/extra-patch-usb-reporting
@@ -0,0 +1,51 @@
+--- include/HidUps.h.orig 2015-02-08 18:00:05 UTC
++++ include/HidUps.h
+@@ -107,6 +107,7 @@ class HidUps (private)
+ /* Fetch a descriptor from an interface (as opposed to from the device) */
+ int GetIntfDescr(
+ unsigned char type, unsigned char index, void *buf, int size);
++ int GetIntfDescrLength(unsigned char index);
+
+ bool init_device(struct usb_device *dev, const char *serno);
+
+--- src/libusbhid/HidUps.cpp.orig 2015-02-08 18:00:05 UTC
++++ src/libusbhid/HidUps.cpp
+@@ -244,6 +244,26 @@ int HidUps::GetIntfDescr(
+ (type << 8) + index, 0, (char*)buf, size, 1000);
+ }
+
++/* Get the interface descriptor's length */
++int HidUps::GetIntfDescrLength(unsigned char index)
++{
++ /* usb_hid_descriptor */
++ char buf[9];
++ memset(buf, 0, sizeof(buf));
++ int ret = usb_control_msg(_fd, USB_ENDPOINT_IN | USB_RECIP_INTERFACE,
++ USB_REQ_GET_DESCRIPTOR,
++ (USB_DT_HID << 8) + index, 0, (char*)buf, sizeof(buf), 1000);
++
++ int len = MAX_SANE_DESCRIPTOR_LEN;
++ if (ret >= 0) {
++ /* wDescriptorLength */
++ int desclen = buf[7] | (buf[8] << 8);
++ if (desclen > 0)
++ len = desclen;
++ }
++ return len;
++}
++
+ /*
+ * Fetch the report descriptor from the device given an _fd for the
+ * device's control endpoint. Descriptor length is written to the
+@@ -255,8 +275,9 @@ unsigned char *HidUps::FetchReportDescr(int *rlen)
+ unsigned char *ptr;
+ int rdesclen;
+
+- ptr = (unsigned char*)malloc(MAX_SANE_DESCRIPTOR_LEN);
+- rdesclen = GetIntfDescr(USB_DT_REPORT, 0, ptr, MAX_SANE_DESCRIPTOR_LEN);
++ int desclen = GetIntfDescrLength(0);
++ ptr = (unsigned char*)malloc(desclen);
++ rdesclen = GetIntfDescr(USB_DT_REPORT, 0, ptr, desclen);
+ if (rdesclen <= 0) {
+ Dmsg(100, "Unable to get REPORT descriptor (%d).\n", rdesclen);
+ free(ptr);
diff --git a/sysutils/apcupsd/files/pkg-message.in b/sysutils/apcupsd/files/pkg-message.in
index 6af80aada141..a9ce5b4d036e 100644
--- a/sysutils/apcupsd/files/pkg-message.in
+++ b/sysutils/apcupsd/files/pkg-message.in
@@ -18,6 +18,10 @@ For default, apcupsd starts with `--kill-on-powerfail` parameter.
Please, read its man page, and if this is not the intended behavior you want,
change it accordingly.
+If connected via USB and apcaccess reports incomplete data consider enabling
+the USB_REPORTING options via 'make config'. This contains an experimental
+patch that may fix some USB attach APC UPS. PR #249041
+
In some systems where the shutdown can take a while (like in bhyve environment),
you may want to change this behavior as follows: