aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ataidle
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-02-07 04:37:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-02-07 04:37:48 +0000
commit6dbf63cf4ee004b7466dd9239b53e14a07bb6206 (patch)
tree5aadfe9dfcca0728e21d9e707fcff8b360f9d0dc /sysutils/ataidle
parentdd712b0fec0438734081f29299e8f1cab2e79b4e (diff)
downloadports-6dbf63cf4ee004b7466dd9239b53e14a07bb6206.tar.gz
ports-6dbf63cf4ee004b7466dd9239b53e14a07bb6206.zip
Notes
Diffstat (limited to 'sysutils/ataidle')
-rw-r--r--sysutils/ataidle/Makefile12
-rw-r--r--sysutils/ataidle/distinfo6
-rw-r--r--sysutils/ataidle/files/ataidle.in25
-rw-r--r--sysutils/ataidle/pkg-message14
4 files changed, 39 insertions, 18 deletions
diff --git a/sysutils/ataidle/Makefile b/sysutils/ataidle/Makefile
index a18bfde85b50..3aa35d2e97e0 100644
--- a/sysutils/ataidle/Makefile
+++ b/sysutils/ataidle/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ataidle
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 2.3
CATEGORIES= sysutils
MASTER_SITES= http://www.cran.org.uk/bruce/software/
@@ -16,7 +15,7 @@ COMMENT= Utility to spin down ATA drives
USE_RC_SUBR= ${PORTNAME}
MAN8= ataidle.8
-PORTDOCS= COPYING ChangeLog README
+PORTDOCS= COPYING Changelog README
PLIST_FILES= sbin/ataidle
do-install:
@@ -27,10 +26,13 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501105
-IGNORE= requires FreeBSD 5.2 or newer
+.if ${OSVERSION} < 600034
+IGNORE= requires FreeBSD 6.1 or newer
.endif
.include <bsd.port.post.mk>
diff --git a/sysutils/ataidle/distinfo b/sysutils/ataidle/distinfo
index ec11d759074c..7a189a1677bb 100644
--- a/sysutils/ataidle/distinfo
+++ b/sysutils/ataidle/distinfo
@@ -1,3 +1,3 @@
-MD5 (ataidle-1.0.tar.gz) = 2d5a49587f8b42042eff4408c2cb6f7d
-SHA256 (ataidle-1.0.tar.gz) = 5b9a853e00c7d7a925f05ddacb555d1e21cfb875c0a0809e2609a0382c5683e5
-SIZE (ataidle-1.0.tar.gz) = 14182
+MD5 (ataidle-2.3.tar.gz) = cce9d298fa83aeab7bda4c9db8372a97
+SHA256 (ataidle-2.3.tar.gz) = 2ddb3688e47b6a60855ac0ae60390d1f415357f478252953557c6948a0fb6e98
+SIZE (ataidle-2.3.tar.gz) = 12504
diff --git a/sysutils/ataidle/files/ataidle.in b/sysutils/ataidle/files/ataidle.in
index 7464d0faea19..dc3e72f1e8c4 100644
--- a/sysutils/ataidle/files/ataidle.in
+++ b/sysutils/ataidle/files/ataidle.in
@@ -8,19 +8,19 @@
#
# ataidle_enable (bool): set to NO by default.
# Set to YES to enable ataidle.
-# ataidle_device: list of devices on which to run ataidle
+# ataidle_devices: list of devices on which to run ataidle
# ataidle_adX: parameters to pass to ataidle(8)
# Example:
-# Put the disks ad1, ad2 and ad3 into Idle mode after 60
+# Put the disks ad0, ad1 and ad2 into Idle mode after 60
# minutes and Standby mode after 120 minutes. Also, set the
# AAM and APM values to their maximum so the drives run at
# their maximum performance.
#
-# ataidle_device="ad1 ad2 ad3"
-# ataidle_ad1="-I 60 -S 120 -A 127 -P 254 0 1"
-# ataidle_ad2="-I 60 -S 120 -A 127 -P 254 1 0"
-# ataidle_ad3="-I 60 -S 120 -A 127 -P 254 1 1"
+# ataidle_devices="ad0 ad1 ad2"
+# ataidle_ad0="-I 60 -S 120 -A 127 -P 254"
+# ataidle_ad1="-I 60 -S 120 -A 127 -P 254"
+# ataidle_ad2="-I 60 -S 120 -A 127 -P 254"
#
. %%RC_SUBR%%
@@ -37,13 +37,18 @@ load_rc_config $name
ataidle_start()
{
- if [ -n "${ataidle_device}" ]; then
- for i in ${ataidle_device}; do
+ if [ -n "${ataidle_device}" -a -z "${ataidle_devices}" ]; then
+ echo "warning: old ataidle rc settings found"
+ ataidle_devices=${ataidle_device}
+ fi
+
+ if [ -n "${ataidle_devices}" ]; then
+ for i in ${ataidle_devices}; do
eval ataidle_args=\$ataidle_${i}
- ${command} ${ataidle_args}
+ echo "ATAidle: configuring device /dev/${i}"
+ ${command} ${ataidle_args} /dev/${i}
done
fi
}
run_rc_command "$1"
-
diff --git a/sysutils/ataidle/pkg-message b/sysutils/ataidle/pkg-message
new file mode 100644
index 000000000000..87f090d05124
--- /dev/null
+++ b/sysutils/ataidle/pkg-message
@@ -0,0 +1,14 @@
+Note: ataidle options and rc startup settings
+ have changed in version 2.
+
+Add the following lines to /etc/rc.conf to enable ataidle:
+
+ataidle_enable (bool): set to NO by default.
+ Set to YES to enable ataidle.
+ataidle_devices: list of devices on which to run ataidle
+ataidle_adX: parameters to pass to ataidle(8)
+
+Example:
+ataidle_enable="YES"
+ataidle_devices="ad0"
+ataidle_ad0="-I 60 -S 120 -A 127 -P 254"