aboutsummaryrefslogtreecommitdiff
path: root/sysutils/atop
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-07-04 07:50:42 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-07-04 07:50:42 +0000
commit00e1554b925f966f5aa6ac04381aacf4c408ef6e (patch)
tree638b94dbbfdddaec443c82e2c1ef9e74872a9fbc /sysutils/atop
parente35a1d39daca754a10f384ded99723ee21b4be1c (diff)
downloadports-00e1554b925f966f5aa6ac04381aacf4c408ef6e.tar.gz
ports-00e1554b925f966f5aa6ac04381aacf4c408ef6e.zip
Change to REQUIRE: LOGIN, and remove a default empty variable assignment [1]
While I'm here, perform a few other should-be-noop cleanups Approved by: maintainer [1]
Notes
Notes: svn path=/head/; revision=277032
Diffstat (limited to 'sysutils/atop')
-rw-r--r--sysutils/atop/Makefile1
-rw-r--r--sysutils/atop/files/atop.in30
2 files changed, 15 insertions, 16 deletions
diff --git a/sysutils/atop/Makefile b/sysutils/atop/Makefile
index 152f96773ed2..10ed6863fc53 100644
--- a/sysutils/atop/Makefile
+++ b/sysutils/atop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= atop
PORTVERSION= 1.26.b4
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR=atop-freebsd
diff --git a/sysutils/atop/files/atop.in b/sysutils/atop/files/atop.in
index e60987c2a86f..3b7aeca851ba 100644
--- a/sysutils/atop/files/atop.in
+++ b/sysutils/atop/files/atop.in
@@ -1,25 +1,32 @@
#!/bin/sh
-# $FreeBSD$
+# $FreeBSD$
+#
# PROVIDE: atop
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
+# REQUIRE: LOGIN
# KEYWORD: shutdown
-
+#
# Define these atop_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/atop
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-atop_enable="${atop_enable-NO}"
-atop_pidfile="/var/run/atop.pid"
. /etc/rc.subr
name="atop"
rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${atop_enable:=NO}
+: ${atop_logdir="%%LOGDIR%%"}
+: ${atop_interval=10}
+: ${atop_keepdays=30}
+
+pidfile="${atop_pidfile:-'/var/run/atop.pid'}"
+
command="%%PREFIX%%/bin/atop"
extra_commands="rotate"
start_cmd="atop_start"
@@ -46,13 +53,4 @@ atop_rotate()
run_rc_command "restart"
}
-load_rc_config $name
-
-: ${atop_logdir="%%LOGDIR%%"}
-: ${atop_interval=10}
-: ${atop_keepdays=30}
-: ${atop_flags=""}
-
-pidfile="${atop_pidfile}"
-
run_rc_command "$1"