aboutsummaryrefslogtreecommitdiff
path: root/sysutils/atop
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2019-10-19 18:52:25 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2019-10-19 18:52:25 +0000
commit0c67e155dcc80ae97126ae4d9070750993d6f4e6 (patch)
treef205d5f886560d08d265140965fe468d7396f794 /sysutils/atop
parenta06276becd399f32710f379901747e70419fa79a (diff)
downloadports-0c67e155dcc80ae97126ae4d9070750993d6f4e6.tar.gz
ports-0c67e155dcc80ae97126ae4d9070750993d6f4e6.zip
sysutils/atop: a function pointer was called with incorrect number of argument
PR: 239586 Submitted by: msl0000023508@gmail.com Approved by: krion (mentor) Differential Revision: https://reviews.freebsd.org/D22090
Notes
Notes: svn path=/head/; revision=514824
Diffstat (limited to 'sysutils/atop')
-rw-r--r--sysutils/atop/Makefile5
-rw-r--r--sysutils/atop/files/patch-atop.c12
2 files changed, 15 insertions, 2 deletions
diff --git a/sysutils/atop/Makefile b/sysutils/atop/Makefile
index 60558a9249e8..7fa8662b57e3 100644
--- a/sysutils/atop/Makefile
+++ b/sysutils/atop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= atop
PORTVERSION= 2.0.2.b3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MAINTAINER= samm@freebsd.org
@@ -11,12 +11,13 @@ COMMENT= ASCII Monitor for system resources and process activity
LICENSE= GPLv2
+USES= ncurses
+
USE_GITHUB= yes
GH_ACCOUNT= samm-git
GH_PROJECT= atop-freebsd
GH_TAGNAME= ${PORTNAME}-${PORTVERSION:C|b|fbsd.beta|}
-USES= ncurses
MAKEFILE= BSDmakefile
LOGDIR?= /var/log/atop
PLIST_SUB+= LOGDIR="${LOGDIR}"
diff --git a/sysutils/atop/files/patch-atop.c b/sysutils/atop/files/patch-atop.c
new file mode 100644
index 000000000000..3d736de7d626
--- /dev/null
+++ b/sysutils/atop/files/patch-atop.c
@@ -0,0 +1,12 @@
+--- atopsar.c.orig 2014-01-16 00:05:34 UTC
++++ atopsar.c
+@@ -600,7 +600,8 @@
+ */
+ printf("%s ", convtime(curtime, timebuf));
+
+- if ( !(rv = (pridef[i].priline)(ss, (struct tstat *)0, 0,
++ if ( !(rv = (pridef[i].priline)(ss, (struct tstat *)0,
++ (struct tstat **)0, 0,
+ numsecs, numsecs*hertz, hertz,
+ osvers, osrel, ossub,
+ stampalways ? timebuf : " ",